Audio Device changes after reboot (XMOS WaveIO Board)

Cubietruck related support

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 27 Jan 2016, 22:37

i tried /etc/asound.conf and changed the command to card three, which is the Xmos/USB Device.

"ctl.!default {
type hw
card 1
}

pcm.!default {
type hw
card 1
}"

Now it dont changes the output on reeboot - but it takes about two minutes for startup from the nand/
Can i expect the WaveIO to work right this way? Or is there anythimg i did not think of?

Best regards
Daniel
Last edited by Guitarfreak on 28 Jan 2016, 11:48, edited 1 time in total.
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby hondagx35 » 27 Jan 2016, 22:51

Hi Daniel,

please try to make mpd.conf readonly:
chmod 444 /etc/mpd.conf


Please post the output from:
Code: Select all
redis-cli get ao

and
Code: Select all
aplay -l

Your USB dac should be enabled before doing this.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 28 Jan 2016, 07:43

Hello Frank,

should i revert my recent changes before doing the read only thing?

I testet yesterday several times and with my latest changes (see my last post) the Audio Output does not change anymore after reboot.

Best regards

Daniel
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby hondagx35 » 28 Jan 2016, 12:33

Hi Daniel,

should i revert my recent changes before doing the read only thing?

Yes, i would do it this way.

Frank
User avatar
hondagx35
 
Posts: 3039
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Audio Device changes after reboot (XMOS WaveIO Board)

Postby Guitarfreak » 28 Jan 2016, 18:54

Hello Frank,

funny thing is: after redoing my last changes the Xmos sill seems to work.

[root@runeaudio ~]# redis-cli get ao
"Luckit USB Audio 2.0"
[root@runeaudio ~]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: sunxicodec [sunxi-CODEC], device 0: M1 PCM [sunxi PCM]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sunxisndspdif [sunxi-sndspdif], device 0: SUNXI-SPDIF sndspdif-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: sunxisndi2s [sunxi-sndi2s], device 0: SUNXI-I2S sndi2s-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 3: L20 [Luckit USB Audio 2.0], device 0: USB Audio [USB Audio]
Subdevices: 0/1
Subdevice #0: subdevice #0
[root@runeaudio ~]#
Guitarfreak
 
Posts: 14
Joined: 13 Dec 2015, 16:34

support RuneAudio Donate with PayPal

Previous

Return to Cubietruck

Who is online

Users browsing this forum: No registered users and 0 guests