Very very slow startup WebUI RuneAudio

Raspberry Pi related support

Very very slow startup WebUI RuneAudio

Postby votya4ok » 25 Feb 2017, 10:27

Hello.
I have installed RuneAudio_rpi2_rp3_0.4-beta_20160321_2GB.img.gz on my RPI 2. All's good, but webUI (RuneUI) is very slow startup - after 95 seconds!

Code: Select all
# systemd-analyze
Startup finished in 4.444s (kernel) + 1min 31.333s (userspace) = 1min 35.778s


I made graph.svf (at attachmnet).
What's wrong?

My hardware: Raspberry Pi2, MicroSD Sandisk ExtremePro 8GB, wired static connection. USB DAC and USB HDD with music not connected now.

Also i tried Volumio and Moodaudio - all two startup after 20-25 seconds.

My Debug info:
http://pastebin.com/LwJ1C7dX
Attachments
graph.rar
(9.19 KiB) Downloaded 19 times
votya4ok
 
Posts: 2
Joined: 25 Feb 2017, 09:58

Re: Very very slow startup WebUI RuneAudio

Postby votya4ok » 25 Feb 2017, 12:23

It seems that I has found a solution at this forum (Thanks to Frank).
I do not have wi-fi dongle, only a wired network.
Need to do:
Code: Select all
systemctl disable netctl-auto@wlan0

and reboot.

And now i have:
Code: Select all
# systemd-analyze
Startup finished in 3.746s (kernel) + 3.767s (userspace) = 7.513s


Excellent!
votya4ok
 
Posts: 2
Joined: 25 Feb 2017, 09:58

Re: Very very slow startup WebUI RuneAudio

Postby adamk » 18 Jun 2017, 16:03

Hello! I just updated to the latest beta and am trying to get things set up properly.

I am also having very very slow startup, and then also very slow interactive use on the WebUI (as in, clicking around is extremely slow).

Any help would be extremely welcome! (I also am only using the wired interface, not wireless).

Code: Select all
root@rune(rw):~# systemd-analyze
Startup finished in 4.762s (kernel) + 1min 30.798s (userspace) = 1min 35.560s


Here is my debug info:

https://pastebin.com/4yBQ5FFK

Then, looking in my journalctl output, looks like a lot of seconds are wasted in this area:
Feb 22 15:40:25 rune ifplugd[272]: Program executed successfully.
Feb 22 15:40:25 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:26 rune ntpd[341]: Listen normally on 2 eth0 192.168.1.253:123
Feb 22 15:40:26 rune ntpd[341]: new interface(s) found: waking up resolver
Feb 22 15:40:28 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:31 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:34 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:37 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:38 rune sshd[432]: Accepted password for root from 192.168.1.153 port 50274 ssh2
Feb 22 15:40:38 rune sshd[432]: pam_unix(sshd:session): session opened for user root by (uid=0)
Feb 22 15:40:38 rune dbus[280]: [system] Activating via systemd: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Feb 22 15:40:38 rune dbus[280]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.login1.service': Unit systemd-logind.service is masked.
Feb 22 15:40:38 rune sshd[432]: pam_systemd(sshd:session): Failed to create session: Unit systemd-logind.service is masked.
Feb 22 15:40:40 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:43 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:46 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:49 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:52 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:55 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:40:58 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:01 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:04 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:07 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:10 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:13 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:16 rune kernel: cfg80211: Verifying active interfaces after reg change
Feb 22 15:41:16 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:19 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:22 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
Feb 22 15:41:25 rune rune_PL_wrk[358]: Warning: socket_connect(): unable to connect [2]: No such file or directory in /srv/http/app/libs/runeaudio.php on line 72
adamk
 
Posts: 3
Joined: 29 Dec 2016, 21:39

Re: Very very slow startup WebUI RuneAudio

Postby adamk » 18 Jun 2017, 16:27

Ok, I believe I've solved my own problem. I did:

Code: Select all
systemctl disable netctl-auto@wlan0.service
systemctl disable netctl-ifplugd@eth1.service
reboot


and so

Code: Select all
root@rune(rw):~# systemd-analyze
Startup finished in 4.210s (kernel) + 4.329s (userspace) = 8.540s


In the interest of "teaching a man to fish", can someone explain what the problem was here and why this solved it?
adamk
 
Posts: 3
Joined: 29 Dec 2016, 21:39

Re: Very very slow startup WebUI RuneAudio

Postby hondagx35 » 18 Jun 2017, 17:36

Hi adamk,

In the interest of "teaching a man to fish", can someone explain what the problem was here and why this solved it?

Networking is done with "netctl service" and "services" are controlled by systemd on RuneAudio.

Rune tries to start the network as soon as possible, to get quick start-up.
If you do not have a wifi dongle installed Rune is paused until the service times out.
To disable the service you have to run this command once.
Code: Select all
systemctl disable netctl-auto@wlan0.service


Code: Select all
systemctl disable netctl-ifplugd@eth1.service

The same for the second ethernet port.
This command should be needless because it is not available and is not enabled on the Pi.

BTW: wlan0 should be disabled by default and only gets enabled when you plug in a wifi dongle.

Frank
User avatar
hondagx35
 
Posts: 2797
Joined: 11 Sep 2014, 22:06
Location: Germany

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 4 guests