Support for: 7″ Touchscreen Monitor for Raspberry Pi

Suggestions/requests/ideas for RuneAudio core features and functions

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby Syco54645 » 23 Jun 2016, 05:42

Hello Frank,

I am having a bit of trouble with my eGalax touch screen. The default drivers are working however the touch is inverted. xinput_calibrator would work (which I know you say it is installed by default but I can assure you that it is not, at least not in v0.3-beta(23/03/2016) rpi2. paste below to show that). Anyway I am new to arch and am having trouble installing xf86-input-egalax through pacman. Is there some special way to install it? The info I am pulling is from https://wiki.archlinux.org/index.php/Mu ... ys#Drivers.

Thanks

-Another Frank

Code: Select all
[root@runeaudio eGTouch_v2.5.5814.L-x]# xinput_calibrator
-bash: xinput_calibrator: command not found
[root@runeaudio eGTouch_v2.5.5814.L-x]# pacman -S xinput_calibrator
resolving dependencies...
looking for conflicting packages...

Packages (1) xinput_calibrator-0.7.5.r88.g03dadf5-1

Total Download Size:   0.04 MiB
Total Installed Size:  0.19 MiB

:: Proceed with installation? [Y/n]


Edit: Never mind, I figured it out. Completely broke touch screen support. Will start fresh next time and just figure out a way to use xinput_calibrator
Syco54645
 
Posts: 1
Joined: 23 Jun 2016, 05:37

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby vanilla8 » 02 Jul 2016, 21:17

I have a IQAudio Digi-Amp DAC, which I have managed to unmute manually, is there a way to run this on every startup/can you add to your image?

I've tried adding this and in /etc/rc.local

Code: Select all
echo "22" > /sys/class/gpio/export
echo "out" >/sys/class/gpio/gpio22/direction
echo "1" >/sys/class/gpio/gpio22/value


but this doesn't work and when i reboot i have to log in via putty and execute
Code: Select all
sudo sh -c "echo 22 > /sys/class/gpio/export"
sudo sh -c "echo out >/sys/class/gpio/gpio22/direction"
 sudo sh -c "echo 1 >/sys/class/gpio/gpio22/value"
vanilla8
 
Posts: 2
Joined: 02 Jul 2016, 21:02

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby hondagx35 » 02 Jul 2016, 22:51

Hi vanilla8,

please try this.

Frank
User avatar
hondagx35
 
Posts: 2693
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby vanilla8 » 03 Jul 2016, 10:10

Thanks very much Frank, that solved it :)
vanilla8
 
Posts: 2
Joined: 02 Jul 2016, 21:02

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby AudioplatinumService » 11 Jul 2016, 13:38

Hi,

I am new here, but I read this forum for some time. Here I have 2 Rune players and almost all work great, but..I have one problem with 7" RPi LCD. I try last image for Rune and connect 7" LCD and I find one problem. Let me try explain. When I boot Rune, all is fine, then If I touch lcd several times in one place (I want to turn up volume) after several presses screen go to white, music play, I can access thru web browser but screen is permanent white. I have mouse attached and If I press right mouse key I get menu from Midori browser but I can`t get local browser with Rune UI on LCD without restart. After restart, all is ok.

Any ideas?

Debug info:
http://pastebin.com/CHcticWd

Interface is IQAudio / RaspyPlay4

Best Regards,
Raf,
AudioplatinumService
User avatar
AudioplatinumService
 
Posts: 2
Joined: 11 Jul 2016, 13:22
Location: Zagreb / Croatia

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby hondagx35 » 11 Jul 2016, 15:44

Hi Raf,

all is fine, then If I touch lcd several times in one place (I want to turn up volume) after several presses screen go to white

This is normal, because Midori (the browser used for local display) opens a new tab when you click several times very fast.
I haven't found a solution to disable this. The only way to close this tab is to use CTRL-w with a attached keyboard.

I'm not shure if it is the window manager or midori that causes this problem.

Frank
User avatar
hondagx35
 
Posts: 2693
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby AudioplatinumService » 11 Jul 2016, 18:24

hondagx35 wrote:This is normal, because Midori (the browser used for local display) opens a new tab when you click several times very fast.
I haven't found a solution to disable this. The only way to close this tab is to use CTRL-w with a attached keyboard.

I'm not shure if it is the window manager or midori that causes this problem.

Frank


Hi Frank,

Ok, now I know why I have problem with this. If I find some solution, I will post here.

Regards,
Raf
User avatar
AudioplatinumService
 
Posts: 2
Joined: 11 Jul 2016, 13:22
Location: Zagreb / Croatia

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby Trima » 20 Jul 2016, 10:05

Hi guys,
I'm new at this forum, you did a great job with this GUI!

First of all, I'm new to RPi and quite new to linux, so I'm not an expert at all.

I'm using an RPi 3 with its official 7" Touchscreen monitor (connected to RPi via DSI).
I burned the RuneAudio_rpi2_rp3_0.4-beta_20160321_2GB.img on a 4GB SD and started using the system.

At first sight everything looked to be ok, but I suddenly noticed that I couldn't use my touch...the display works fine on the "graphical" point of view, but I'm not able to control nothing without a mouse.

Can someone help me to understand what I have to do to enable the touch function?

Thanks so much.

BR.
Trima
 
Posts: 1
Joined: 20 Jul 2016, 09:54

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby nicko500 » 25 Jul 2016, 16:25

Touch panel should works with downloaded image, without any setting.
Maybe touch panel flat cable is not correctly connected ?
nicko500
 
Posts: 3
Joined: 13 Apr 2016, 18:39

Re: Support for: 7″ Touchscreen Monitor for Raspberry Pi

Postby sandbox » 27 Sep 2016, 16:15

hondagx35 wrote:Hi Justin,

However, I've run into a bug where several fast taps on the touchscreen will result in a white screen on the RPi.

This is not a bug, it is midori opening a new empty window.
I have to find a way to disable this.
Thanks for reporting.

Frank


Hi Frank, Hi Justin,
I've found out a nice solution to fix this problem:
Edit the /root/.config/midori/config File and change the tabhome default behaviour :
Code: Select all
//...
tabhome=http://localhost
//...

If the webbrowser opens a new tab by "touch-mistake ", it automatically opens the regular webfrontend-url.

@Frank: By the way, it is my first day with this first class project - and i love it :O) !!!!!!! My current environment: Raspi3 + 7" Touchscreen
sandbox
 
Posts: 3
Joined: 27 Sep 2016, 15:35

support RuneAudio Donate with PayPal

PreviousNext

Return to Feature request

Who is online

Users browsing this forum: No registered users and 1 guest