Spotify Connect autostart

Raspberry Pi related support

Re: Spotify Connect autostart

Postby zomtec » 01 Aug 2017, 20:16

Stert wrote:Secondly volume controls do not work as the DAC has no software volume control ...

Have you a solution for the volume control?
zomtec
 
Posts: 15
Joined: 17 Jun 2017, 19:39

Re: Spotify Connect autostart

Postby zomtec » 05 Aug 2017, 20:37

I add
Code: Select all
ExecStartPre=/bin/sleep 25
and then it working.

Code: Select all
[Unit]
Description=Spotify Connect
After=network.target

[Service]
ExecStartPre=/bin/sleep 25
ExecStart=/usr/bin/sh /root/spotify-connect-web.sh --name RuneAudio --username 123 --password xyz --bitrate 320
Restart=always
RestartSec=10
StartLimitInterval=30
StartLimitBurst=20

[Install]
WantedBy=multi-user.target


frakki wrote:Hey guys, ive tried the autostart as well but it isnt working. Nevertheless it seems that the service is starting but not working properly.

if i try to manually run the spotify connect putty gives me this:

Code: Select all
 [root@runeaudio ~]# sudo /root/spotify-connect-web.sh --name Rune --username XXXXXXX --password XXXX --bitrate 320
mount: proc is already mounted or /root/spotify-connect-web-chroot/proc busy
       proc is already mounted on /proc
       proc is already mounted on /root/spotify-connect-web-chroot/proc


If I use

Code: Select all
systemctl stop spotify-connect


and after this the manual method, everything is working.

Does anyone know where the problem is?

Im runnig an rpi3 with pifiberry dac+ and the latest rune0.4 beta
zomtec
 
Posts: 15
Joined: 17 Jun 2017, 19:39

Spotify Connect autostart

Postby gvasco » 19 Aug 2017, 21:38

zomtec wrote:I have problem to install the script.
What is wrong?

What means
./spotify-connect-web.sh: line 9: sudo: command not found

thx

Code: Select all
login as: root
root@192.168.100.39's password:
===============  RuneOS distribution  ===============
  ____                      _             _ _
 |  _ \ _   _ _ __   ___   / \  _   _  __| (_) ___
 | |_) | | | | '_ \ / _ \ / _ \| | | |/ _` | |/ _ \
 |  _ <| |_| | | | |  __// ___ \ |_| | (_| | | (_) |
 |_| \_\\__,_|_| |_|\___/_/   \_\__,_|\__,_|_|\___/

================  www.runeaudio.com  ================
RuneOs: 0.3-beta (build 20141029)
RuneUI: 1.3
Hw-env: RaspberryPi

Last login: Tue Jul 25 20:04:38 2017 from tobias-pc.fritz.box
[root@runeaudio ~]# curl -O http://spotify-connect-web.s3-website.eu-central-1.amazonaws.com/spotify-connect-web.sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   497  100   497    0     0   2730      0 --:--:-- --:--:-- --:--:--  2761
[root@runeaudio ~]# chmod u+x spotify-connect-web.sh
[root@runeaudio ~]# ./spotify-connect-web.sh install
./spotify-connect-web.sh: line 9: sudo: command not found
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0curl: (23) Failed writing body (1232 != 2864)
[root@runeaudio ~]#


You are logged in as root, therefore no need to use sudo command and therefore error you’re experiencing.

Try changing the script using nano to remove “sudo” on the line indicated or login as a regular another user if possible to run the run the script

Edit: Not sure if ArchLinux uses nano but any text edit command utility will do.
gvasco
 
Posts: 8
Joined: 03 May 2016, 17:48

Re: Spotify Connect autostart

Postby tml3nr » 08 Apr 2018, 01:07

zomtec wrote:
Stert wrote:Secondly volume controls do not work as the DAC has no software volume control ...

Have you a solution for the volume control?

If your DAC has hardware volume control. Set '--mixer Digital' in spotify-connect.service. The volume of RuneAudio is linked with the Spotify app.

Image

I wrote a thread about Spotify Connect on RuneAudio:

spotify-connect-on-runeaudio-t6315.html

Many thanks to @Fornoth, @hongdagx35, @Lazerharp, @Stert...
tml3nr
 
Posts: 9
Joined: 02 Apr 2016, 07:43

Re: Spotify Connect autostart

Postby Fabian » 15 Apr 2018, 14:42

zomtec wrote:
Stert wrote:Secondly volume controls do not work as the DAC has no software volume control ...

Have you a solution for the volume control?


First of all: Thank you very much for this wonderful piece of software you make!


I had similar problems with volume control, using RuneAudio v0.3-beta with a Hifiberry AMP+ and Spotify Connect 0.0.4-alpha. Changing the volume in the Spotify App did not change the volume in RuneAudio.

So I made use of the "--device" and "--mixer_device_index" parameters and changed the mixer to "Master".
With "aplay -l" you should be able to recognize the right output device index (--device) and the right sound card index for the mixer (--mixer_device_index). In the "alsamixer" view you can check which sound card is linked to the RuneAudio volume controls and how the mixer is named (usually PCM, Digital or Master)

For my setup it looks like this:
Code: Select all
/root/spotify-connect-web.sh --name RuneAudio --device 1 --mixer_device_index 1 --mixer Master --username abc --password xyz --bitrate 320


Hopefully this will help someone with similar problems I had.


Fabian
Fabian
 
Posts: 3
Joined: 09 Aug 2016, 23:32

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest