RuneAudio 0.5-beta for most Raspberry Pi models

Raspberry Pi related support

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby mattra » 18 Apr 2019, 09:28

I've just checked the diffences between my Runeaudioboven and Runeaudiobeneden.

The one that doesn't connect by name any more is the 'boven' and is Ver. 0.5 build janui-20180903 Linux version 4.14.34-1-ARCH (alarm@alarmpi) (gcc version 7.3.1 20180312 (GCC)) #1 SMP Tue May 15 00:50:02 CDT 2018

The one that still connects normally is Ver. 0.4b build 20170229 Linux version 4.4.39-ARCH+ (frank@franks-ubuntu) (gcc version 4.8.3 20140106 (prerelease) (crosstool-NG linaro-1.13.1-4.8-2014.01 - Linaro GCC 2013.11) ) #5 SMP Sat Feb 11 15:43:36 CET 2017 and doesn't update automatically

So something happened with the 0.5 build... but what?
mattra
 
Posts: 26
Joined: 22 Apr 2016, 13:32

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby janui » 18 Apr 2019, 11:42

Hi mattra,
mattra wrote:So something happened with the 0.5 build... but what?
Could you check that you have the latest patch level for 0.5b (see instructions in the first post in this thread). There were some issues with the original version which are fixed in the latest patch version.
Regardless of the patch version it should always connect with its name for a couple of hours after a reboot. Depending on your client one of the following will work:
Via SSH you can check that the player name actually is is what you think it should be by running the following commands:
Code: Select all
hostname
redis-cli get hostname
avahi-browse -atrkp | grep ';80'
You should be able to see your hostname is all responses (upper and lower case differences are OK). If it appears wrong, change it back to ‘RuneAudio’ in the Settings UI and then change it to your preferred name.
janui
User avatar
janui
 
Posts: 588
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby mattra » 19 Apr 2019, 09:04

Hi Janui,
In runeaudioboven/dev it says 0.5b and it is set to update automatically, so I suppose I have the latest version?

Today I could connect without problem with my client (cantata) but not with my browser (firefox, ubuntu), but after some tries it connected as well... So it's a bit of a hit and miss. Don't know why...
The result of the commands after ssh are
Code: Select all
root@runeaudioboven(rw):~# hostname
runeaudioboven
root@runeaudioboven(rw):~# redis-cli get hostname
"RuneAudioBoven"
root@runeaudioboven(rw):~# avahi-browse -atrkp | grep ';80'
=;wlan0;IPv4;RuneAudio\032\091runeaudioboven\093\032\091b8\05827\058eb\05861\05826\05851\093;_http._tcp;local;runeaudioboven.local;192.168.1.20;80;"runeos_version=0.5-gearhead-janui" "skin_name=RuneUI"

which I suppose is all correct?
mattra
 
Posts: 26
Joined: 22 Apr 2016, 13:32

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby janui » 20 Apr 2019, 17:47

Hi mattra,
mattra wrote:...it says 0.5b and it is set to update automatically, so I suppose I have the latest version?...
We don't have an automatic update feature for the RuneAudio software, there is an automatic update feature for your MPD music library, maybe a misunderstanding… So, could be that you are using an old patch version. The patch version is shown in your debug and in the 'show status' display in the Settings UI. Upgrading is explained in the first post in this thread.
mattra wrote:...which I suppose is all correct?...
Yes, the output looks fine.
janui
User avatar
janui
 
Posts: 588
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby Nim » 21 Apr 2019, 16:59

First of all: Thank you for updating this project! It has given my Rpi3+ something to do again.
My desktop is a tad noisy, so having a quieter option for a music player is a blessing.

Some quirks things I did noticed:
- There's no Hangul support by default, so installing something like
Code: Select all
pacman -S ttf-baekmuk
is a good idea
- USB mounts seem somewhat iffy, every few reboots it seems like MPD can't see the mounted drive, even though I can just safely unmount it.
Nim
 
Posts: 1
Joined: 21 Apr 2019, 16:29

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby R101 » 26 Apr 2019, 16:17

Hi janui,

Is there any chance that 0.5b would work on the Orange Pi3?

The better wifi and the USB3 ports look very attractive.
(Pi 3, Ver. 0.4b build 20170229, JLS I2S over USB)
R101
 
Posts: 208
Joined: 29 Apr 2016, 16:16

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby eze » 27 Apr 2019, 18:40

Hello Janui

Is there away to permanently change the resampler quality from "very high" to "high" in the ssh MPD configuration without effecting the functionality of the GUI MPD configuration page ?
eze
 
Posts: 3
Joined: 13 Apr 2019, 13:33

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby janui » 28 Apr 2019, 11:22

Hi R101,
R101 wrote:Is there any chance that 0.5b would work on the Orange Pi3?
No, at least not without some significant work and testing. Worst case (most likely) is that Rune UI would need to be rebuilt for the specific platform. Best case is that the Orange Pi3 equivalent of the /boot/bcm2837-rpi-3-b.dtb file needs to be copied to /boot/. A couple of tweaks would also be required to identify the hardware type in Rune UI.
janui
User avatar
janui
 
Posts: 588
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby janui » 28 Apr 2019, 11:52

Hi eze,
eze wrote:Is there away to permanently change the resampler quality from "very high" to "high" in the ssh MPD configuration without effecting the functionality of the GUI MPD configuration page ?
Yes, log in via SSH and use this command to see the current setting:
Code: Select all
redis-cli hget mpdconf soxr
To set it to high, use this command:
Code: Select all
redis-cli hset mpdconf soxr 'high'
Then reboot.
To set it back to very high, use this command:
Code: Select all
redis-cli hset mpdconf soxr 'very high'
And reboot.
Other valid values are: ‘medium’, ‘low’ and ‘quick’.
If you use 'reset to default' in the MPD UI it will revert to 'very high'.
janui
User avatar
janui
 
Posts: 588
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for most Raspberry Pi models

Postby mattra » 29 Apr 2019, 08:32

Hi Janui,

Thank you.

Yes, I had still an old patch (-0) and updated it to (-10) now.

I'll see if it makes any difference.

It's a bit of a hit and miss I have the impression, because most times the client and Runeui in firefox connect just fine to the name 'RuneAudioBoven). It's only sometimes... What I've noticed also is that in my modem RuneAudioBoven is listed as Runeaudio-2, which seams strange...

Mattra
mattra
 
Posts: 26
Joined: 22 Apr 2016, 13:32

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest