RPi + Runeaudio +Wifi as Accesspoint

Raspberry Pi related support

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby dror » 25 Oct 2016, 09:19

Hi
Noticed (a while a go) that updating Rune revertes the refresh_nics, so one needs to repaste the lines.
dror
 
Posts: 88
Joined: 03 Dec 2015, 10:14

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby BorGreiner » 14 Nov 2016, 23:02

Followed the instructions. Got it working but... Inbuilt WIFI that identifies itself as Cisco00068 has internet, my other dongle (that I can also connect to) has no internet access. I'd prefer vice versa, as dongle has better range.

Can some help me out here?
BorGreiner
 
Posts: 36
Joined: 30 Oct 2014, 06:37

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby rlsten » 22 Jan 2017, 01:05

I have been unable to get this to work using a Raspberry Pi 3 internal wifi. I started with a fresh installation of the latest image, and then followed Frank's how to from page 2. The results of redis-cli hgetall AccessPoint were:

Code: Select all
1) "enabled"
2) "1"
3) "enable-NAT"
4) "1"
5) "ip-address"
6) "192.168.12.1"
7) "broadcast"
8) "255.255.255.0"
9) "ssid"
10) "RuneAudioAP"
11) "passphrase"
12) "RuneAudio"
13) "dhcp-range"
14) "192.168.12.2,192.168.12.254,24h"
15) "dhcp-option"
16) "option:dns-server,192.168.12.1"


The results of /usr/sbin/hostapd /etc/hostapd/hostapd.conf were:

Code: Select all
Configuration file: /etc/hostapd/hostapd.conf
Failed to initate interface mon.wlan0: -95 (Operation not supported)
wlan0: Could not connect to kernel driver
Using interface wlan0 with hwaddr b8:27:eb:87:8c:51 and ssid "RuneAudioAP
wlan0: interface state UNINITIALIZED->ENABLED
wlan0: AP-ENABLED


When I tried to access the Pi from my Android phone, the RuneAudioAP was visible, but it was unable to obtain an IP address.

When I tried an iPad Pro, it seemed to be connected, but with no internet access; however, there was a continuous spinning and not a check mark for a connection, and the IP address was nowhere near the dhcp range.

Of course I could not connect to Rune at 198.168.12.1.

When I tried the connection I had the /usr/sbin etc. command still running and got the following output:

Code: Select all
wlan0: STA [i]MAC ADDRESS OF MY IPAD[/i] IEEE 802.11:associated
wlan0: AP-STA-CONNECTED STA [i]MAC ADDRESS OF MY IPAD[/i]
wlan0: STA [i]MAC ADDRESS OF MY IPAD[/i] RADIUS: starting accounting session 9FD30F51A234569D5
wlan0: STA [i]MAC ADDRESS OF MY IPAD[/i] WPA: pairwise key handshake completed (RSN)


And then it froze.

Any ideas what I am doing wrong?

Thanks,
Rod
rlsten
 
Posts: 66
Joined: 25 May 2015, 18:06

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests