pi3 and pifi dac+ 2.0 is not working

Everything about Hi-Fi equipment

pi3 and pifi dac+ 2.0 is not working

Postby jonghyun » 25 Dec 2016, 11:25

Dear All.

I have pi3 and pifi dac+ 2.0

i'm tried to set all procedure refer http://www.runeaudio.com/documentation/troubleshooting/rpi-troubleshooting/

but it's not working. anyone can help me?

i tried 2 options.

1. set hifiberry dac : aplay -l show device but can not output sounds.

2. set hifiberry dac plus : aplay -l doesnt show device

please advice.


Code: Select all
###### System info ######
Linux version 4.1.20-1-ARCH (builduser@leming) (gcc version 5.3.0 (GCC) ) #1 SMP Sat Mar 19 20:07:23 MDT 2016

system time:   Sun Dec 25 11:14:12 CET 2016

system load:   0.93 0.31 0.11 1/168 890

HW platform:   RaspberryPi2 (08)

playerID:   08b26fff2ac4ddac6fee7fbbc1890504ae


###### System load statistics (procinfo -H) ######
Memory:        Total        Used        Free     Buffers
RAM:       922.67MiB   285.23MiB   637.44MiB    17.60MiB
Swap:          0.00B       0.00B       0.00B

Bootup: Sun Dec 25 11:13:23 2016   Load average: 0.93 0.31 0.11 1/170 892

user  :   00:00:09.94   5.2%  page in :           170629
nice  :   00:00:09.74   5.1%  page out:             1376
system:   00:00:14.30   7.4%  page act:            11542
IOwait:   00:00:15.76   8.2%  page dea:                0
hw irq:   00:00:00.00   0.0%  page flt:           154804
sw irq:   00:00:00.32   0.2%  swap in :                0
idle  :   00:02:22.28  74.0%  swap out:                0
uptime:   00:00:48.88         context :            70230

irq  16:          0                      irq  65:         19
irq  20:          0                      irq  66:          2
irq  21:          0                      irq  75:          1
irq  29:        311                      irq  77:       3769
irq  31:          1                      irq  82:        128
irq  32:      16692                      irq  84:       5492
irq  49:          0                      irq  96:          0
irq  50:          0                      irq  97:      12773

mmcblk0            3711r                 mmcblk0p2            3613r
mmcblk0p1              59r

eth0        TX 231.80KiB     RX 30.17KiB      wlan0       TX 0.00B         RX 7.67KiB
lo          TX 1.05MiB       RX 1.05MiB


###### Active processes (pstree) ######
systemd-+-2*[agetty]
        |-at-spi-bus-laun-+-dbus-daemon
        |                 |-{dconf worker}
        |                 |-{gdbus}
        |                 `-{gmain}
        |-at-spi2-registr-+-{gdbus}
        |                 `-{gmain}
        |-avahi-daemon---avahi-daemon
        |-cmd_async---sh---sudo---xinit-+-Xorg-+-{llvmpipe-0}
        |                               |      |-{llvmpipe-1}
        |                               |      |-{llvmpipe-2}
        |                               |      `-{llvmpipe-3}
        |                               `-sh-+-matchbox-window
        |                                    `-midori-+-{dconf worker}
        |                                             |-{gdbus}
        |                                             |-{gmain}
        |                                             |-{llvmpipe-0}
        |                                             |-{llvmpipe-1}
        |                                             |-{llvmpipe-2}
        |                                             |-{llvmpipe-3}
        |                                             `-2*[{midori}]
        |-2*[dbus-daemon]
        |-dbus-launch
        |-devmon---udevil
        |-dhcpcd
        |-ifplugd
        |-mpd-+-{decoder}
        |     |-{io}
        |     |-{output:snd_rpi_}
        |     `-{player}
        |-nginx---nginx
        |-nmbd
        |-ntpd---{ntpd}
        |-php-fpm---3*[php-fpm]
        |-redis-server---2*[{redis-server}]
        |-rune_PL_wrk
        |-rune_SY_wrk---sh---debug_collector---sh---pstree
        |-sh---sleep
        |-shairport---{shairport}
        |-smbd---smbd
        |-sshd---sshd---bash
        |-systemd-journal
        |-systemd-resolve
        |-systemd-udevd
        |-upmpdcli---7*[{upmpdcli}]
        |-wpa_supplicant
        `-xbindkeys


###### Audio backend ######
Advanced Linux Sound Architecture Driver Version k4.1.20-1-ARCH.

Card list: (/proc/asound/cards)
--------------------------------------------------
 0 [sndrpihifiberry]: snd_rpi_hifiber - snd_rpi_hifiberry_dac
                      snd_rpi_hifiberry_dac


PLAYBACK devices: (aplay -l)
--------------------------------------------------
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0


PCM devices: (aplay -L)
--------------------------------------------------
null
    Discard all samples (playback) or generate zero samples (capture)
default:CARD=sndrpihifiberry
    snd_rpi_hifiberry_dac,
    Default Audio Device
sysdefault:CARD=sndrpihifiberry
    snd_rpi_hifiberry_dac,
    Default Audio Device


Simple mixer controls: (amixer scontrols)
--------------------------------------------------
card 0:
no mixer scontrols


Mixer controls: (amixer controls)
--------------------------------------------------
card 0:
no mixer controls


MPD audio outputs status: (mpc outputs)
--------------------------------------------------
Output 1 (snd_rpi_hifiberry_dac) is enabled

###### mpd version ######
mpd version: 0.19.0

###### mpd.conf ######
###################################
# Auto generated mpd.conf file
# please DO NOT edit it manually!
# Use RuneUI MPD config section
###################################

log_level   "default"
log_file   "/var/log/runeaudio/mpd.log"
state_file   "/var/lib/mpd/mpdstate"
zeroconf_enabled    "yes"
zeroconf_name    "runeaudio"
bind_to_address "/run/mpd.sock"
bind_to_address    "any"
port    "6600"
max_connections    "20"
user    "mpd"
group    "audio"
db_file    "/var/lib/mpd/mpd.db"
sticker_file    "/var/lib/mpd/sticker.sql"
pid_file    "/var/run/mpd/pid"
music_directory    "/mnt/MPD"
playlist_directory    "/var/lib/mpd/playlists"
follow_outside_symlinks    "yes"
follow_inside_symlinks    "yes"
auto_update    "no"
filesystem_charset    "UTF-8"
id3v1_encoding    "UTF-8"
volume_normalization    "no"
audio_buffer_size    "2048"
buffer_before_play    "20%"
gapless_mp3_playback    "yes"
mixer_type    "software"

input {
   plugin    "curl"
}

decoder {
   plugin    "ffmpeg"
   enabled "yes"
}
replaygain    "off"

audio_output {
   name       "snd_rpi_hifiberry_dac"
   type       "alsa"
   device       "hw:0,0"
   auto_resample    "no"
   auto_format    "no"
   enabled    "yes"
}


###### Kernel optimization parameters ######
hardware platform:   RaspberryPi2
current orionprofile:   RuneAudio


kernel scheduler for mmcblk0:         [noop] deadline cfq bfq
/proc/sys/vm/swappiness:         0
/proc/sys/kernel/sched_latency_ns:      18000000
/proc/sys/kernel/sched_rt_period_us:      1000000
/proc/sys/kernel/sched_rt_runtime_us:      950000
/proc/sys/kernel/sched_autogroup_enabled:   1
/proc/sys/kernel/sched_rr_timeslice_ms:      10
/proc/sys/kernel/sched_min_granularity_ns:   2250000
/proc/sys/kernel/sched_wakeup_granularity_ns:   3000000


###### Kernel module snd_usb_audio settings ######
Error opening module snd_usb_audio

jonghyun
 
Posts: 2
Joined: 25 Dec 2016, 11:19

Re: pi3 and pifi dac+ 2.0 is not working

Postby hondagx35 » 25 Dec 2016, 12:16

Hi jonghyun,

your DAC needs the Hifiberry DAC+ setting in /boot/config.txt see here.

On your DAC there are two LEDs one red and one green.
Does the red one light up when you power the PI?

Frank
User avatar
hondagx35
 
Posts: 3016
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: pi3 and pifi dac+ 2.0 is not working

Postby jonghyun » 26 Dec 2016, 02:13

I tried set hifiberry plus option

But its not working

My pifi board only on red light
Green is not on

What i miss important points?
jonghyun
 
Posts: 2
Joined: 25 Dec 2016, 11:19

support RuneAudio Donate with PayPal


Return to Hi-Fi systems

Who is online

Users browsing this forum: No registered users and 1 guest