Pi3 and DAC+ Pro

Raspberry Pi related support

Pi3 and DAC+ Pro

Postby jimmeuh » 16 Mar 2016, 20:11

Hi All

First I wanna thank you guys for this awesome looking software!

I'm experimenting with my brand new Pi3 and DAC+ Pro board.
Wanting not to pollute the main Pi3 thread to much with this issue a seperated thread, as it seems a DAC+ Pro problem.

Besides the more common wireless problems more people are experiencing i'm also having an audio issue.
The music coming out of the RCA is really disturbed (read : noise). The strange thing is when I'm skip forward in a track, it sometimes gets ok.

I'm using the test image from Frank (thanks!).

Code: Select all
/boot/config.txt :
dtparam=i2c_arm=on
dtparam=i2s=on
dtoverlay=hifiberry-dacplus
dtoverlay=pi3-disable-bt


Based on:
https://support.hifiberry.com/hc/en-us/community/posts/207234405-RPi3-and-DAC-Pro-Linux-not-working-Working-on-a-fix-
http://www.runeaudio.com/forum/hifiberry-dac-pro-t2954-10.html

Code: Select all
# uname -a
Linux runeaudio 4.1.18-v7+ #846 SMP Thu Feb 25 14:22:53 GMT 2016 armv7l GNU/Linux


Code: Select all
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0


After this I was able to choose the "HifiBerry Dac+ I2c" option in the MPD settings in the UI.
I've added the disable bluetooth option to try and prevent the noise, but that didn't help.

Any ideas?

Greatly appreciated

(If I can help debug the wifi issue, let me know what I can test - it appeared after I enabled the DAC settings in my setup)
jimmeuh
 
Posts: 28
Joined: 16 Mar 2016, 19:47

Re: Pi3 and DAC+ Pro

Postby hondagx35 » 16 Mar 2016, 22:11

Hi

dtparam=i2c_arm=on
dtparam=i2s=on

No need for this settings.

As i do not own a DAC + pro i can not help at the moment, sorry.

Frank
User avatar
hondagx35
 
Posts: 2957
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Pi3 and DAC+ Pro

Postby jimmeuh » 17 Mar 2016, 09:53

No problem Frank.

I'll try to delete those settings (I think i've tried already though)
Keep u posted If I find a solution.
jimmeuh
 
Posts: 28
Joined: 16 Mar 2016, 19:47

Re: Pi3 and DAC+ Pro

Postby jimmeuh » 17 Mar 2016, 10:04

On the Hifiberry forum, they seem to have found a solution:

https://support.hifiberry.com/hc/en-us/community/posts/207256895-Fix-for-DAC-Pro-on-RPi3-disable-bluetooth

Is it possible to test it on my Runeaudio setup?
jimmeuh
 
Posts: 28
Joined: 16 Mar 2016, 19:47

Re: Pi3 and DAC+ Pro

Postby hondagx35 » 17 Mar 2016, 11:22

Hi,

see also here.

Is it possible to test it on my Runeaudio setup?

Yes, you have to add this:
Code: Select all
dtoverlay=pi3-disable-bt

to your /boot/config.txt

Frank
User avatar
hondagx35
 
Posts: 2957
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Pi3 and DAC+ Pro

Postby jimmeuh » 17 Mar 2016, 11:55

Hi Frank

Yes I know I've tried to disable the BT.
But they seem to have a updated kernel now, with a fix for the issue.
See the github links in the post:

https://github.com/raspberrypi/linux/pull/1340
https://github.com/raspberrypi/linux/issues/1321
jimmeuh
 
Posts: 28
Joined: 16 Mar 2016, 19:47

Re: Pi3 and DAC+ Pro

Postby ingohz » 17 Mar 2016, 13:00

You may try

Code: Select all
pacman -Sy --force raspberrypi-firmware-bootloader linux-raspberrypi


This updates to the latest kernel/firmware, but could result in other problems.
  • HiFi 1: Alix/voyage-mpd, MusicalFidelity M1 DAC (RP2/HifiBerry Digi+), Accuphase DP-67, Accuphase E-212, Infinity Kappa 8.2i
  • HiFi 2: RP2/7" Touchscreen/IQaudIO Pi-DAC+, Philips Fidelio X1
ingohz
 
Posts: 45
Joined: 22 Feb 2016, 12:11

Re: Pi3 and DAC+ Pro

Postby jimmeuh » 17 Mar 2016, 19:53

I've removed those first:
Code: Select all
dtparam=i2c_arm=on
dtparam=i2s=on


reboot -> no difference

I've tried the update
Code: Select all
pacman -Sy --force raspberrypi-firmware-bootloader linux-raspberrypi


reboot ->..... yeah! it works

Thanks for the great support!
jimmeuh
 
Posts: 28
Joined: 16 Mar 2016, 19:47

Re: Pi3 and DAC+ Pro

Postby jimmeuh » 18 Mar 2016, 17:22

Been playing some with the software which now works great!

Next issue to tackle.. the wifi issue.

I can setup a wifi connection fine. The PI3 is available afterwards through the wifi connection. No problems at all...
Until I reboot the PI. The wireless interface won't respond anymore. I need to delete the wireless profile, add it again, and then works fine again.

I've tried the fix for the power issue from Frank:

Code: Select all
cd /srv/http
git stash
git pull


But no difference.

A problem with the combination of the DAC?

Looking in the debug log:

Network interfaces:

Code: Select all
3: wlan0:  mtu 1500 qdisc fq_codel state DORMANT group default qlen 1000
    link/ether b8:27:eb:4d:d9:f8 brd ff:ff:ff:ff:ff:ff


Dmesg:

Code: Select all
[    7.393567] brcmfmac: brcmf_add_if: ERROR: netdev:wlan0 already exists
[    7.393580] brcmfmac: brcmf_add_if: ignore IF event
[    7.397469] brcmfmac: power management disabled



Thanks again...
jimmeuh
 
Posts: 28
Joined: 16 Mar 2016, 19:47

Re: Pi3 and DAC+ Pro

Postby hondagx35 » 18 Mar 2016, 18:12

Hi jimmeuh,

i have the same error message, but my wifi works.
I did a web search for this error, but couldn't find a solution / fix.

The build in wifi isn't great at all.
Please try to move your Pi, maybe the signal strength is not good enough.

Frank
User avatar
hondagx35
 
Posts: 2957
Joined: 11 Sep 2014, 22:06
Location: Germany

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: Bing [Bot] and 2 guests