No connection with QNAP folders

Raspberry Pi related support

No connection with QNAP folders

Postby franen » 18 Sep 2018, 22:20

Dear all,
I've just bought a Raspberry Pi3b+ with an Hifiberry DIGI+Pro. I run Runeaudio 0.4b (build: 20170229) and it perfectly works.
But I cannot configure the system for accessing my NAS Qnap 469L. You can see in the screenshot here what I get.

Image

Image
I access the NAS from everywhere (iMac and Sony TV) with smb://10.10.10.10. But with runeaudio it does not work.
Any advice?

Francesco, a new runeaudio user (I hope :D )
franen
 
Posts: 4
Joined: 17 Sep 2018, 19:56
Location: Trento

Re: No connection with QNAP folders

Postby MidnightExpress » 19 Sep 2018, 08:59

Hi franen,
franen wrote:I've just bought a Raspberry Pi3b+ with an Hifiberry DIGI+Pro. I run Runeaudio 0.4b (build: 20170229) and it perfectly works.
But I cannot configure the system for accessing my NAS Qnap 469L. You can see in the screenshot here what I get.

I am a QNAP user. To connect to the NAS, you may try either of the followings from the NAS Mounts page:
1. Select SMB/CIFS (OS X share) from Fileshare protocol option.
2. Turn on the Advanced options and type in the following line in the Mount flags option.
Code: Select all
vers=2.1,sec=ntlmssp,cache=none,noserverino,ro

The second method may not be perfect but it works.

MidnightExpress
Pi3b+, Ver. Experimental Beta 0.5 20180903, ES9018K2M Dac
MidnightExpress
 
Posts: 12
Joined: 04 Aug 2018, 12:19

Re: No connection with QNAP folders

Postby franen » 19 Sep 2018, 16:48

Thank you,
I tried but the result is still the same. I have that red cross and no MDP library is created
franen
 
Posts: 4
Joined: 17 Sep 2018, 19:56
Location: Trento

Re: No connection with QNAP folders

Postby MidnightExpress » 23 Sep 2018, 13:53

Hi franen,

It is hard to tell what is wrong when mounting the NAS through RuneUI as no error message would show if anything goes wrong. You may try to mount your NAS manually through SSH.
Try the following command and see what happens.
Code: Select all
mount.cifs //10.10.10.10/Multimedia/Music /mnt/MPD/NAS -o user=admin

Type in your password when your NAS ask for. On my machines, share folder name is case insensitive. Write down the error message if your NAS complaints. If successful, unmount the mounted directory and re-mount through RuneUI.

To unmount the mounted directory, do:
Code: Select all
umount /mnt/MPD/NAS

I am not a Linux expert, I just tell you what I have tried on my machines.

Good luck.

MidnightExpress
Pi3b+, Ver. Experimental Beta 0.5 20180903, ES9018K2M Dac
MidnightExpress
 
Posts: 12
Joined: 04 Aug 2018, 12:19

Re: No connection with QNAP folders

Postby janui » 23 Sep 2018, 21:27

Hi franen,
Two alterntives to try in the mount flags:
Code: Select all
vers=1.0,sec=ntlmssp,cache=none,noserverino,ro
and
Code: Select all
vers=1.0,cache=none,noserverino,ro
janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: No connection with QNAP folders

Postby franen » 01 Oct 2018, 17:21

I tried janui andMIdnightexpress solutions, but they did not work. I tried to install Vol***o and it worked immediately, with cifs share.
I really do not know what to do.
franen
 
Posts: 4
Joined: 17 Sep 2018, 19:56
Location: Trento

Re: No connection with QNAP folders

Postby janui » 01 Oct 2018, 21:08

Hi franen,

You could try using the latest cifs version and working backwards until you find one which the NAS supports. The later versions are also more reliable and faster.
The cifs versions which could work are (oldest to newest):
vers=1.0, vers=2.0, vers=2.1, vers=3.0, vers=3.02, vers=3.1.1

So the mount options that you could first try
Code: Select all
cache=none,noserverino,ro,vers=3.1.1
then work backwards through the list until
Code: Select all
cache=none,noserverino,ro,vers=1.0


This has solved problems for a couple of other users (not using your NAS) and it is now impelemted as standard in Rune 0.5b.

janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: No connection with QNAP folders

Postby franen » 22 Oct 2018, 17:30

Sorry for the delay in answering and sorry for keeping on posting revealing my lack on knowledge in Rune World :-)
I'm using Release version: 0.5 (build: janui-20180903) om Raspberry Pi 3b+.
Now I can mount folders via ssh as MidnightExpress suggested:
Code: Select all
mount.cifs //10.10.10.10/Multimedia/Music /mnt/MPD/NAS -o user=admin

But if I unmount them and then I try to do it via runeaudio.local I have no success.

And then, Runeaudio app for android does not work anumore, I only see a down-head android logo at the top of a dark screen :-(
franen
 
Posts: 4
Joined: 17 Sep 2018, 19:56
Location: Trento

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 0 guests