i2s connection to an external DAC

Raspberry Pi related support

i2s connection to an external DAC

Postby jazzaj » 14 Aug 2015, 19:29

Hi all,

Today, I tried to connect my RPI2B to my DAC, an Audio-gd NFB1 (ES9018), via the i2s input of the DAC (RJ45).

According to the Audio-gd website, the RJ45 use the follow pins define :
Image
Pin 1 : SDATA
Pin 3 : LRCK
Pin 5 : SCLK
Pin 7 : MCLK
Pin 2,4,6,8 GND
ES9018 doesn't need MCLK and Audio-gd asks to cut the MCLK wire in the source and connect to GND, so the schema become :

For the RPI2B i2s output, I follow the schema on Archpile website :
Image

I used a short cat7 cable (10cm) with this schema :
RJ45 > GPIO
Pin 1 (SDATA) Pin 40
Pin 3 (LRCK) Pin 35
Pin 5 (SCLK/BCK) Pin 12
Pin 2,4,6,7,8 (GND) all on Pin 39

Once the cable connect to the GPIO and the DAC, I tried to play Runeaudio... but without success because I can't choose the proper MPD Audio output interface. :(
In config.txt, I uncommented the line "device_tree_param=i2s=on" and, one after the other, the lines of audio interfaces, but each time, after reboot, I can't see none of the i2s audio interface.

Any idea ?
Odroid C1+ (/regulated linear PSU) > Audio-gd NFB-1 (with Amanero384 combo) > Audio-gd Precision 2 > Triangle Lyrr 222
User avatar
jazzaj
 
Posts: 47
Joined: 23 Apr 2015, 20:49

Re: i2s connection to an external DAC

Postby hondagx35 » 14 Aug 2015, 21:05

Hi jazzaj,

In config.txt, I uncommented the line "device_tree_param=i2s=on" and, one after the other, the lines of audio interfaces, but each time, after reboot, I can't see none of the i2s audio interface.

There is something wrong. After changing /boot/config.txt like this:
Code: Select all
#device_tree_param=i2c_arm=on
#device_tree_param=i2c_vc=on
#device_tree_param=i2s=on
#device_tree_param=spi=on
#device_tree_param=act_led_trigger=mmc

# Uncomment one of these lines to enable an audio interface
device_tree_overlay=hifiberry-dac
#device_tree_overlay=hifiberry-dacplus
#device_tree_overlay=hifiberry-digi
#device_tree_overlay=hifiberry-amp
#device_tree_overlay=iqaudio-dac
#device_tree_overlay=iqaudio-dacplus

there should be a new entry on the mpd configuration page.

I tested it with a fresh image and even with no DAC connected the entry is there.

Please post your debug data:

HOW TO COLLECT AND POST DEBUG INFO
  1. In the RuneUI, go to MENU > Debug;
  2. Click the "COPY DATA TO CLIPBOARD" button;
  3. Go to http://pastebin.com and paste the debug output in the "New Paste" textarea. Leave the default options (Syntax Highlighting: None, Paste Expiration: Never, Paste Exposure: Public), give a name to il (e.g. RuneAudio debug info) and submit.
  4. Copy the url of the submitted Pastebin (e.g. http://pastebin.com/dL1k9irT) and include it in your post here in the forum.

Frank
User avatar
hondagx35
 
Posts: 2992
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: i2s connection to an external DAC

Postby jazzaj » 15 Aug 2015, 09:21

Hi Franck,

Tried another time this morning, i2s comment, hifiberry digi uncomment, and still no new interface except Amanero (USB DAC), RPI analog output, RPI HDMI output...

Here the debug data :

http://pastebin.com/C0zRWLzT
Odroid C1+ (/regulated linear PSU) > Audio-gd NFB-1 (with Amanero384 combo) > Audio-gd Precision 2 > Triangle Lyrr 222
User avatar
jazzaj
 
Posts: 47
Joined: 23 Apr 2015, 20:49

Re: i2s connection to an external DAC

Postby hondagx35 » 15 Aug 2015, 11:00

Hi jazzaj,

hifiberry digi uncomment, and still no new interface except Amanero (USB DAC), RPI analog output


Code: Select all
[    8.115472] snd-hifiberry-digi sound: ASoC: CPU DAI (null) not registered
[    8.115537] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517
[    8.115760] platform sound: Driver snd-hifiberry-digi requests probe deferral
[    8.124732] snd-hifiberry-digi sound: ASoC: CPU DAI (null) not registered
[    8.124790] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517
[    8.124818] platform sound: Driver snd-hifiberry-digi requests probe deferral
[    8.124875] bcm2708_i2c 3f804000.i2c: BSC1 Controller at 0x3f804000 (irq 79) (baudrate 100000)
[    8.125039] snd-hifiberry-digi sound: ASoC: CPU DAI (null) not registered
[    8.125081] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517
[    8.125109] platform sound: Driver snd-hifiberry-digi requests probe deferral
[    8.125788] snd-hifiberry-digi sound: ASoC: CPU DAI (null) not registered
[    8.125836] snd-hifiberry-digi sound: snd_soc_register_card() failed: -517
[    8.125862] platform sound: Driver snd-hifiberry-digi requests probe deferral
[    8.127856] wm8804 1-003b: Failed to read device ID: -1
[    8.127878] wm8804 1-003b: ASoC: failed to probe component -1
[    8.127955] snd-hifiberry-digi sound: ASoC: failed to instantiate card -1
[    8.128067] snd-hifiberry-digi sound: snd_soc_register_card() failed: -1
[    8.128096] snd-hifiberry-digi: probe of sound failed with error -1


You can't use other drivers than hifiberry-dac and iqaudio-dac,
because all others expect a Device on the I2C bus to respond.
Sorry i thought you know this.
So please try it like i told you in my last post.

Frank

BTW:
You did the wifi configuration manually with wifi-menu, right?
Is there a reason for this?
The configuration with the UI is easy and should work without any problems.
The only thing is, that you have to get a working ethernet connection first.
User avatar
hondagx35
 
Posts: 2992
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: i2s connection to an external DAC

Postby jazzaj » 15 Aug 2015, 12:41

Ok. This time I can access to the hifiberry-dac but not the iqaudio-dac.
I can play music too but no sound. If I switch to amanero from the mpd audio interface, sound is recover.

Looking to the hifiberry website, it appears that the hifiberry-dac is only running on RPI1, I have RPI2. So I tried to choose hifiberry-dac+ in config.txt, but I can't see this interface (like iqaudio-dac) in the mpd tab.

And yes, I had to manualy config my wifi. I can't remember exactly what was the problem on the first install : can't access to RPI wifi or via the ethernet ?!?
Odroid C1+ (/regulated linear PSU) > Audio-gd NFB-1 (with Amanero384 combo) > Audio-gd Precision 2 > Triangle Lyrr 222
User avatar
jazzaj
 
Posts: 47
Joined: 23 Apr 2015, 20:49

Re: i2s connection to an external DAC

Postby hondagx35 » 15 Aug 2015, 14:27

Hi jazzaj,

sorry my fault.
The iqaudio-dac also uses I2C and therefor needs the appropriate hardware to work.
So the hifiberry-dac seems the only that will work in your case.

An other possibility is to disable device tree and load the needed modules the old way.

Frank
User avatar
hondagx35
 
Posts: 2992
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: i2s connection to an external DAC

Postby jazzaj » 15 Aug 2015, 14:34

hondagx35 wrote:load the needed modules the old way.


How to do that ?
Odroid C1+ (/regulated linear PSU) > Audio-gd NFB-1 (with Amanero384 combo) > Audio-gd Precision 2 > Triangle Lyrr 222
User avatar
jazzaj
 
Posts: 47
Joined: 23 Apr 2015, 20:49

Re: i2s connection to an external DAC

Postby nfb29 » 08 Sep 2015, 16:59

Hello everybody ,

I am also looking for a way to connect my Audio-GD NFB29 with the RaspberryPi 2 on the I2S interface .

About the USB Port everything runs properly.

In the following lines /boot/config.txt I commented out :
device_tree_param = I2S = on
device_tree_overlay = hifiberry - DAC

Then i can select Hifiberry DAC as an audio output interface also, but hear no sound .

Am I on the right track , or I may have another module use ?
nfb29
 
Posts: 3
Joined: 08 Sep 2015, 16:37

Re: i2s connection to an external DAC

Postby popov » 08 Sep 2015, 18:48

Hi

Found this, https://volumio.org/forum/es9018k2m-t1218-20.html
This is the old way, but no I2c

Regards
popov
 
Posts: 48
Joined: 11 Oct 2014, 16:13

Re: i2s connection to an external DAC

Postby nfb29 » 09 Sep 2015, 07:50

I've already tried , but somehow I no new or different devices are displayed .
Only the change of /boot/config.txt affects the hardware devices .

Code: Select all
[root@runeaudio ~]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
  Subdevices: 8/8
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1
  Subdevice #2: subdevice #2
  Subdevice #3: subdevice #3
  Subdevice #4: subdevice #4
  Subdevice #5: subdevice #5
  Subdevice #6: subdevice #6
  Subdevice #7: subdevice #7
card 0: ALSA [bcm2835 ALSA], device 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 2: Audiogd [Audio-gd], device 0: USB Audio [USB Audio]
  Subdevices: 0/1
  Subdevice #0: subdevice #0



If I change then file /etc/modules-load.d/raspberrypi.conf to (have already tried many suggestions)
Code: Select all
bcm2708-rng
snd-bcm2835
snd_soc_bcm2708
snd_soc_bcm2708_i2s
bcm2708_dmaengine
snd-soc-pcm1794a
snd_soc_rpi_dac


... nothing happens.

Is there somewhere a logfile on the impact ?

It must be possible to tap the I2S signal raw without the I2C bus ?

About more tips I would be very grateful .

Thx!
nfb29
 
Posts: 3
Joined: 08 Sep 2015, 16:37

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests