[BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Raspberry Pi related support

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby Tom2112 » 29 Nov 2016, 04:21

hondagx35 wrote:This is a known issue, but nothing we can solve at the moment.
volume-control-linear-or-logarithmic-t254.html


So what would you recommend? Just use software volume control?

Does this affect all DACs? I'm experiencing it on my SainSmart SX400 (which pretends to be an IQaudIO DAC+).
Tom2112
 
Posts: 4
Joined: 19 Nov 2016, 16:57

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby bloodnok » 12 Dec 2016, 03:22

matt wrote:Thanks for this, I got it to work this time.
I also find that the volume control is really only usable between 60 and 100, can we fix this or is it a hardware issue?


I have just released a hack for this. There is an executable for Pi model 1 which you can try.

https://github.com/marcmunro/MPD
bloodnok
 
Posts: 4
Joined: 16 Nov 2016, 02:03

Re: [BugFix] HiFiBerry DAC+ HW Volume (RuneAudio 0.3-beta)

Postby snafu » 10 Feb 2018, 19:35

Hmmm. When I run the "redis-cli.....", I get- "(interger) 0" displayed. Is that a good thing or a bad thing?
Then when I run the "refresh_ao" I get "command not found".
My guess is the refresh_ao error is a path related issue? Which folder does this command reside?

I'm using a HiFiBerry Dac+. It's working except the hardware volume control fails to work. Software enabled works, but it effects the sound quality. I'm hoping if I can get your command to work, it'll fix this.
snafu
 
Posts: 3
Joined: 10 Feb 2018, 03:02

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 0 guests