Digi+ support in RuneAudio.

Raspberry Pi related support

Digi+ support in RuneAudio.

Postby radekker » 21 Sep 2015, 07:07

I have installed RuneAudio v0.3-beta on my Raspberry Pi 2B plus Digi+ sound card.
In the audio output menu the Digi+ option is missing however.
I can only choose analog or HDMI output.
I'm I doing something wrong?
radekker
 
Posts: 3
Joined: 21 Sep 2015, 06:58

Re: Digi+ support in RuneAudio.

Postby Gingko » 21 Sep 2015, 08:10

radekker wrote:I have installed RuneAudio v0.3-beta on my Raspberry Pi 2B plus Digi+ sound card.
In the audio output menu the Digi+ option is missing however.
I can only choose analog or HDMI output.
I'm I doing something wrong?


You need to enable I2S in Settings before the option becomes available for selection.
Gingko
 
Posts: 5
Joined: 21 Feb 2015, 07:58

Re: Digi+ support in RuneAudio.

Postby hondagx35 » 21 Sep 2015, 11:35

Hi,

you have to edit the file /boot/config.txt see here.

You need to enable I2S in Settings before the option becomes available for selection.

This is correct for the older PIs, but not for Pi 2B.
On a Pi2 there is a help text on the settings page:
Enable I2S output by selecting one of the available sets of modules (in this version you have to edit /boot/config.txt), specific for each hardware. Once set, the output interface will appear in the MPD configuration select menu, and modules will also auto-load from the next reboot.


Frank
User avatar
hondagx35
 
Posts: 2833
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Digi+ support in RuneAudio.

Postby radekker » 22 Sep 2015, 18:30

Thnx, looks like I missed the small print.
radekker
 
Posts: 3
Joined: 21 Sep 2015, 06:58

Re: Digi+ support in RuneAudio.

Postby pzwief » 13 Dec 2015, 05:04

I do not understand what this is telling me to do. Anyone willing to lay it out for this newbie? Thanks.
pzwief
 
Posts: 12
Joined: 12 Dec 2015, 18:58

Re: Digi+ support in RuneAudio.

Postby hondagx35 » 13 Dec 2015, 16:48

Hi pzwief,

From here:
As it's an embedded platform, the Raspberry Pi doesn't have a BIOS like you'd find on a conventional PC. The various system configuration parameters, which would traditionally be edited and stored using a BIOS, are stored in an optional text file named config.txt. This is read by the GPU before the ARM CPU (and Linux) is initialised; therefore it must be located on the first (boot) partition of your SD card, alongside bootcode.bin and start.elf. This file is normally accessible as /boot/config.txt from Linux and must be edited as root; but from Windows or OS X it is seen as a file in the only accessible part of the card. If you need to apply some of the config settings below, but you don't have a config.txt on your boot partition yet, then simply create it as a new text file.

Any changes will only take effect after you've rebooted your Raspberry Pi.


Put your sd card into your PC or Mac and navigate to the folder /boot.
Now you have to edit the file "config.txt".

Code: Select all
# Uncomment one of these lines to enable an audio interface
#device_tree_overlay=hifiberry-dac
#device_tree_overlay=hifiberry-dacplus
#device_tree_overlay=hifiberry-digi
#device_tree_overlay=hifiberry-amp
#device_tree_overlay=iqaudio-dac
#device_tree_overlay=iqaudio-dacplus


For the HifiBerry Digi+ it should look like this:
Code: Select all
# Uncomment one of these lines to enable an audio interface
#device_tree_overlay=hifiberry-dac
#device_tree_overlay=hifiberry-dacplus
device_tree_overlay=hifiberry-digi
#device_tree_overlay=hifiberry-amp
#device_tree_overlay=iqaudio-dac
#device_tree_overlay=iqaudio-dacplus


Put the card back in your Pi and power it up.
Now you should be able to select the HifiBerry Digi+ under MENU->Mpd

Frank
User avatar
hondagx35
 
Posts: 2833
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Digi+ support in RuneAudio.

Postby pzwief » 13 Dec 2015, 21:43

Now I understand. That fixed it. Thank you Frank!
pzwief
 
Posts: 12
Joined: 12 Dec 2015, 18:58

Re: Digi+ support in RuneAudio.

Postby gabcosse » 08 Jan 2017, 16:29

Hello, i have the same trouble here with my RPi3 with the element14 7" screen and the HifiBerry digi.
I have modified the Config.txt file like listed below and in the MPD list a cannot see the I2S out.
even in the setting page i can only see this:
Image.

can anybody help me please?

Have I forgot some passages?
gabcosse
 
Posts: 11
Joined: 08 Jan 2017, 16:19

Re: Digi+ support in RuneAudio.

Postby hondagx35 » 08 Jan 2017, 17:03

Hi gabcosse,

welcome to Rune Audio.

hondagx35 wrote:......
Now you should be able to select the HifiBerry Digi+ under MENU->Mpd

Frank

It is not on the settings page, but on Menu->MPD

Frank
User avatar
hondagx35
 
Posts: 2833
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Digi+ support in RuneAudio.

Postby gabcosse » 08 Jan 2017, 19:37

hondagx35 wrote:Hi gabcosse,

welcome to Rune Audio.

hondagx35 wrote:......
Now you should be able to select the HifiBerry Digi+ under MENU->Mpd

Frank

It is not on the settings page, but on Menu->MPD

Frank

Not even in the mpd page.
I would try on my PI2 in these days.
gabcosse
 
Posts: 11
Joined: 08 Jan 2017, 16:19

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests