Page 52 of 52

Re: RuneAudio 0.4-beta for Raspberry Pi2/3

PostPosted: 05 Dec 2018, 10:54
by Dimon B
Hello! I chose Raspberry Pi DAC in the settings. Aoid dac II is defined as" I-Sabre DAC (I2S)". Perform poorly. When switching tracks there is a click. When playing DSD files noise instead of music. There's no problem with Volumio, but I like RuneAudio. Is there a possibility of normal operation of this DAC C RuneAudio 0.4 and Raspberry Pi 3B ? Thank you!

Re: RuneAudio 0.4-beta for Raspberry Pi2/3

PostPosted: 06 Dec 2018, 15:55
by janui
Hi Dimon B,
Dimon B wrote:....Aoid dac II is defined as" I-Sabre DAC (I2S)". Perform poorly....but I like RuneAudio. Is there a possibility of normal operation of this DAC C RuneAudio 0.4 and Raspberry Pi 3B ?
We have had reports that the DAC works correctly with RuneAudio 0.5b. See here: runeaudio-0-5-beta-for-all-raspberry-pi-models-t6532-20.html?hilit=sabre#p25862
To download the image, see here: runeaudio-0-5-beta-for-all-raspberry-pi-models-t6532.html#p25819
The problems mentioned in the post above have already been fixed. To get the fixes you need to upgrade to the latest version as described in the post containing the downloads.
janui

Re: RuneAudio 0.4-beta for Raspberry Pi2/3

PostPosted: 10 Dec 2019, 10:39
by looper
I'm having trouble adding https radio streams to my RaspberryPi2, the normal http ones work ok, but many changed to the secure version and it seems that Rune doesn't recognize them.

Can this be solved somehow?

Re: RuneAudio 0.4-beta for Raspberry Pi2/3

PostPosted: 11 Jan 2020, 01:36
by MusicLover22
Just testing this release and this is by far the best working runeaudio release so far, i'm surprised that the almost a year newer version is really broken compared to this one, this one operates pretty perfectly on my pi 3+, thanks!

Auto Mounting of external USB drive as Read Only

PostPosted: 04 Mar 2020, 20:30
by Nudge
I'm trying to set a trigger on Rune 0.4b that changes a USB external drive to be Read Only when mounted.

The following does not appear to work on Rune 0.4b using Arch Linux although it does on other flavours of Linux.


/etc/udev/rules.d/96-enforce-usb-ro.rules: (also tried: /usr/lib/udev/rules.d/96-enforce-usb-ro.rules)
SUBSYSTEMS=="usb", ACTION=="add", KERNEL=="sd*", ENV{SYSTEMD_WANTS}="enforce-usb-ro@%k"

/lib/systemd/system/enforce-usb-ro@.service:
[Unit]
Description=Enforce read-only mode on USB storage device
BindsTo=dev-%i.device

[Service]
Type=simple
ExecStart=/usr/bin/mount -o remount,ro /dev/%I


I'm obviously missing something and cannot determine the Arch Linux automount rule which might be a better place to mount as Read Only (I have a sneaky suspicion that devmon may be involved somewhere).


Any pointers / examples gratefully received !

Re: RuneAudio 0.4-beta for Raspberry Pi2/3

PostPosted: 09 May 2020, 20:26
by Spiralgalaxy5
Hi Frank,

I hope you're still checking this topic :-) I'm still happily using 0.3 on my Pi 3B v1.20 with iqaudio-dacplus but recently checked out this forum again. "Lockdown" and all that... I see some very new stuff but this 0.4 image would seem to be the best software upgrade for me - I have the 7" touchscreen that "just worked" and looked good with 0.3 but maybe 0.4 would make it look even more lovely :-) I do love this Rune interface on my DAC.

Question 1: is the link at the head of this topic for the image correct for the latest work on 0.4? I know that there is also a 0.5 and others but I'm interested in this particular one as it's an incremental change from what I've got right now. I like the changes you've made and especially the screensaver function looks good but the HiFi audio is the whole point of the thing for me and I have no need to change my "old" version on that score, so far as I can tell. MPD etc all works fine for me just as it is. I have an ethernet connection to the internet and my NAS so WiFi is not required.

Question 2: does this 0.4 image improve / update the Midori version from the one in 0.3? I ask because I have found that Midori romps away with CPU and heats it up unnecessarily - strangely this behaviour seems to manifest itself especially when webradio streams are in use. Midori seems to suffer from this kind of thing sometimes, e.g: https://bugs.launchpad.net/midori/+bug/1103102

I resorted to this (example below) - it's actually not too bad here at 15% but I have seen the CPU at >65% for Midori at another time and load average up to 0.97 over 15 minutes - which raised CPU +10 deg C, to 60 deg C in 20 deg room ambient :-( :

Code: Select all
[root@runeaudio ~]# ps -eo pid,ppid,cmd,%mem,%cpu --sort=-%mem | head
  PID  PPID CMD                         %MEM %CPU
  630   623 midori -p -e Fullscreen htt 11.3 14.7
  609   592 /usr/lib/xorg-server/Xorg :  3.1  1.6
  519     1 /usr/bin/mpd --no-daemon     2.6  0.3
  560   558 php-fpm: pool display        1.4  0.0
  368     1 /usr/bin/php /var/www/comma  1.3  0.0
  566     1 /usr/bin/php /var/www/comma  1.3  0.0
  ...
[root@runeaudio ~]# kill -TERM 630


This works if I want to leave the radio playing all day after I have booted normally (browser enabled) then ssh to the Pi to kill Midori - I could try to write a script to do it with one command but the better solution would be to get Midori fixed... What do you think?

Hope you're well anyway? Thanks for all the work - I'm still enjoying the results.

Tim

Re: RuneAudio 0.4-beta for Raspberry Pi2/3

PostPosted: 13 May 2020, 11:06
by hondagx35
Hi Tim,

Spiralgalaxy5 wrote:Question 1: is the link at the head of this topic for the image correct for the latest work on 0.4?

Yes it is the latest 0.4.

Question 2: does this 0.4 image improve / update the Midori version from the one in 0.3?

If i remember correctly there was an issue with the GUI that causes this.
It should be fixed with 0.4.

Hope you're well anyway? Thanks for all the work - I'm still enjoying the results.

Thanks i am fine.
Nice to hear that you enjoy rune.

Frank

Re: RuneAudio 0.4-beta for Raspberry Pi2/3

PostPosted: 16 May 2020, 21:11
by Spiralgalaxy5
>It should be fixed with 0.4
It'll be interesting to try it out. Thanks for getting back to me.

Tim

Re: RuneAudio 0.4-beta for Raspberry Pi2/3

PostPosted: 23 Jun 2020, 21:21
by Spiralgalaxy5
Quick update: I messed up some details on my previous postings - I stated I was using 0.3 but I was already on 0.4 (2016 build). I've tried the build at the head of this post (0.4b 2017) and I love the enhancements to the graphics so will be sticking with this build for now as it looks lovely - thanks Frank - and the fundamentals seem to be the same as what I was using before. It all looks very efficient and a nice build, as was the previous version.

But (there's always a but), the Midori CPU usage with webradio streams is unaffected so I will still be using my script to kill the local browser if I listen to a radio stream to reduce CPU temperature. It's not a big deal.

Code: Select all
21:04:11 up 49 min,  1 user,  load average: 1.15, 1.06, 0.78

CPU Temperature is: 55 degrees C

  PID CMD                         %MEM %CPU
  641 midori -p -e Fullscreen htt 16.3 38.9
  625 /usr/lib/xorg-server/Xorg :  3.6  1.8
  530 /usr/bin/mpd --no-daemon     2.6  2.2
  313 python /usr/share/amixer-we  2.0  0.1

KILL a process (y/n)? y

Which process to KILL? : 641