Page 13 of 15

Re: Raspberry Pi Zero Support in 0.4

PostPosted: 19 Jan 2018, 13:57
by janui
Hi gearhead,
I found when testing WiFi a full shutdown, power off and disconnecting the power is required between tests if the configuration has been changed. If you have not been doing this, you should try some of the tests again.
Could you tell me what type of Zero you are using?
With AP switched off, after a reboot, could you supply the output of the command:
Code: Select all
iw list
I have found that for some WiFi dongles it returns nothing.
And finally could you supply the output of the command:
Code: Select all
pacman -Q raspberrypi-firmware raspberrypi-bootloader linux-raspberrypi linux-firmware cifs-utils openssl netctl iw iputils ldns net-tools iptables ca-certificates ca-certificates-utils

Re: Raspberry Pi Zero Support in 0.4

PostPosted: 19 Jan 2018, 20:27
by gearhead
Well, it all seems to be 'there and ready". Are one of my packages out of date? This is on an 'old' b+, not a Pi Zero... This image of the Rune OS was built with newer components from 0.4 with help from the old recipe plus some assistance from Frank... My thought is this should also run on a Zero and it uses the newer 0.4b UI.

Code: Select all
root@runeaudio:~ # pacman -Q raspberrypi-firmware raspberrypi-bootloader linux-aspberrypi linux-firmware cifs-utils openssl netctl iw iputils ldns net-tools itables ca-certificates ca-certificates-utils
raspberrypi-firmware 20170301-1
raspberrypi-bootloader 20170303-1
linux-raspberrypi 4.9.13-3
linux-firmware 20170217.12987ca-2
cifs-utils 6.7-2
openssl 1.0.2.k-1
netctl 1.12-2
iw 4.9-1
iputils 20161105.1f2bb12-1
ldns 1.7.0-2
net-tools 1.60.20160710git-1
iptables 1.6.0-1
ca-certificates 20160507-1
ca-certificates-utils 20170307-1
root@runeaudio:~ # iw list
Wiphy phy0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        RTS threshold: 2347
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports RSN-IBSS.
        Supported Ciphers:
                * WEP40 (00-0f-ac:1)
                * WEP104 (00-0f-ac:5)
                * TKIP (00-0f-ac:2)
                * CCMP-128 (00-0f-ac:4)
                * CCMP-256 (00-0f-ac:10)
                * GCMP-128 (00-0f-ac:8)
                * GCMP-256 (00-0f-ac:9)
                * CMAC (00-0f-ac:6)
                * CMAC-256 (00-0f-ac:13)
                * GMAC-128 (00-0f-ac:11)
                * GMAC-256 (00-0f-ac:12)
        Available Antennas: TX 0 RX 0
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
        Band 1:
                Capabilities: 0x1862
                        Static SM Power Save
                        RX HT20 SGI
                        RX HT40 SGI
                        No RX STBC
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 16 usec (0x07)
                HT Max RX data rate: 150 Mbps
                HT TX/RX MCS rate indexes supported: 0-7, 32
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps
                        * 5.5 Mbps
                        * 11.0 Mbps
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm)
                        * 2472 MHz [13] (20.0 dBm)
                        * 2484 MHz [14] (disabled)
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * start_ap
                 * new_station
                 * new_mpath
                 * set_mesh_config
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * join_mesh
                 * remain_on_channel
                 * set_tx_bitrate_mask
                 * frame
                 * frame_wait_cancel
                 * set_wiphy_netns
                 * set_channel
                 * set_wds_peer
                 * probe_client
                 * set_noack_map
                 * register_beacons
                 * start_p2p_device
                 * set_mcast_rate
                 * testmode
                 * set_qos_map
                 * connect
                 * disconnect
        Supported TX frame types:
                 * IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa00xb0 0xc0 0xd0 0xe0 0xf0
                 * managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0a0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0b0 0xc0 0xd0 0xe0 0xf0
                 * AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0a0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x9 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x9 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0x0 0xb0 0xc0 0xd0 0xe0 0xf0
                 * P2P-device: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x9 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
        Supported RX frame types:
                 * IBSS: 0x40 0xb0 0xc0 0xd0
                 * managed: 0x40 0xd0
                 * AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
                 * AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
                 * mesh point: 0xb0 0xc0 0xd0
                 * P2P-client: 0x40 0xd0
                 * P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
                 * P2P-device: 0x40 0xd0
        software interface modes (can always be added):
                 * AP/VLAN
                 * monitor
        interface combinations are not supported
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        Device supports TX status socket option.
        Device supports HT-IBSS.
        Device supports SAE with AUTHENTICATE command
        Device supports low priority scan.
        Device supports scan flush.
        Device supports AP scan.
        Device supports per-vif TX power setting
        Driver supports full state transitions for AP/GO clients
        Driver supports a userspace MPM
        Device supports configuring vdev MAC-addr on create.


Re: Raspberry Pi Zero Support in 0.4

PostPosted: 05 Feb 2018, 21:20
by janui
Hi there,

Updated Rune arch6h Pi1 image for Pi Zero and legacy Pi models

I have published a new version of the Rune 0.3 Pi1 arch6h image for Pi A, A+, B, B+, Zero and Zero W.
You can find the image here: raspberry-pi-zero-support-in-0-4-t3711-70.html#p20577

This is probably my last 0.3 release. I know I have said that this would be my last release before but it time to move on to the new 0.4 version. For details of the pevious two releases (a bug fix and a functional release) see here: raspberry-pi-zero-support-in-0-4-t3711-100.html#p23880 and here: raspberry-pi-zero-support-in-0-4-t3711-80.html#p23506

    • Changes:
      o Previous build: ‘20171209_runeaudio_raspberry1_raspberryZero_4.9.67-1.img’
      o New build: ‘20180202_runeaudio_raspberry1_raspberryZero_4.9.79-1.img’
    • Upgraded openssl and fixed Access Point functionality:
      o A large number of packages have been upgraded in order to make openssl work. Many additional packages have been upgraded for other reasons, the upgraded package list is here:
      Code: Select all
      apr-util 1.6.1-2
      alsa-lib 1.1.5-1
      ca-certificates-utils 20170307-1
      coreutils 8.28-1
      curl 7.57.0-1
      damageproto 1.2.1-3
      ffmpeg 1:3.4.1-3
      file 5.32-1
      findutils 4.6.0-2
      fontconfig 2.12.6+5+g665584a-1
      freetype2 2.9-1
      fribidi 0.19.7-1
      gawk 4.2.0-2
      giflib 5.1.4-1
      git 2.15.1-2
      graphite 1:1.3.10-1
      grep 3.1-1
      gzip 1.8-2
      harfbuzz 1.7.4-1
      hicolor-icon-theme 0.17-1
      hostapd 2.6-6
      icu 60.2-1
      iptables 1.6.1-2
      iputils 20161105.1f2bb12-2
      ladspa 1.13-6
      lcms2 2.9-1
      ldns 1.7.0-4
      libarchive 3.3.2-1
      libass 0.14.0-1
      libavc1394 0.5.4-3
      libbluray 1.0.1-1
      libdrm 2.4.89-1
      libelf 0.170-1
      libevent 2.1.8-1
      libglvnd 1.0.0-1
      libgme 0.6.1-1
      libiec61883 1.2.0-4
      libmpdclient 2.11-1
      libnfs 2.0.0-1
      libnftnl 1.0.8-1
      libnghttp2 1.28.0-1
      libomxil-bellagio 0.9.3-1
      libpcap 1.8.1-2
      libpciaccess 0.14-1
      libpulse 11.1-1
      libraw1394 2.1.2-1
      libsasl 2.1.26-11
      libshout 1:2.4.1-3
      libssh 0.7.5-2
      libssh2 1.8.0-2
      libtheora 1.1.1-3
      libva 2.0.0-2
      libvdpau 1.1.1+3+ga21bf7a-1
      libvpx 1.6.1-1
      libwebp 0.6.1-1
      libx264 2:152.20171224-1
      libxcursor 1.1.15-1
      libxdamage 1.1.4-2
      libxrender 0.9.10-1
      libxshmfence 1.2-1
      libxxf86vm 1.1.4-1
      llvm-libs 4.0.1-5
      lm_sensors 3.4.0-2
      lz4 1:1.8.0-1
      mesa 17.3.2-2
      mpc 0.28-1
      mpd 0.20.15-2
      ntp 4.2.8.p10-2
      openjpeg2 2.3.0-1
      openssh 7.6p1-1
      openssl 1.1.0.g-1
      opus 1.2.1-1
      pacman 5.0.2-2.1
      pacman-mirrorlist 20171201-1
      pcre 8.41-1
      pcre2 10.30-1
      pkg-config 0.29.2-1
      procps-ng 3.3.12-2
      python2 2.7.14-1
      renderproto 0.11.1-3
      sdl2 2.0.7-1
      sed 4.4-1
      s-nail 14.9.6-1
      speex 1.2.0-1
      speexdsp 1.2rc3-2.1
      texinfo 6.5-1
      v4l-utils 1.12.5-1
      vid.stab 1.1-1
      wavpack 5.1.0-1
      wayland 1.14.0-1
      wpa_supplicant 1:2.6-11
      x265 2.6-1
      xf86vidmodeproto 2.3.1-3
      xvidcore 1.3.4-1
      xz 5.2.3-1
      yajl 2.1.0-1
      zlib 1:1.2.11-2
      zziplib 0.13.67-1

      o Access Point functionality retested and enabled. This works only for WiFi interfaces with Access Point support:
        o Some WIFi interfaces have no Access Point support - Access Point will not start
        o Some WIFi interfaces have Access Point support, but are not capable of searching for other access points at the same time - You can attach with Access Point, but need to add your connection details manually
        o Some WIFi interfaces (including that on the Pi Zero W) have Access Point support and are capable of searching for other access points at the same time (this is what is really required)
      o Old library versions and restored after the upgrade
      o Random play works properly and really plays random tracks
    • Fixed spotify cache path:
    • Upgraded spop-rune (Spotify) to the latest version:
      o This does not solve all the problems, e.g. ‘undefined (undefined)’ is still there. But it no longer crashes and is therefore much faster
    • Upgraded MPD to the latest standard version (Music Player Daemon 0.20.15):
      o Removed the Rune version of MPD (mpd-rune and ffmpeg-rune)
      o Very fast MPD library build
      o Unfortunately Native DSD not supported
    • Added some packages for the hobbyist, these have not been integrated into Rune:
      o Shairport-sync installed, it is built with most options enabled
      o Shairport-sync-metadata-reader installed
      o Alac installed for shairport-sync
      o Brutefir installed. Not practically useful, it requires more CPU power than a B+/Zero can provide
      o Snapcast server and client installed
    • Modified RuneOS/RuneUI:
      o Fixed random play start-up failure after switching player mode
      o Fixed random play random disable. This happened after updating the settings UI
      o Fixed hardware-ID selection bug for Pi Zero W, lower and upper-case codes are now tested. See here for the bug report: raspberry-pi-zero-support-in-0-4-t3711-100.html#p24106. Thanks to porcupiney.
      o Fixed the way the player-ID is determined for the Pi Zero W when connecting via Access Point. Normally the player-ID is derived from the MAC-address of the Wired ethernet port. If this does not exit the MAC-address of the WiFi ethernet port is used.
      o Corrected redis_datastore_setup setting lock_globalrandom.
    • Upgraded the Arch Linux Kernel to 4.9.79-1:
      o Packages raspberrypi-firmware 20180131-1, raspberrypi-bootloader 20180131-1, linux-raspberrypi 4.9.79-1, linux-firmware 20180119.2a713be-1, cifs-utils 6.7-2 installed.
      o No changes to the supported audio overlays, for supported sound cards see here: raspberry-pi-zero-support-in-0-4-t3711-80.html#p23506
      o To identify this image:
         In debug: ‘Linux version 4.9.79-1-ARCH’, ‘HW platform: RaspberryPi (01)’ and ‘Build version: janui-20180202
         From SSH: ‘uname -r’ which returns ‘4.9.79-1-ARCH’, ‘redis-cli get hwplatformid’ which returns ‘01’ and ‘redis-cli get buildversion’ which returns ‘janui-20180202
Please contact me via PM if you need the package build and installation files/scripts for: shairport-sync, shairport-sync-metadata-reader, alac, brutefir or snapcast.

Re: Raspberry Pi Zero Support in 0.4

PostPosted: 05 Feb 2018, 22:00
by hondagx35
Hello janui,

thank you very much for the work you have done.


Re: Raspberry Pi Zero Support in 0.4

PostPosted: 03 Mar 2018, 03:32
by gearhead

I have a new Pi Zero W. I also have an image I have updated all the rune packages as well as the rest of the OS. Well, I made a copy of the image and got it going on a B+ so I could set up networking and everything. Well, It works, somewhat. I can send DLNA and shairport to it, but MPD does not run. Dmesg is not helpful. systemctl says MPD is running without errors. Keep in mind this image worked perfectly on my B+ and I took the card out and put it in the ZeroW and have my problem.

What I get in the UI is a spinning circle if I select anything in the library. If I click again, the circle goes away and I can select a song. It is this way navigating. Click, circle, click again and i can select. If I try to 'add and play', I get nothing added to the queue. If I select the queue, I get aspinning sircle on a black background. Since there is nothing in the queue, I cannot select anything. Nothing plays. I have pored through the logs and see nothing. What could cause this? I have tried updating the kernel and such. If I pull this image out and put it in a B+, it works fine.



Re: Raspberry Pi Zero Support in 0.4

PostPosted: 03 Mar 2018, 12:51
by janui
Hi gearhead,

I have a couple of versions of your image: 'RuneAudio_rpi-beta_20180129_2GB.img' and 'RuneAudio_rpi-beta_20180202_2GB.img'. I retested them both this morning on a Zero and B+ but cannot recreate your problems.

But after upgrading packages during the last week I have been having various problems with these and other arm6 images. There is a new Linux version for this platform (4.14.22-1), this seems a big step from 4.9.79-1 which I was using. I have been struggling with this for nearly a week now, but simple things which worked before do not work anymore. Even without upgrading Lunix, package upgrades are causing problems. During the week I have also seen very many package updates posted, the whole arch arm community seems busy making changes for the new Linux version. I have a feeling that arch6 is, at this moment, unstable. So much so that it is too unreliable for development.
I am planning to do nothing more with Rune for a week or so. I hope that will be enough time for things to stabilise.

I just tried the following with 'RuneAudio_rpi-beta_20180202_2GB.img':
Code: Select all
pacman -Rs mpd-rune ffmpeg-rune ashuffle-rune
pacman -Sy mpd libmpdclient libsoxr ffmpeg mpc libmpd
This seems to recreate your problem.

EDIT: Modified the MPD user and it all worked again, maybe this will solve your problem:
Code: Select all
id mpd
usermod -g audio mpd     
id mpd
usermod -a -G mpd mpd
id mpd
Output from the last command should be 'uid=45(mpd) gid=92(audio) groups=92(audio),45(mpd)'. Primary group of user 'mpd' must be 'audio', secondary 'mpd'.

Re: Raspberry Pi Zero Support in 0.4

PostPosted: 03 Mar 2018, 17:00
by gearhead

Thanks for the help, but that also did not work...
I made that change and still have the same issue. Strange that it does not act like that on a B+, just a Zerow. If I plug this image in my B+ and reset it, it boots comes up and is fluid and works just fine. On the zeroW, I cannot add anything to the queue and it always has the spinning circle. Strange.

I grabbed your image and was able to make that work for me.

Is there a reason why does your image from 20180202 not start in AP mode? I flashed it and powered up my zerow and did not see any SSID from it. To get it on my network (Zeros are a pain like this... No eth0 makes it hard), I copied my netctl profile from the other image booted it with keyboard and monitor attached. Enabled it from the command line "netctl enable profile" and rebooted and it connected and came up...

Also, you may want to install sudo on the image. If you install addons from rern to this image, it will fail the last couple lines of his script as there is no /etc/sudoers.d/.

Thanks for the help. Sorry you wasted time on it for me, though.

Re: Raspberry Pi Zero Support in 0.4

PostPosted: 03 Mar 2018, 19:46
by gearhead
OK, Here I am again...

I can get Janui's image going on my zerow. All good. I tried to update the UI to the 0.4b from Frank and it mostly works except the version of mpd on the image does not support soxr and mpd fails to start. I know nothing about soxr nor do I have interest in it. What I do know is that if I delete the line in the /etc/mpd.conf that references soxr, it all seems to work. Problem is that when I do that, I no longer get the UI page to edit the mpd config items... Where in the UI is this so I can delete the reference to soxr in the config? When I search on 'soxr' in all the files in /var/www 'soxr' is nowhere to be found. It must be comparing it to a file somewhere else. Even the _os/config files do not reference soxr... How does the UI know that I edited the mpd.conf file and where can I go to fix this issue?


Re: Raspberry Pi Zero Support in 0.4

PostPosted: 03 Mar 2018, 20:18
by janui
Hi gearhead,
On my Zero W the ‘20180202_runeaudio_raspberry1_raspberryZero_4.9.79-1’ image starts in AP mode, even bought a Zero W to test this. Don't understand why it’s not starting on yours. Is your power supply OK? Is your SD card OK?
Thanks for the info about sudo.
On your image you should install/upgrade mpfr and parted before carrying out any other actions:
Code: Select all
pacman -Sy mpfr parted


Re: Raspberry Pi Zero Support in 0.4

PostPosted: 03 Mar 2018, 20:32
by janui
Hi gearhead,
The soxr redis variable is set to generate soxr code in mpd.conf from runeaudio.php, function wrk_mpdconf. By installing the 0.4 code you have overwritten runeaudio.php, but the redis variable is still set. To fix the soxr issue:
Code: Select all
redis-cli hdel mpdconf soxr