Page 1 of 1

RuneOS-git php issue

PostPosted: 16 Dec 2014, 20:48
by aj78
On my Cubox I just did a git pull on the /usr/local/src/RuneOS directory and updated the Cubox-i packages that have been updated since the 0.3-beta release and now instead of the homepage get the following response:

Fatal error: Class 'Redis' not found in /srv/http/app/config/config.php on line 46

I've rebooted, /var/www is up to date with git and redis-server is running - for good measure I even reinstalled the phpredis-rune package in case updating the other packages had overwritten something, but without success. Am I missing something obvious? I had this all working before....

Re: RuneOS-git php issue

PostPosted: 17 Dec 2014, 00:18
by aj78
Now solved - I rebuilt the phpredis-rune package and it started working.

Re: RuneOS-git php issue

PostPosted: 23 Jun 2019, 16:52
by beasly
Any fix?

Re: RuneOS-git php issue

PostPosted: 03 Dec 2019, 06:36
by Kasey00
aj78 wrote:On my Cubox I just did a git pull on the /usr/local/src/RuneOS directory and updated the Cubox-i packages that have been updated since the 0.3-beta release and now instead of the homepage get the following response:

Fatal error: Class 'Redis' not found in /srv/http/app/config/config.php on line 46

I've rebooted, /var/www is up to date with git and redis-server is running - for good measure I even reinstalled the phpredis-rune package in case updating the other packages had overwritten something, but without success. Am I missing something obvious? I had this all working before....
pdfescape wp engine


I am having the same problem. Can anyone guide me?