Page 7 of 11

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 14 Sep 2016, 13:06
by Arnoedi
Hi,

Have you setup the Rpi as an AP as Frank explained? (page 2 of this discussion)

No, I found this thread after I managed to create an ap with the create_ap script, like specified in my previous post.

EDIT : Ok, I set up my AccessPoint like Frank explained, it works very well and the explanation is very easy to follow and to apply, great job. It doesn't change a thing on my other problems though.

Can you see the Runeaudio UPNP renderer?

Nope, with BubbleUPnP I can't see it.

the Airplay renderer? (using Airstream or Airaudio or equivalents)

Yes, I can see the Airplay renderer

While on your eth0:
Can you see the Rune UPNP renderer if you search for it?

No, but if I specify IP address and port I have a response from the device. However it is a HTTP 500 Error.

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 14 Sep 2016, 22:01
by hondagx35
Hi Arnoedi,

upmpdcli only supports the usage of one network interface at once.
UPnP network parameters

upnpiface

Network interface to use for UPnP. libupnp/pupnp only supports communicating on a single interface and will use the first found, this allows forcing the use of another interface.
upnpip

.....


Airplay works on booth interfaces.

EDIT : Ok, I set up my AccessPoint like Frank explained, it works very well and the explanation is very easy to follow and to apply, great job.

Thanks

Frank

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 15 Sep 2016, 17:52
by Arnoedi
upmpdcli only supports the usage of one network interface at once

Ok, so it's normal I don't see it on the WiFi.

But why isn't it working even on the eth0 interface (the one where it's activated) ? (see my post before for the error)

I tried to look at upmpdcli and MPD upnp documentation, but since the whole thing is managed by redis and the runeaudio php scripts I haven't managed to tweak the config to do some tests.

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 15 Sep 2016, 18:19
by hondagx35
Hi Arnoedi,

But why isn't it working even on the eth0 interface (the one where it's activated) ?

I have no idea what goes wrong on your system. Your debug data looks good.

Please check your firewall settings and try to disable temporarily.

Frank

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 15 Sep 2016, 18:59
by Arnoedi
Hi,

TL;DR : It works now, I was missing a configuration step, thank you.

The long story :
I went over my whole setup, and it turned out that it was my use of pulseaudio-dlna which was lacking.

For the record, to debug this I tried to scan my network for upnp renderer with the gupnp-tools package (from the command line with gsspd-discover and from the graphical interface). Since the runeaudio renderer was showing up and responding to the gupnp controls, I figured something was wrong mostly on the desktop side.

In fine I had to do first :
Code: Select all
pulseaudio-dlna --create-device-config
to properly detect and interface pulseaudio with the renderer, and then simply launching
Code: Select all
pulseaudio-dlna
enabled me to see the RuneAudio device on the pavucontrol manager and to stream the audio to it easily.

Strange I missed the create-device-config part on the tuto I read about the pulseaudio-dlna package.

Thank you for your time and your responses :-)

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 15 Sep 2016, 22:10
by johnbanks
Frank ...
Your Access Point solution has now been well tested by several users and it works.
You should be feeling confident.
Would it be a good idea to make this some kind of sticky thread so it always remains at or near the top of the forum listings?
Thx

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 16 Sep 2016, 20:51
by Joe90
Hi Frank and John Banks

I have my Ralink Rt5370 dongle now

It shows up with iw list and indicates it does AP

What is the name of the driver I need to put in the hostapd.conf file?

I have tried rt2800usb and rt2x00usb but these come up with an error - invalid / unknown driver

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 16 Sep 2016, 22:52
by hondagx35
Hi Joe90,

What is the name of the driver I need to put in the hostapd.conf file?

"driver=nl80211" does not work?

Frank

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 16 Sep 2016, 23:41
by Joe90
OK, getting somewhere, didn't realise the "driver" name was related to something else ;)

Using my phone I now see RuneAudioAP as a wireless network and can authenticate with RuneAudio, but I am not given an IP, thus not connected.

When I run "/usr/bin/hostapd /etc/hostapd/hostapd.conf" this time it returns

Code: Select all
nl80211: Could not configure driver mode
nl80211: deinit ifname=wlan0 disabled_11b_rates=0
nl80211 driver initialization failed
wlan0: interface state UNINITIALIZED->DISABLED
wlan0: AP-DISABLED
hostapd_free_hapd_data: Interface wlan0 wasn't started


ifconfig shows wlan0 up and running with an IP of 192.168.1.1

Re: RPi + Runeaudio +Wifi as Accesspoint

PostPosted: 17 Sep 2016, 00:04
by johnbanks
joe90 ...

I don't know which hostapd.conf file version you are using but if it contains the following lines ....

# Comment out following line if using a WIFI adapter with RT5370 chipset
ht_capab=[HT40][SHORT-GI-20][DSSS_CCK-40]

Then you should comment out (with a #) the line ... ht_capab=[HT40][SHORT-GI-20][DSSS_CCK-40]

Hope this helps