Page 1 of 1

Spotify Not Playing on RuneAudio

PostPosted: 29 Feb 2020, 17:07
by Eespinosa
Hello, all. Just got RuneAudio loaded on a Pi 2B. After some tinkering, I got my browser to log into Rune. I entered my Spotify credentials into the UI, but the Pi is not seen by the Spotify Android app or the Spotify Windows app. I have a Spotify Premium account, but that doesn't seem to matter. My phone and laptop are on the same network as the Pi 2. Is there something else that I can look into?

Re: Spotify Not Playing on RuneAudio

PostPosted: 07 Mar 2020, 10:36
by eea123
I don't have a Spotify account, but the few streaming stations I use I have to play from Rune under My Web radios. I'm not using the Spotify app, but I wouldn't think they could control Rune. The Rune app would just control the playback volume or pause on the few ones I use.

Re: Spotify Not Playing on RuneAudio

PostPosted: 10 Mar 2020, 07:41
by PieterDV
Hi Team behind this beautifull software,

I recently installed this software on my PI ; this is really great to play my NAS music & streaming radio.
What I really miss is the Spotify that is not working. This is a showstopper .

Are there any plans in the future to ensure that this will work again ?

Any way, many thanks to create this software as a work of art. I love it.

With kind regards,
Pieter

Re: Spotify Not Playing on RuneAudio

PostPosted: 15 Mar 2020, 10:25
by janui
Hello Pieter,
I have a version of RuneAudio 0.5b, a sort of pre-release for 0.6b which supports Spotify Connect. I use as my main player at the moment. It has some minor bugs, which I will probably not correct. You can try it if you want to, but please note that I will not provide any support. I am too busy with other things at the moment. I have not tested Rern's addon's, I would be surprised if this works. There is no equivalent version for the Pi 1 (models A, B or Zero), it works only for only for the Pi 2 (models 2B, 3B, 3B+ and 3A+) and there is no support for the Pi 4B.

Download link: http://www.mediafire.com/file/szaru2s7g ... mg.xz/file
Download file name: 20190301_runeaudio_rpiB2_prerelease.img.xz
Download file size: 1323376000 bytes (1262 MiB)
Download SHA256: C8D16D40788514A144F5FBE1256CFFF33417C43ED8684FABFECA8163C336F10B
Image file name: 20190301_runeaudio_rpiB2_prerelease.img
Image file size: 4510720000 bytes (4301 MiB)
Image SHA256: EC0C99ACE595DED44D7A7704CB4AE18596BE7412BAFDDC440CD8605BFED3847D

There are some updates for this image, a normal git pull will not work. You need to log in via SSH and run the following commands from the CLI:

cd /var/www
git config user.email "any@body.com"
git config user.name "anybody"
git config --global core.editor "nano"
git stash
git pull --no-edit https://github.com/gearhead/RuneUI.git/ 0.5b-dev
chown -R http.http /srv/http/
find /srv/http/ -type f -exec chmod 644 {} \;
find /srv/http/ -type d -exec chmod 755 {} \;
find /etc -name *.conf -exec chmod 644 {} \;
find /usr/lib/systemd/system -name *.service -exec chmod 644 {} \;
chmod 644 /etc/nginx/html/50x.html
chmod 777 /run
chmod 755 /srv/http/command/*
chmod 755 /srv/http/db/redis_datastore_setup
chmod 755 /srv/http/db/redis_acards_details
chmod 755 /etc/X11/xinit/start_chromium.sh
chown mpd.audio /mnt/MPD/*
chown mpd.audio /mnt/MPD/USB/*
chmod 777 /mnt/MPD/USB
chmod 777 /mnt/MPD/USB/*
chown -R mpd.audio /var/lib/mpd
/srv/http/command/rune_shutdown
reboot

If I change anything I will keep this up to date, occasionally running these commands again may provide an update.

janui

Re: Spotify Not Playing on RuneAudio

PostPosted: 22 Mar 2020, 10:15
by PieterDV
Hi,

I have no Linux experiences at all. ..But succeeded. :-)
It works!

Many thanks! :-)

Kind regards,
Pieter

PS: I saw this during the procedure; probably normal ?
root@runeaudio(rw):/var/www# chown mpd.audio /mnt/MPD/USB/*
chown: cannot access '/mnt/MPD/USB/*': No such file or directory
root@runeaudio(rw):/var/www# chmod 777 /mnt/MPD/USB
root@runeaudio(rw):/var/www# chmod 777 /mnt/MPD/USB/*
chmod: cannot access '/mnt/MPD/USB/*': No such file or directory
root@runeaudio(rw):/var/www# chmod 777 /mnt/MPD/USB/*
chmod: cannot access '/mnt/MPD/USB/*': No such file or directory
root@runeaudio(rw):/var/www# chown -R mpd.audio /var/lib/mpd
root@runeaudio(rw):/var/www# /srv/http/command/rune_shutdown

Re: Spotify Not Playing on RuneAudio

PostPosted: 22 Mar 2020, 15:53
by janui
Hello Pieter,
PS: I saw this during the procedure; probably normal ?
This is normal, no problem at all.
janui

Re: Spotify Not Playing on RuneAudio

PostPosted: 30 Mar 2020, 14:04
by PieterDV
Hi Janui,
Runeaudio is a fantastic software. Many thanks!!! I am so happy with this spotify version, that I have invested in a housing for my Raspberry Pi (hifiberry DAC pro) and also a Raspberry PI 7-inch touchscreen. Unfortunately, this does not work. Screens stops on message "Starting ..Runeaudio". Probably I have to install a screendriver? ..Or do some adaption in the config.txt file?

Via the webbrowser everything is working fine!

I have no real Linux knowledge but able to nano a file, run a command (via Putty). Do an file transfer, etc.. Can you please help me forward? Put me in the right direction ?

Many thanks in advance and kind regards,
Pieter

##### System info ######
Linux version 4.19.27-1-ARCH (alarm@alarmpi) (gcc version 8.2.1 20181127 (GCC)) #1 SMP PREEMPT Sun Mar 10 06:56:02 CDT 2019

System time: Thu Feb 21 14:45:47 CET 2019
System load: 0.50 0.11 0.04 1/158 967
Hardware model: Raspberry Pi 3 Model B Rev 1.2
Linux version: 4.19.27-1-ARCH
RuneOS/UI: 0.6b (gearhead) - Experimental Beta 0.6 20190220
Git Branch: 0.6b
HW platform: RaspberryPi (08)
Build version: janui-20180903-11
PlayerID: 088322f8d3c2e3cb3931d8625a4da4d042

Re: Spotify Not Playing on RuneAudio

PostPosted: 30 Mar 2020, 16:40
by PieterDV
I have found my problem after reading a lot of forum messages.
If you have the same problem ; go to setting and put local browser to "ON" :-)

You have to play a bit with the display zoom factor. I have a standarda RPI 7" touchscreen and have put this to 1. ..Still the track-timer, photo and volume are vertical, so you always have to scroll down.

Probably this is solved with a lower value than 1 ? ..But he does not acccept a lower value. How to do that ? ..Or do I have to solve that problem in another way ?

Thx for your feedback

Re: Spotify Not Playing on RuneAudio

PostPosted: 31 Mar 2020, 07:16
by PieterDV
Hi,
Once again I found the the problem: If you configure a 7 inch screen (local browser on) than you have to config the 'Display Zoom Factor' . Here you can NOT write a value lower than 1. So as example "0.7" is not accepted or interpreted correctly. you have to write ".7" instead. :-)