Page 18 of 20

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 08 Oct 2019, 15:52
by Alien8
rern wrote:Update 20191008
- Fix - Switches in setting pages not responding.
- Fix - NAS mount notification bug.
- Allow consume mode while others still on.

rern


Thanks Rern

NAS mount works again
Switches work again

BUT ....

the timezone always shows the first option of the list (Africa/Abijan)
luckily the system time is acutally still correct (system time is local time) (Europe/Brussels in my case)

an old bug seems to creep up again : changing the time zone 'scrambles' the I²S DAC settings to usually X10 DAC and it's impossible to set it back to my working config. Upon close of the system page, I get the reboot popup.
Almost every reboot has to be a cold boot, a warm boot just hangs after mounting/starting the USB peripeherals
After the boot, I don't have I²S output on the MPD page and no sound, analog output instead
If I go back to system page, I see that my dac is selected correctly yet the relevant section of the /boot/config.txt shows differently
Code: Select all
## RuneAudio HDMI & 3,5mm jack
dtparam=audio=on

## RuneAudio I2S-Settings
#dtoverlay=none


This is after the reboot, I actually checked : before the boot it has audio=off and dtoverlay=none

So I said no mas and manually changed this to
Code: Select all
## RuneAudio HDMI & 3,5mm jack
dtparam=audio=off

## RuneAudio I2S-Settings
dtoverlay=rpi-dac

and after reboot, everything appears to be fine (I get sound, I²S in MPD page)

No status info at the top of the system page

The switches do toggle on the system page but if I close the page and reopen it, all toggles are set to off again...

It seems that the system page has issues getting/setting the correct data

Could someone who has RPI2 confirm this if possible

A8

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 08 Oct 2019, 19:45
by tixs
Some earlier bugs seem to still exist on a fresh installation of Re1.2 (with all updates as of today applied):

- WLAN does not work for me. (My WLAN Router is not even shown, even though it sits in just 1 m distance and all other WiFi devices connect fine and SSID is not hidden). Setup of a static IP also fails. (I use a Raspberry Pi 3 B Rev. 1.2 with the standard Edimax WiFi dongle, onboard devices are switched of by removing the # in the config.txt in root folder immediately after writing the image (Re1.2) to the SD card. That approach worked well with the RuneAudio versions prior to Re edition.)
- Change of device name still shows no effect. Player remains to be browser accessible via runeaudio.local only but not via the changed player name as is shown in the System menu.
- Volume knob magically moves up or down by one notch from time to time without anything being touched. (I use hardware control of a HifiBerry DAC.)

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 08 Oct 2019, 21:09
by kiddy
tixs wrote:Some earlier bugs seem to still exist on a fresh installation of Re1.2 (with all updates as of today applied):

- WLAN does not work for me. (My WLAN Router is not even shown, even though it sits in just 1 m distance and all other WiFi devices connect fine and SSID is not hidden). Setup of a static IP also fails. (I use a Raspberry Pi 3 B Rev. 1.2 with the standard Edimax WiFi dongle, onboard devices are switched of by removing the # in the config.txt in root folder immediately after writing the image (Re1.2) to the SD card. That approach worked well with the RuneAudio versions prior to Re edition.)
- Change of device name still shows no effect. Player remains to be browser accessible via runeaudio.local only but not via the changed player name as is shown in the System menu.
- Volume knob magically moves up or down by one notch from time to time without anything being touched. (I use hardware control of a HifiBerry DAC.)


+1 and RuneAudio+R e1 works great and the sound is great. RuneAudio + R_e1.2 I have no way to run.

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 09 Oct 2019, 09:10
by Alien8
kiddy wrote:RuneAudio + R_e1.2 I have no way to run.


Same here, latest updates seem to make things worse
using a fresh Re1.2 image and the 'hacks' to get my dac configured I mentioned earlier, I can get the system to play webstreams, no mpd database

Latest update 'crashes' mpd when I try to build my music library
After sitting idle for a while, the whole ui becomes unresponsive and a cli reboot is required only to see it all happen again

A8

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 09 Oct 2019, 10:58
by R101
tixs wrote:Some earlier bugs seem to still exist on a fresh installation of Re1.2 (with all updates as of today applied):

- WLAN does not work for me. (My WLAN Router is not even shown, even though it sits in just 1 m distance and all other WiFi devices connect fine and SSID is not hidden). Setup of a static IP also fails. (I use a Raspberry Pi 3 B Rev. 1.2 with the standard Edimax WiFi dongle, onboard devices are switched of by removing the # in the config.txt in root folder immediately after writing the image (Re1.2) to the SD card. That approach worked well with the RuneAudio versions prior to Re edition.)
- Change of device name still shows no effect. Player remains to be browser accessible via runeaudio.local only but not via the changed player name as is shown in the System menu.
- Volume knob magically moves up or down by one notch from time to time without anything being touched. (I use hardware control of a HifiBerry DAC.)


I think you still need to blacklist a couple of drivers if you are using the Edimax dongle. Try adding two files to /etc/modprobe.d

blacklist-rtl8xxxu.conf containing the line: blacklist rtl8xxxu and blacklist-rtl8192cu.conf containing the line: blacklist rtl8192cu

Then disable the on-board in /etc/modprobe.d/disable_rpi3_wifi_bt.conf

If it still does not work check the output of the rfkill command. There was a bug which invoked this if you used the menu to disable wifi, and it did not go back to normal when you turned the wifi back on. It may have been fixed now.

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 09 Oct 2019, 17:04
by AndyF
@kiddy
What about permissions in /srv/http/data folder? Do you have an ext4-formatted USB-Stick?

Andy

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 09 Oct 2019, 18:24
by kiddy
AndyF wrote:@kiddy
What about permissions in /srv/http/data folder? Do you have an ext4-formatted USB-Stick?

Andy


Hi Andy, I did not check the / srv / http / data folder directory. USB formatted ext4 and worked. I can’t help with checking the / srv / http / data directory already formatted the card, returned RuneAudio + R e1
I can add that RuneAudio + R e1 cannot be updated, the system stops working after the update. It starts with an incomprehensible interface and some artifacts. I do not think that the original raspberry display that is connected prevents the system from working normally after the update
respectfully kiddy

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 09 Oct 2019, 18:47
by Toube
I can't get the 1.2 to install on my Raspberry Pi 3 Model B Plus Rev 1.3.
On the 3 Model B without the plus it installs.

I get the same problem I don't see any menu.
I have a ext4 formatted USB attached before I power on the Pi.

I redownloaded image and reimaged using Win32 disk imager. Still no luck. If I go to system page using url it will not show the runeversion .. it shows kernel version etc. but the runeversion is empty or only the rune icon is there.
If I go to the add-ons page using url and update the version to 17 of September and then go to the front page.. it will only show me a plus icon so the UI get totally messed up.
The difference between my plus on non plus version is that on the plus version I have the Allo digione signature inside and on the non plus I'm using a USB dac.

Any ideas?

-Toube

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 09 Oct 2019, 20:04
by tixs
R101 wrote:I think you still need to blacklist a couple of drivers if you are using the Edimax dongle. Try adding two files to /etc/modprobe.d

blacklist-rtl8xxxu.conf containing the line: blacklist rtl8xxxu and blacklist-rtl8192cu.conf containing the line: blacklist rtl8192cu

Then disable the on-board in /etc/modprobe.d/disable_rpi3_wifi_bt.conf

If it still does not work check the output of the rfkill command. There was a bug which invoked this if you used the menu to disable wifi, and it did not go back to normal when you turned the wifi back on. It may have been fixed now.


Thanks - will check, even though I don't think this procedure was required with RuneAudio prior to Re1.
But the possibilty to switch off onboard WiFi via the system (?) menu of Re1.2 seems not to work either since the switches were in off position.

I have to admit the recent version seems to be quite unstable. Menu items got completely lost after I added a couple of files on the USB stick which stores my music and run a database update. After a little bit of testing, I could only start RuneAudio with menu items if the USB stick was not mounted. Reset of RuneAudio didn't help. Had to reflash the whole image but did not yet start again. I just went back to the image of a system with the version prior to Re1. Will probably wait for a version that seems to be more stable (hopefully).

Re: RuneAudio+R e1 - An improved version of RuneAudio

PostPosted: 10 Oct 2019, 06:18
by rern
@tixs,

Since you don't like virtually everything about RuneAudio+R e1 and you've tried it, you should stay with your current version.

rern