Page 1 of 1

Installing Alsaequal

PostPosted: 30 Jan 2020, 16:32
by hokamyiu
hi there,

I'm trying to install Alsaequal on Rune Ver. 0.5 build janui-20180903-11 and followed the instruction from the below post -

tutorial-install-alsa-equal-t3178.html#p11556

I could only get as far as to step 3 -

pacman -S base-devel

always get these error messages

"error: failed retrieving file 'gcc-libs-8.2.1+20181127-1-armv7h.pkg.tar.xz' from mirror.archlinuxarm.org : The requested URL returned error:
404 warning: failed to retrieve some files
error: failed retrieving file 'gawk-4.2.1-2-armv7h.pkg.tar.xz' from mirror.archlinuxarm.org : The requested URL returned error: 404."

for all 33 packages during the process.

what could have gone wrong ?

Thanks
Keith

Re: Installing Alsaequal

PostPosted: 01 Feb 2020, 06:27
by hokamyiu
From the forums of Arch Linux, learned that pacman -S would cause inconsistencies on glibc, and pacman will not function after the command.

Nonetheless I've built another RuneAudio image and retried. Now I am running into another issue with pacman -Syu (which updates glibc) -

Enter a selection (default=all):
:: Starting full system upgrade...
:: Replace ca-certificates-cacert with core/ca-certificates? [Y/n] y
:: Replace libsystemd with core/systemd-libs? [Y/n] y
:: Replace pkg-config with core/pkgconf? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: libdmx: installing xorgproto (2019.2-2) breaks dependency 'dmxproto'
:: libxxf86dga: installing xorgproto (2019.2-2) breaks dependency 'xf86dgaproto'

It says it failed to prepare transaction as it could not satisfy dependencies ? How to resolve these dependencies?
BTW mine is a Raspberry Pi3 (not an odroid where the tutorial was for), are the steps the same ?

Appreciate your help!
Keith

Re: Installing Alsaequal

PostPosted: 10 Feb 2020, 13:12
by hokamyiu
hi,

Would greatly appreciate any help on resolving the above issue!

Thanks!
Keith