Raspberry Pi Zero Support in 0.4

Raspberry Pi related support

Re: Raspberry Pi Zero Support in 0.4

Postby janui » 22 Nov 2017, 13:09

Hi Mat,

Pi Zero first time boot can take 4/5 minutes, normal boot is less than 1 minute. Some (dis)advantages of this image (and Rune on a Pi Zero generally) are:
    1. The PI Zero has no onboard wired Ethernet. Wired ethernet is definitely better than WiFi for streaming radio, Spotify, AirPlay and UPnP/DLNA. The onboard WiFi on the Pi Zero W (and on the Pi B3) is not brilliant, if you want to use WiFi an external dongle is recommended. The Access Point function makes WiFi on the Zero W and B3 easy to set-up.

    2. AirPlay (shairport) consumes large amounts of CPU time on the Pi Zero. Even so, I have not yet experienced playback problems with this.

    3. The quality of the sound cards for the Pi Zero are, in general, not as good as those for the Pi B+/2/3 versions. On the other side of the coin, the Pi Zero sound cards are a lot cheaper than those for the Pi B models. You could choose to use a sound card for a Pi B+/2/3 on the Pi Zero, looks strange see here: raspberry-pi-zero-support-in-0-4-t3711-80.html#p23517 This provides you the option to start with a Zero and later upgrade to a B3.

    4. The Rune UI responsiveness is almost identical on the Pi Zero and B2/3.

    5. Total cost for my cheapest Pi Zero & TI PCM5102 DAC (including case, power, dongles, cables, SD Card, etc.) was about €30 (lots of ebay shopping and use of recycled parts to get the all bits so cheap). For my Pi B3 & HifiberryDacPlus (also including case, power, dongles, cables, SD Card, etc.) it was about €130. The price difference is significant.

    6. I do not expect a full functional version of the new Rune 0.4 being released for the existing Pi Zero model. I expect a lot of the extra features to be switched off, there are limits to what the Pi Zero can do. It would be nice to be proved wrong on this one ;)
janui
Last edited by janui on 10 Feb 2018, 12:09, edited 2 times in total.
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Raspberry Pi Zero Support in 0.4

Postby Mat » 27 Nov 2017, 16:59

Thanks janui. I appreciate your help. Mat
Mat
 
Posts: 21
Joined: 01 Jul 2015, 12:19

Re: Raspberry Pi Zero Support in 0.4

Postby zomtec » 02 Dec 2017, 21:21

How can i change the order of the library?
This not works in the new version. is-it-possible-to-change-the-order-of-the-library-t3133.html#p11164
In the last version it works.
zomtec
 
Posts: 15
Joined: 17 Jun 2017, 19:39

Re: Raspberry Pi Zero Support in 0.4

Postby janui » 03 Dec 2017, 22:09

Hi zomtec,
It should work fine, but you must minify the '/srv/http/assets/js/runeui.js' file after changing it. The minify instructions are here: post17072.html?hilit=minified#p17072
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Raspberry Pi Zero Support in 0.4

Postby janui » 10 Dec 2017, 19:09

Hi there,

Updated Rune arch6h Pi1 image for Pi Zero and legacy Pi models

I have published a new version of the Rune 0.3 Pi1 arch6h image for Pi A, A+, B, B+, Zero and Zero W.
You can find the image here: raspberry-pi-zero-support-in-0-4-t3711-70.html#p20577

This is basically a bug fix release, no new functionality. For details of the last functional release see here: raspberry-pi-zero-support-in-0-4-t3711-80.html#p23506

    • Changes:
      o Previous build: ‘20171109_runeaudio_raspberry1_raspberryZero_4.9.58-1.img’
      o New build: ‘20171209_runeaudio_raspberry1_raspberryZero_4.9.67-1.img’
    • Fix problem with libreadline.so.7:
    • Fixed a problem which occurs when expanding the Linux file system:
      o Packages parted 3.2-6 and device-mapper 2.02.176-1 installed
    • Upgraded Samba:
      o Connection problem when accessing Rune via the file share network from Windows 10 fixed
      o Package samba-rune removed
      o Packages samba 4.7.3-1, gnutls 3.5.16-1, nettle 3.4-1, p11-kit 0.23.9-1, libtasn1 4.12-2, dbus 1.12.2-1, dbus-glib 0.108-1 and talloc 2.1.10-1 installed
      o Modified smbd.service and nmbd.service to correctly start samba
      o Samba installation in RuneOS modified, documented, and made safe:
         no write access as default
         read access given only to the rune_samba_readme file as default, additional instructions in this file
    • Upgraded avahi:
      o Reliability problems when connecting to RuneIU from Windows with ‘http://runeaudio.local’ fixed
      o Package avahi 0.7-1 installed and enabled
    • Upgraded wget:
      o Some of Rerns Addons will now download correctly (no functional testing done)
      o Packages wget 1.19.2-1 libidn2 2.0.4-2 libpsl 0.18.0-2 installed
    • Expanded the Linux file system 3Gb:
      o Linux partition was more than 90% full, so no choice.
      o The image is now built to fit on a 4Gb Micro-SD card
    • Modified RuneOS:
      o Modified the distribution process to include the ‘test’ WiFi access profile
      o Fixed a problem to correctly refresh the image when the Player ID is cleared in the /dev menu
      o Made some small changes in the debug_collector used in the Debug screen to provide easier image identification
      o Fixed the sluggish RuneUI response when using Global Random by modifying rune_PL_wrk
      o Checked all the systemctl services and corrected those which should be disabled or enabled.
    • Upgraded the Arch Linux Kernel to 4.9.67-1:
      o Packages raspberrypi-firmware 20171119-1, raspberrypi-bootloader 20171201-1, linux-raspberrypi 4.9.67-1, linux-firmware 20171206.fdee922-1 and cifs-utils 6.7-2 installed.
      o No changes to the supported overlays, for supported sound cards see here: raspberry-pi-zero-support-in-0-4-t3711-80.html#p23506
      o To identify this image:
         In debug: ‘Linux version 4.9.67-1-ARCH’, ‘HW platform: RaspberryPi (01)’ and ‘Build version: janui-20171209
         From SSH: ‘uname -r’ which returns ‘4.9.67-1-ARCH’, ‘redis-cli get hwplatformid’ which returns ‘01’ and ‘redis-cli get buildversion’ which returns ‘janui-20171209
janui
Last edited by janui on 23 Dec 2017, 21:22, edited 1 time in total.
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Raspberry Pi Zero Support in 0.4

Postby thanhvo31 » 16 Dec 2017, 03:02

Nice job, @janui . Thank you.

I'd love "Modified the distribution process to include the ‘test’ WiFi access profile" to save time config Wifi.

I will treat my Zero team with new image and report.

Image
SBC alot of Pis and DAC HAT
OS: Volumio , RuneAudio, Openelec, Moode, Ubuntu
DAC: HRT ustreamer, Audioquest Dragonfly 1.2, TEAC UD-501
CD: Marrantz CD6005
Amp: NAD D3020, Cambridge CXA80
Spk: Q Acoustic Concept 20, KEF R300

thanhvo31
 
Posts: 56
Joined: 13 Nov 2014, 15:31
Location: Haiphong

Re: Raspberry Pi Zero Support in 0.4

Postby porcupiney » 04 Jan 2018, 20:43

Hi,

I have been having a problem with the recent 0.3beta for Pi Zero W. It was not seeing the wifi
SSID in my house
However, I installed two packages iw and crda, modified a file (/etc/conf.d/wireless-regdom) and also added an entry in
/etc/modprobe.d/cfg80211.cfg:
Code: Select all
options cfg80211 ieee80211_regdom=GB


And now my onboard wifi works!

Dave
Raspberry Pi Zero W; Rune 0.5b; JustBoom Zero HAT
Raspberry Pi B 2; Rune 0.5b; JustBoom HAT
porcupiney
 
Posts: 8
Joined: 20 Dec 2017, 17:26

Re: Raspberry Pi Zero Support in 0.4

Postby janui » 04 Jan 2018, 21:39

Hi porcupiney,
Thanks for the information. Could you post the output of the following commands:
Code: Select all
uname -r
redis-cli get buildversion
pacman -Q iw crda
Could you also post what you changed in /etc/conf.d/wireless-regdom. I am currently testing a new build and would also like to test these settings. Thanks in advance.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Raspberry Pi Zero Support in 0.4

Postby porcupiney » 05 Jan 2018, 11:20

Hi,

OK - here are the outputs you requested:
Code: Select all
[root@home-w ~]# uname -r
4.9.67-1-ARCH
[root@home-w ~]# redis-cli get buildversion
"janui-20171209"
[root@home-w ~]# pacman -Q iw crda
iw 4.9-2
crda 3.18-1


I had to manually download the iw tarball.

Also, I have found that the hwplatformid code was not working with my Pi Zero W.

I had to modify the code in runeaudio.php because it was checking for upper-case revision data.

Here is my cpuinfo:
Code: Select all
[root@home-w ~]# cat /proc/cpuinfo
processor   : 0
model name   : ARMv6-compatible processor rev 7 (v6l)
BogoMIPS   : 997.08
Features   : half thumb fastmult vfp edsp java tls
CPU implementer   : 0x41
CPU architecture: 7
CPU variant   : 0x0
CPU part   : 0xb76
CPU revision   : 7

Hardware   : BCM2835
Revision   : 19000c1
Serial      : 000000008a877913


/etc/conf.d/wireless-regdom has a load of environment settings for all countries in the world. All I did was uncomment the one applicable to me - WIRELESS_REGDOM="GB"

Cheers,

Dave
Raspberry Pi Zero W; Rune 0.5b; JustBoom Zero HAT
Raspberry Pi B 2; Rune 0.5b; JustBoom HAT
porcupiney
 
Posts: 8
Joined: 20 Dec 2017, 17:26

Re: Raspberry Pi Zero Support in 0.4

Postby janui » 05 Jan 2018, 18:28

Thanks porcupiney,
here are the outputs you requested:
CODE: SELECT ALL
[root@home-w ~]# uname -r
4.9.67-1-ARCH
[root@home-w ~]# redis-cli get buildversion
"janui-20171209"
[root@home-w ~]# pacman -Q iw crda
iw 4.9-2
crda 3.18-1
I was already using iw 4.9-2. A normal installation (pacman -Sy iw) worked without problems, but I had already upgraded many other packaged. Tried installing crda, but it caused the Access Point functionality to stop working.
I had to modify the code in runeaudio.php because it was checking for upper-case revision data.
I don't have a Zero W so it's great to get this infomatation (with an example). I have already included the code, thanks.
janui
User avatar
janui
 
Posts: 682
Joined: 20 Dec 2014, 12:55
Location: Ollanda

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 6 guests