Wireless on Rune

Raspberry Pi related support

Re: Wireless on Rune

Postby PierreG64 » 11 Jun 2015, 21:08

Hello! Sorry for my english.
I post to say many thanks for the coders of runeaudio and for the forumers who says how to configure wifi with runeaudio.
I have runeaudio 0.3, a raspi 2 with digi + of wifiberry connect to a teac ud-501 in french "Que du bonheur" (but happiness in english? )
I have no formation in programming and with just this code:

Command :
- wifi-menu

i have configure my wifi with an Edimax wireless nano USB adapter.
You have made me a happy man!

Thanks! Because before, all i have try don't working or was to difficult to understand for me.
PierreG64
 
Posts: 10
Joined: 11 Jun 2015, 20:46

Re: Wireless on Rune

Postby hondagx35 » 11 Jun 2015, 21:13

Hi PierreG64,

welcome to the forum.

With RP2 and Rune Audio wifi configuration should be much easier.
No need to use wifi-menu or other tools.

See here.

Frank
User avatar
hondagx35
Moderator
 
Posts: 2669
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Wireless on Rune

Postby PierreG64 » 11 Jun 2015, 23:59

Thanks Franck,
Yes it's really simple now. For people like me :D
I'm very happy with runeaudio.
PierreG64
 
Posts: 10
Joined: 11 Jun 2015, 20:46

Re: Wireless on Rune

Postby afick » 17 Jul 2015, 23:15

junaling wrote:Here's how I got wifi working using a TP-link 725N:

Install wifi driver for TP-link 725N :
a) pacman -S dkms-8188eu
b) systemctl enable dkms
c) systemctl start dkms

Config wifi:
a) ip link set wlan0 up
b) create profile: wifi-menu -o
c) start profile: netctl start <profile>
d) auto-start : netctl enable <profile>
e) /etc/modprobe.d/8188eu.conf
options 8188eu rtw_wmm_enable=1 rtw_power_mgnt=0

Refer to the arch wireless wiki for more details.

I've documented my setup here for future reference, hope it can be useful to anyone :

https://plus.google.com/109011453482291647619/posts

Hello,

sorry for diging-out very old post.

What I have:

-Rpi 1
- Wifi donge 725n
- RuneAudio - last nightly release.
- RuneOS - out-of-box without any update, just fresh os from iso.
I can't connect with my Hidden secure (wpa2) wifi network. Default driver didn't want to work

I want to 'install' those drivers in the same way but I can't becouse in repo my pacman didn't see linux-headers for 3.12.25-1-Arch kernel.
repo.PNG
repo
repo.PNG (16.51 KiB) Viewed 864 times


Even if I try to install all what they want, still get error
repo2.PNG
repo2
repo2.PNG (22.33 KiB) Viewed 864 times



Im trying to resolve it since 2 day but without success.


Please help :)
afick
 
Posts: 3
Joined: 17 Jul 2015, 22:54

Re: Wireless on Rune

Postby wakeskate » 18 Jul 2015, 21:35

I had to mess with this for a while to get wireless to work
after a reboot.

Goto /etc/netctl/ directory

Under that dir their is another dir called examples.
Look at the descriptions to determine which one you need.
For example if you want to setup a wireless network with wpa and static ip.
open the file named wireless-wpa-static

This iswhat you will see

Description='A simple WPA encrypted wireless connection using a static IP'
Interface=wlan0
Connection=wireless
Security=wpa
ESSID='MyNetwork'
Key='WirelessKey'
IP=static
Address='192.168.1.23/24'
Gateway='192.168.1.1'
DNS=('192.168.1.1')
# Uncomment this if your ssid is hidden
#Hidden=yes

So you don't overwrite the example copy the one you need
but rename it to wlan0.

cp wireless-wpa-static /etc/netctl/wlan0

This will copy that config file to the netctl dir and then you can edit it.

nano wlan0

edit this file to meet what you need.
Make sure to leave the ' ' around options and you must leave
the /24 on the end of the static ip address.

You can also add
Netmask='255.255.255.0'
after the Gateway entry

Don't change anything until you get to the ESSID entry
in this field type the name of the Wireless Network you want to
connect to again make sure to include the ' ' in the entry

example:
ESSID='mynetwork'

Key='WirelessKey'
is you WPA password

If you don't know your DNS server.
You can use OpenDNS.
DNS='208.67.222.222'
DNS='208.67.220.220'

After you have this file saved in the /etc/netctl directory reboot you Pi
and give it about 20-30 seconds to find the network and connect.

Note: Not a secure way to handle this with the WPA password stored in the clear
but it will get you up and running with wireless even after a reboot.

Hope this helps someone.....
wakeskate
 
Posts: 10
Joined: 18 Jul 2015, 20:58

Re: Wireless on Rune

Postby afick » 20 Jul 2015, 17:20

Hello,

I don't know how but it works :) it;s kind of mirracle :)

I tryied this solution few times but never worked. Now work for a firs time :)

Thank's a lot :). Now i'm waiting for 0.4 :)
afick
 
Posts: 3
Joined: 17 Jul 2015, 22:54

Re: Wireless on Rune

Postby Stert » 21 Jul 2015, 09:52

I'm having an issue with a 5ghz wireless N network.

I have wireless G and N networks running and want to use the N network for audio streaming. Problem is the AP does not appear in the settings page, only the G network.

I'm definitely using a wireless N adaptor, is there anything that I should try?
Stert
 
Posts: 7
Joined: 21 Jul 2015, 09:47

Re: Wireless on Rune

Postby azndoodle » 10 May 2016, 05:31

Has the wifi GUI been implemented in 0.4beta yet?
azndoodle
 
Posts: 4
Joined: 10 May 2016, 05:26

Re: Wireless on Rune

Postby hondagx35 » 10 May 2016, 12:06

Hi,

Has the wifi GUI been implemented in 0.4beta yet?

No idea what GUI your qustion belongs to, but wifi can be configured within RuneUI.

Frank
User avatar
hondagx35
Moderator
 
Posts: 2669
Joined: 11 Sep 2014, 22:06
Location: Germany

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: Google [Bot] and 1 guest