Wireless on Rune

Raspberry Pi related support

Re: Wireless on Rune

Postby MrBiek » 18 Mar 2014, 16:11

Orion wrote:We are working on a complete rewrite of Wi-Fi config GUI interface.
At the moment, you have to configure your Wireless connection manually (through SSH console).
RuneOS is ready for wireless setup.
You can follow Arch Linux Wiki - Wireless Setup Guide and configure your wireless connection.
I hope to introduce Wireless GUI setup in 0.4-beta.

Bye.
Simone



I cannot get any of this to work, also Rune is not showing up on my windows network, how do i enable samba?
MrBiek
 
Posts: 2
Joined: 01 Mar 2014, 08:13

Re: Wireless on Rune

Postby skrodahl » 20 Mar 2014, 00:41

Hi all, I have a solution that will work straight out of the box. The only requirement to successfully enable wireless, is that you have sufficient knowledge to login to your RuneAudio device. It will not involve any editing of configuration files in Linux, as I know that can be quite a difficult task for those who have little or no experience with Unix-based systems.

I am a bit reluctant to post the full instructions for wireless, since booting RuneAudio without a functioning ethernet connection will delete your MPD database. Running wireless only, without first booting with the network cable attached, will not let you mount any network drives. The moral is that the network cable needs to be connected while booting RuneAudio.

This is beta software, and you should not stress about this at all. The project is great, and its prospects are greater. With the proper warnings, you should be able to decide on your own whether or not to use this solution. Should you happen to boot RuneAudio without an ethernet connection (wifi enabled or not), the same thing will happen.

I intend to make this understandable for anyone who can SSH into their Raspberry Pi. If it seems like spoon feeding, that's because it is spoon feeding.

Preferred solution:
This is what you should do the first time you want to use Wi-Fi:

  • Always boot RuneAudio with the network cable connected.
  • Always connect your wireless network card before booting RuneAudio.
  • The first time you want to setup Wi-Fi, login to your RuneAudio (e.g. using SSH) device and run the command 'wifi-menu -o', without the quotes. The '-o' part is for safety, since this will produce a Wi-Fi profile. Without the '-o', you will have your Wi-Fi password saved in plain text. This might not bother you at all, but since it has no other effect I would recommend that you add those two extra characters this one time only.
  • You will get a (text based) menu allowing you to choose your network by using the arrow keys on your keyboard, and input the password.
  • Select the appropriate network and type in the password.
  • Your RuneAudio device should now be connected to the wireless network. You can detach the network cable and you should still be up and running (with another IP address, of course).
  • By following these steps, you have automatically created a network profile. Now you need to know the name of your profile, which is explained below.

What just happened, and where do I go from here?
From now on, you don't have to use the 'wifi-menu' command anymore. You will just need to use the network profile to connect to Wi-Fi.

Now, this was for the first connection to the wireless network. For all consecutive reboots, it will be a bit different. After running the command 'wifi-menu -o' a network profile will be created. This is how you will know what it's called:

  • After logging into your RuneAudio device (maybe you're already logged in after following the instructions above), you need to run the following command, again without the quotes:
  • 'ls /etc/netctl'
  • This will give you a list of files that reside in the folder /etc/netctl, which also is the list of your network profiles.
  • How do you know which one of the profiles to look for? It will contain the name of your wireless network, as well as what's called a device name. The device name is simply the Linux name for your wireless network card.
  • If your network name is "MyWireless", the profile name will most likely be "wlan0-MyWireless". It could be something different, but "MyWireless" will always appear in the profile name.
  • Make a note of the profile name, as it will be needed for the next steps.

Use the network profile for Wi-Fi connections:
To avoid any problems, remember the advice about (for now, until newer releases that support wireless are made available) always using the network cable when booting RuneAudio. Here are the three steps needed to enable Wi-Fi:

  • Connect the network cable, start your RuneAudio device.
  • Login to the RuneAudio device.
  • Assuming (as in the example above) that your profile name is "wlan0-MyWireless", issue the following command without the surrounding quotes:
  • 'netctl start wlan0-MyWireless'
  • That's all you should need to connect to the wireless network, and you can disconnect the network cable.

-------

Now this is where the instructions should end, to make sure you don't delete your music database. Keeping in mind that you won't actually harm anything else, that no music will be deleted, nor any settings, there is one more thing you could do. That is to make this setting "stick" between reboots, to not have to do the 'netctl start wlan0-MyWireless" command every time and just get connected to Wi-Fi automagically.

I strongly suggest that you refrain from doing this, all disclaimers you can think of apply here. The only way I can be held responsible for any problems is if a two-headed dragon eats your bran-flakes and loses 30 pounds along with the ability to breathe fire.

In order to connect to the wireless network automagically, again assuming that your network profile is called "wlan0-MyWireless", you need to do the following:

  • Boot your Raspberry Pi with both the network cable and the wireless network card attached.
  • Login to your Raspberry Pi and issue the following command (without the qoutes):
  • 'netctl enable wlan0-MyWireless'

Also, be sure to call me if an anorectic, smoke-blowing, constipated two-headed dragon complains that you're out of extra soft three-ply toilet paper.
-skrodahl

Muffsy Phono Preamp PP-3 || Audiobah TPA3116 || ESP P88 || ProJect Debut Carbon Espirit DC || RuneAudio / RaspBerry Pi / HifiBerry DAC || Dynaco A25
User avatar
skrodahl
Moderator
 
Posts: 160
Joined: 27 Jan 2014, 10:08
Location: Sweden

Re: Wireless on Rune

Postby Peter » 20 Mar 2014, 22:44

Great guide..... and the 3ply is as yet unused! Could your post be put somewhere as a sticky to aid other illiterates like me? :lol:
User avatar
Peter
 
Posts: 64
Joined: 06 Mar 2014, 23:32

Re: Wireless on Rune

Postby skrodahl » 21 Mar 2014, 01:16

Thanks :)
I suspect, and this is perhaps the main reason for posting the information, that the beta 0.3 will be made available sometime in the near future. (Sorry if I put to much pressure on the developers, that's not my intention.)

The new beta is said to include wireless support, effectively rendering this short guide obsolete.

The MPD database deletion pitfall exists until then, and I think it would be a disservice to use this as a sanctioned guide because of that. Personally, I think that adding more information about SSH, logging in, identifying the wlan device, getting hold of the IP-addresses and more is equally necessary to make this a complete guide.

Or maybe I'm just being too hard on myself, the devs/mods may decide otherwise. Still, glad I could be of help.

- Skrodahl
-skrodahl

Muffsy Phono Preamp PP-3 || Audiobah TPA3116 || ESP P88 || ProJect Debut Carbon Espirit DC || RuneAudio / RaspBerry Pi / HifiBerry DAC || Dynaco A25
User avatar
skrodahl
Moderator
 
Posts: 160
Joined: 27 Jan 2014, 10:08
Location: Sweden

Re: Wireless on Rune

Postby junaling » 22 Apr 2014, 18:34

Here's how I got wifi working using a TP-link 725N:

Install wifi driver for TP-link 725N :
a) pacman -S dkms-8188eu
b) systemctl enable dkms
c) systemctl start dkms

Config wifi:
a) ip link set wlan0 up
b) create profile: wifi-menu -o
c) start profile: netctl start <profile>
d) auto-start : netctl enable <profile>
e) /etc/modprobe.d/8188eu.conf
options 8188eu rtw_wmm_enable=1 rtw_power_mgnt=0

Refer to the arch wireless wiki for more details.

I've documented my setup here for future reference, hope it can be useful to anyone :

https://plus.google.com/109011453482291647619/posts
junaling
 
Posts: 8
Joined: 02 Apr 2014, 05:56

Re: Wireless on Rune

Postby cmh714 » 04 May 2014, 03:11

Thanks for a great write up that definitely assisted me in getting my wifi working....finally. My problem at the moment is not being able to set a static IP on the wired eth0 interface for some unknown reason....

I did however find a solution to the "needing the ethernet cable plugged in" problem.....from the archlinux wiki
Tip: To enable static IP profile on wired interface no matter if the cable is connected or not, use SkipNoCarrier=yes in your profile.

This worked for me....YMMV

EDIT: Well this fixed getting wifi to work without a cable....unfortunately the database is not accessible without a wire and rebuilds as posted above :(
Gonna try a loopback adapter if I can find it....
cmh714
 
Posts: 276
Joined: 04 May 2014, 03:06

Re: Wireless on Rune

Postby cmh714 » 04 May 2014, 16:55

So basically the failure is to mount anything when the ethernet cable is out....what gives with that? very odd.
cmh714
 
Posts: 276
Joined: 04 May 2014, 03:06

Re: Wireless on Rune

Postby cmh714 » 04 May 2014, 19:03

SOLUTION: An ethernet loopback cable works perfectly, fools the Pi into believing it has a live connection. My db is intact and appears to function properly, but I havent tried to add anything yet.

I had one laying around, but they are easy to make. Pin 1 to Pin3, Pin 2 to Pin 6 and voila a loopback adapter.

see here if you need more: http://www.maguire.com/page.php/troubleshooting.htm

EDIT: I Guess I spoke to soon...wishful thinking. You can see the db n the UI but the USB HD is not mounted again. Need to figure this out.... :)
cmh714
 
Posts: 276
Joined: 04 May 2014, 03:06

Re: Wireless on Rune

Postby cmh714 » 04 May 2014, 22:09

I just edited my fstab to include the mount for the USB and with the loopback adapter I mentioned above everything is working as expected. The db does NOT rebuild everytime, ie it is persistent now across reboots.

I also disabled dhcpd since I am using static. The eth0 looks setup correctly but was having issue getting it to accpet the static...but will keep playing.
cmh714
 
Posts: 276
Joined: 04 May 2014, 03:06

Re: Wireless on Rune

Postby junaling » 07 May 2014, 06:46

cmh714,

to get your wired connection working with static ip, your /etc/netctl/eth0 or whatever profile name you are using should look something like this:

Description='static eth0'
Interface='eth0'
Connection=ethernet
IP=static
Address=('192.168.1.15/24')
Gateway='192.168.1.1'
DNS=('192.168.1.1')

see here: https://wiki.archlinux.org/index.php/Netctl

note the /24 in the address is the netmask equivalent to 255.255.255.0
junaling
 
Posts: 8
Joined: 02 Apr 2014, 05:56

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest