Wi-Fi Connection Defaults to Google NameServers

ODROID related support

Wi-Fi Connection Defaults to Google NameServers

Postby EddieA » 05 Feb 2017, 23:12

While I was initially trying out Rune, via a wired connection I was able to resolve other machines in my network by name, including the server that holds all my music.

After switching to a Wi-Fi connection, the mount for my music failed. Eventually traced it down to a /etc/resolv.conf that only contained the default Google nameservers. Although in one of the many attempts, I thought I did see my own nameserver once, but could be mistaken as I was switching between wired and wireless lots of times.

Could this solely due to no configuration file for wlan0 network file being created under /etc/systemd/network/, because after manually creating one, I now get a correctly configured /etc/resolv.conf for my local network. Or could it be a timing issue and I've just been lucky on the last few attempts.

BTW the DHCP setting in /etc/systemd/network/eth0.network is set to: both. According to the man page, this shoul be "yes", "no", "ipv4", or "ipv6".

Cheers.
EddieA
 
Posts: 18
Joined: 30 Jan 2017, 22:06

Re: Wi-Fi Connection Defaults to Google NameServers

Postby hondagx35 » 05 Feb 2017, 23:22

Hi EddieA,

please tell us what image you are working on (see your debug data).

Newer images do not use networkd!

Frank.
User avatar
hondagx35
 
Posts: 3016
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Wi-Fi Connection Defaults to Google NameServers

Postby EddieA » 06 Feb 2017, 04:51

Don't see anything in the debug page that shows the image:
Code: Select all
###### System info ######
Linux version 3.10.80 (root@runeaudio) (gcc version 4.9.2 20150304 (prerelease) (GCC) ) #2 SMP PREEMPT Sat Aug 15 16:29:14 CEST 2015

system time:   Fri Feb  3 20:09:22 PST 2017

system load:   0.70 0.16 0.05 1/127 708

HW platform:   ODROID-C1 (09)

playerID:   097774dd8e208a508d631d33b0b32a0f6a

ssh'ing in gives this:
Code: Select all
RuneOs: 0.3-alpha (build 20140709)
RuneUI: 1.3-alpha
Hw-env: Odroid C1
ported by Frank Friedmann (aka hondagx35)

The image downloaded is:
Code: Select all
RuneAudio_odroid-c1_0.3-dev_20150824_2GB.img

Cheers.
EddieA
 
Posts: 18
Joined: 30 Jan 2017, 22:06

Re: Wi-Fi Connection Defaults to Google NameServers

Postby hondagx35 » 06 Feb 2017, 18:01

Hi EddieA,

your image is OK.

Rune doesn't use networkd.
We use netctl-auto for WiFi and netctl-ifplugd for ethernet.

Frank
User avatar
hondagx35
 
Posts: 3016
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Wi-Fi Connection Defaults to Google NameServers

Postby EddieA » 06 Feb 2017, 19:28

Frank, thanks for confirming what's used. I guess it was these that sent me down the wrong path:
Code: Select all
[root@runeaudio ~]# ls -l /etc/resolv.conf
lrwxrwxrwx 1 root root 32 Apr  1  2015 /etc/resolv.conf -> /run/systemd/resolve/resolv.conf

Code: Select all
[root@runeaudio ~]# cat /etc/resolv.conf
# This file is managed by systemd-resolved(8). Do not edit.
#
# Third party programs must not access this file directly, but
# only through the symlink at /etc/resolv.conf. To manage
# resolv.conf(5) in a different way, replace the symlink by a
# static file or a different symlink.

nameserver 2001:4860:4860::8844
nameserver 8.8.4.4
nameserver 2001:4860:4860::8888
# Too many DNS servers configured, the following entries may be ignored.
nameserver 8.8.8.8

Let me keep an eye on it.

BTW Are there any plans to support the C2. And will the new HiFi Shield 2 need any updates to the image.

Cheers.
EddieA
 
Posts: 18
Joined: 30 Jan 2017, 22:06

Re: Wi-Fi Connection Defaults to Google NameServers

Postby EddieA » 07 Feb 2017, 00:19

Frank. Even though this is using netctl-auto for WiFi it sure looks like the assignment of the nameservers still depends on a file in the /etc/systemd/network/ directory.

I just ran some tests where I re-booted the C1+ 10 times. 5 of the times I had a /etc/systemd/network/wlan0.network file in place and every time /etc/resolv.conf was configured with my local nameserver. For the other 5 re-boots, this file was not present. On every one of those, /etc/resolv.conf was configured to use the Google nameservers.

Cheers.
EddieA
 
Posts: 18
Joined: 30 Jan 2017, 22:06

Re: Wi-Fi Connection Defaults to Google NameServers

Postby EddieA » 27 Feb 2017, 09:08

And to add to the confusion, even though /etc/resolv.conf was correctly set at boot time to point to my local nameserver, at some point when it renewed the lease, it then switched over to the Google ones again.

Cheers.
EddieA
 
Posts: 18
Joined: 30 Jan 2017, 22:06

Re: Wi-Fi Connection Defaults to Google NameServers

Postby hondagx35 » 27 Feb 2017, 11:21

Hi EddieA,

please check this:
Code: Select all
root@runeaudio(rw):~# systemctl status dhcpcd
● dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/usr/lib/systemd/system/dhcpcd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
root@runeaudio(rw):~# systemctl status systemd-networkd
● systemd-networkd.service - Network Service
   Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:systemd-networkd.service(8)


If one is running then use:
Code: Select all
systemctl stop dhcpcd
systemctl disable dhcpcd
systemctl stop systemd-networkd
systemctl disable systemd-networkd


Frank
User avatar
hondagx35
 
Posts: 3016
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Wi-Fi Connection Defaults to Google NameServers

Postby hondagx35 » 27 Feb 2017, 12:33

Hi EddieA,

BTW Are there any plans to support the C2. And will the new HiFi Shield 2 need any updates to the image.

https://sourceforge.net/projects/runeau ... ROID%20C2/
odroid-c2-t3181-70.html#p14973

Frank
User avatar
hondagx35
 
Posts: 3016
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Wi-Fi Connection Defaults to Google NameServers

Postby EddieA » 27 Feb 2017, 19:39

Frank, not quite sure what you're suggesting that I stop/disable as the way you show it I would see 2 inactive services that I do the action on both.

Here is what I get from those commands:

Code: Select all
[root@runeaudio ~]# systemctl status dhcpcd
● dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/usr/lib/systemd/system/dhcpcd.service; disabled; vendor preset: disabled)
   Active: inactive (dead)
[root@runeaudio ~]#
[root@runeaudio ~]# systemctl status systemd-networkd
● systemd-networkd.service - Network Service
   Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
   Active: active (running) since Sun 2017-02-26 23:55:06 PST; 10h ago
     Docs: man:systemd-networkd.service(8)
 Main PID: 211 (systemd-network)
   Status: "Processing requests..."
   CGroup: /system.slice/systemd-networkd.service
           └─211 /usr/lib/systemd/systemd-networkd
[root@runeaudio ~]#


Cheers.
EddieA
 
Posts: 18
Joined: 30 Jan 2017, 22:06

support RuneAudio Donate with PayPal

Next

Return to ODROID

Who is online

Users browsing this forum: No registered users and 1 guest