Waveshare Spotspear 3.5" Touch Screen Working with Rune

Raspberry Pi related support

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby hondagx35 » 03 Sep 2017, 19:45

Hi luthier,

rlsten wrote:One suggestion: Look under Settings in the Rune Audio Menu and make sure Local Browser is set to off.

This is one solution or login via SSH.

Frank

- Get access to the console:
Use SSH from your PC
    If you are not familiar with SSH read this for Windows or this for Linux/MacOS
    The default login for RuneAudio is "root" with the password "rune" (without quotes).

- Use sftp to access files on Rune Audio:
Get WinSCP from here and install it.
When it opens setup the following:
- Session
File Protocol: SCP
Host name: The IP address of you Raspberry Pi
User name: root
Password: rune

That's it, connect and you can transfer files just by dragging and dropping.
User avatar
hondagx35
 
Posts: 2981
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby soyelrichal » 29 Jan 2018, 11:16

Hi!! I'm a novice in this of PI 3. Thanks for the tutorial, but I have a question. step number 5 I do not know how to do it ... any help? (Create the file /etc/X11/xorg.conf.d/99-calibration.conf ).
Thanks!!
soyelrichal
 
Posts: 3
Joined: 29 Jan 2018, 11:11

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby janui » 01 Feb 2018, 13:28

Hi soyelrichal,
Easiest way is to use nano. Get access to the console via SSH, see here: waveshare-spotspear-3-5-touch-screen-working-with-rune-t3859-40.html#p22370
Use nano like this:
Code: Select all
nano /etc/X11/xorg.conf.d/99-calibration.conf

Then copy the required content from the web page and paste it into nano (use the menu to paste). Clean up any empty lines by deleting them. Save is with the key combination CTRL & O, then exit nano with the key combination CTRL & X. Check your work with:
Code: Select all
cat /etc/X11/xorg.conf.d/99-calibration.conf

janui
User avatar
janui
 
Posts: 299
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby soyelrichal » 15 Feb 2018, 10:19

janui wrote:Hi soyelrichal,
Easiest way is to use nano. Get access to the console via SSH, see here: waveshare-spotspear-3-5-touch-screen-working-with-rune-t3859-40.html#p22370
Use nano like this:
Code: Select all
nano /etc/X11/xorg.conf.d/99-calibration.conf

Then copy the required content from the web page and paste it into nano (use the menu to paste). Clean up any empty lines by deleting them. Save is with the key combination CTRL & O, then exit nano with the key combination CTRL & X. Check your work with:
Code: Select all
cat /etc/X11/xorg.conf.d/99-calibration.conf

janui


hi! janui!! very thanks!!! inally I was able to follow all the steps, but I did not see runeaudio on the screen waveshare 3.5 ... could you provide an image with everything installed? It would be a great help!I am very novice...jjjj
soyelrichal
 
Posts: 3
Joined: 29 Jan 2018, 11:11

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby luthier » 19 Mar 2018, 19:23

Hello again guys, after some time i got back at this and got the 3.5" display to work but i am now facing a new issue.
The screen is in landscape mode which is fine but the touchscreen panel seems to be 90 degrees rotated relative to the display.
I have googled a good 3 hours now but nothing fixed this issue.
Anyone has any tips/help ?
luthier
 
Posts: 4
Joined: 03 Sep 2017, 12:03

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby luthier » 20 Mar 2018, 11:40

Alright in order to help others these are the full steps i took to get my 3.5" TFT touchscreen up and running with RuneAudio:
1)Download the image file for RuneOS v0.3-beta (23/03/2016) and burn to SD (I used Etcher)
2)Connect power and ethernet to rpi and boot the sd up
3)From a computer that is on the same network as the rpi open a browser and type runeaudio/ ,this is the control panel for RuneAudio and from here you can configure wifi access if you have a wifi module from the settings in the top right corner.
4)After internet access is fixed we need a file transferring program (i used FileZilla on windows) and an ssh client (i used putty).If you are on windows start a terminal and type in "arp -a" without quotes to find out which ip address the raspberry pi has or you can also see this in the runeaudio/ page by going to network in options.
5)From putty connect to the pi and login (user root, pass rune) and you should be greeted with some text.From there we need to use the tutorial in this post but it doesn't wanna work so instead do these commands:
pacman -S xorg-server --force ,and say "y" to all the confirmations about replacing packages and such
pacman -S xf86-video-fbturbo once the terminal comes back from updating xorg server(these commands may take few minutes so be patient)
pacman -S xf86-inpit-evdev
pacman -S xf86-video-fbdev
pacman -S xinput_calibrator
pacman -S glibc
Now follow the original tutorial from step 2. which is downloading the zip with the drivers and use FileZilla to transfer all the files and edit all the configs from there.
For step 3. in the /boot/config.txt the gpu_mem option already exists so do not paste it in, instead change the one that already exists to be 128.
Also instead of "dtoverlay=waveshare35a" type in "dtoverlay=waveshare35a-overlay.dtb,rotate=0" and find in line 75 the option lcd_rotate=2 and add a # to comment it out. The rotate=0 and commenting of lcd_rotate=2 was done because otherwise the touchpanel and display had a 90 degrees difference which i can not yet sort out to be in widescreen mode, but in portrait mode everything works.

Reboot the pi either from putty by typing "reboot" or from the browser go to menu turn off and click on the reboot button.
Once the pi reboots you notice that the display is not really working and you see a terminal there asking for a login.

Reconnect using putty and type in this command: "xinit -- :1" without quotes and the display will work! (ignore any errors, google says they are not important)
That's it the touchscreen works although it is in portrait mode.If anyone knows how to rotate it it would be awesome.
Thanks for everyone's help!!!
You're awesone
luthier
 
Posts: 4
Joined: 03 Sep 2017, 12:03

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby rlsten » 20 Mar 2018, 13:33

You might try rotate=90 or rotate=270 instead of rotate=0 in the line "dtoverlay=waveshare35a-overlay.dtb,rotate=0" to get landscape.
rlsten
 
Posts: 89
Joined: 25 May 2015, 18:06

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby luthier » 20 Mar 2018, 16:36

Yes but then the display would be in landscape mode but the touchscreen would still work as if it were in portrait mode.This is the only issue left for me to solve before the screen works perfectly
luthier
 
Posts: 4
Joined: 03 Sep 2017, 12:03

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby rlsten » 20 Mar 2018, 17:02

luthier wrote:Yes but then the display would be in landscape mode but the touchscreen would still work as if it were in portrait mode.This is the only issue left for me to solve before the screen works perfectly


I see; have you tried this:

http://www.runeaudio.com/forum/post13781.html?hilit=xinput_calibrator#p13778
rlsten
 
Posts: 89
Joined: 25 May 2015, 18:06

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby Ripa » 11 Jun 2018, 14:39

I have trying to make this work now for several days, still not working

I have the waveshare 3.5 inch RPI LCD (A) display even when i do this step by step in still no screen.
if i load the image thats on the disk the screen work, but not work with rune.

i there somebody that can help me out with this

i use rasberry 3 and want to use RuneAudio 0.4-beta for Raspberry Pi2/3

2)Connect power and ethernet to rpi and boot the sd up

3)From a computer that is on the same network as the rpi open a browser and type runeaudio/ ,this is the control panel for RuneAudio and from here you can configure wifi access if you have a wifi module from the settings in the top right corner.

4)After internet access is fixed we need a file transferring program (i used FileZilla on windows) and an ssh client (i used putty).If you are on windows start a terminal and type in "arp -a" without quotes to find out which ip address the raspberry pi has or you can also see this in the runeaudio/ page by going to network in options.

*** how can i access the RPI with filezilla? i have an ip address but i get an error***


5)From putty connect to the pi and login (user root, pass rune) and you should be greeted with some text.From there we need to use the tutorial in this post but it doesn't wanna work so instead do these commands:

pacman -S xorg-server --force ,and say "y" to all the confirmations about replacing packages and such
pacman -S xf86-video-fbturbo
pacman -S xf86-inpit-evdev
pacman -S xf86-video-fbdev
pacman -S xinput_calibrator
pacman -S glibc

**** i get error ***



Now follow the original tutorial from step 2. which is downloading the zip with the drivers and use FileZilla to transfer all the files and edit all the configs from there.
For step 3. in the /boot/config.txt the gpu_mem option already exists so do not paste it in, instead change the one that already exists to be 128.
Also instead of "dtoverlay=waveshare35a" type in "dtoverlay=waveshare35a-overlay.dtb,rotate=0" and find in line 75 the option lcd_rotate=2 and add a # to comment it out. The rotate=0 and commenting of lcd_rotate=2 was done because otherwise the touchpanel and display had a 90 degrees difference which i can not yet sort out to be in widescreen mode, but in portrait mode everything works.

Reboot the pi either from putty by typing "reboot" or from the browser go to menu turn off and click on the reboot button.
Once the pi reboots you notice that the display is not really working and you see a terminal there asking for a login.

Reconnect using putty and type in this command: "xinit -- :1" without quotes and the display will work! (ignore any errors, google says they are not important)
That's it the touchscreen works although it is in portrait mode.If anyone knows how to rotate it it would be awesome.
Thanks for everyone's help!!!
Ripa
 
Posts: 50
Joined: 04 Dec 2017, 03:55

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 0 guests