Waveshare Spotspear 3.5" Touch Screen Working with Rune

Raspberry Pi related support

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby kb06 » 17 Jun 2017, 17:59

clarindo wrote:Hi Frank, could you find out something about it? I really wish this system working ... Please, help me to find a way.

I've followed this tutorial and got the tft working. However, after boot the runeaudio login is required.
Before this instructions is need to change something in another file, like /boot/config.txt to skip login and start RuneUi Main Page?
The browser is enabled and I have tried use fb=0 and fb=1.


Clarido, Frank, any news in this case?
I have the same issue. TFT is working, but it requires log in to Rune. I would love to see RuneUI instead of login prompt.
kb06
 
Posts: 5
Joined: 17 Jun 2017, 15:38

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby clarindo » 05 Jul 2017, 12:34

I think this question has been left aside by administrators, but if anyone has this same problem and gets it resolved, let us know.
Thank you!
Clarindo
clarindo
 
Posts: 6
Joined: 24 May 2017, 02:22

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby hondagx35 » 05 Jul 2017, 15:21

Hi clarindo,

I think this question has been left aside by administrators, but

No, it has not.
But what do you think can we do without such hardware to test?

Frank
User avatar
hondagx35
 
Posts: 3013
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby rlsten » 11 Jul 2017, 20:08

I believe the problem with the Waveshare screen and Rune may be a conflict between the fbturbo driver and xorg server that has arisen since the March 2016 Rune Audio image was posted.

I tried a fresh install of RuneAudio_rpi2_rp3_0.4-beta_20160321_2GB from http://www.runeaudio.com/download/#raspberry-pi-3. When I attempted to download the fbturbo driver

Code: Select all
pacman -Sy xf86-video-fbturbo


I received this message:
Code: Select all
looking for conflicting packages...
:: xf86-video-fbturbo-git and xorg-server are in conflict (X-ABI-VIDEODRV_VERSION). Remove xorg-server? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: xf86-video-fbturbo-git and xorg-server are in conflict (X-ABI-VIDEODRV_VERSION<23


I could not figure out how to fix this problem. (I tried uninstalling and reinstalling xorg and various other files, but nothing worked.)

So, I got out my old image where the Waveshare screen was working, and copied fbturbo_drv.so (dated 11/22/2015) to /lib/xorg/modules/drivers. (I also followed the other steps outlined in the first post of this thread.)

After rebooting, the screen booted to the Rune interface, and touch worked.

I would be happy to attach the driver, but the upload attachment feature won't let me.
rlsten
 
Posts: 102
Joined: 25 May 2015, 18:06

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby rogercorrea » 09 Aug 2017, 02:54

But the RuneAudio interface is shown for you?
For me the 3.5 display worked but he stopped in login console. Don't showed the interface for me.

I'm using the Waveshare 3.5 display and Rpi 2 model B.
rogercorrea
 
Posts: 2
Joined: 09 Aug 2017, 02:50

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby rogercorrea » 09 Aug 2017, 03:54

Worked for me now.
I found the fbturbo driver in my LCD3.5 Waveshare image and copy to /lib/xorg/modules/drivers and solved my problem.
Thanks for shared.

In attach I uploaded the files for it.
Attachments
drivers.tar.gz
Zip file with the drivers for fbturbo for work with the Waveshare 3.5 display and RuneAudio.
(58.15 KiB) Downloaded 265 times
rogercorrea
 
Posts: 2
Joined: 09 Aug 2017, 02:50

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby ckiley3 » 01 Sep 2017, 07:22

I am having troubles with this as well, They just put out a new RuneAudio so maybe that is my issue? All i get is the same white screen
ckiley3
 
Posts: 1
Joined: 31 Aug 2017, 13:20

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby nikosr6 » 02 Sep 2017, 20:22

rogercorrea wrote:Worked for me now.
I found the fbturbo driver in my LCD3.5 Waveshare image and copy to /lib/xorg/modules/drivers and solved my problem.
Thanks for shared.

In attach I uploaded the files for it.

Hello hello!!!!
First of all thanks for the post...
Second...a question..all the files in the compressed folder going to /lib/xorg/modules/drivers ?
I got stuck in the RuneAudio log in screen...Raspbery Pi 3...Whaveshare 3.5 screen not A or B..
Thanks in advance Nikolas...
nikosr6
 
Posts: 3
Joined: 02 Sep 2017, 20:13

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby luthier » 03 Sep 2017, 12:10

Hi everyone, i am new to this forum and the RuneAudio player and i recently bought a TFT touch screen off ebay but i am having the following issue:

On RaspberryPi 2 and using the latest version of RuneAudio(beta) i login normally to access the console [User:root Pass:rune] but i can not type commands because the system boots into the player even after i log in to have terminal access!!

Trying to run this: pacman -Sy xf86-video-fbturbo in order to get my TFT unstuck from the log in screen

Always after login to terminal a white screen appears and i am inside the player before i can type any command
If anyone knows how to make the terminal stay i would greatly appreciate it
Thanks
luthier
 
Posts: 4
Joined: 03 Sep 2017, 12:03

Re: Waveshare Spotspear 3.5" Touch Screen Working with Rune

Postby rlsten » 03 Sep 2017, 15:27

One suggestion: Look under Settings in the Rune Audio Menu and make sure Local Browser is set to off.
rlsten
 
Posts: 102
Joined: 25 May 2015, 18:06

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest