Page 63 of 64

Re: [Addon] RuneUI Enhancement

PostPosted: 31 May 2019, 02:15
by rern
ga1580 wrote:I was experiencing some slow load time on the old interface, and updated to the UI Enhancement today. Pretty slick, and was working much quicker for a couple hours.

Now when I go to load the app on my phone or using browser on my pc, it just sits on the logo screen. Tried powering down and restarting, same issue. It isn't a delay, been sitting on the logo for 10 minutes. I know the system is up because I can still cast music to the Rune and it is working through the speakers, but I can't access any controls. Any idea what would have changed that quickly?

Try:
- Clear browser cache > refresh

If still no:
- SSH: copy and paste all + enter
Code: Select all
. /srv/http/addonsedit.sh
file=/srv/http/assets/js/enhancefunction.js
string=$( cat <<'EOF'
$( '#splash' ).click( function() {
   $( this ).remove();
} );
EOF
)
insert 'function removeSplash'
- Refresh browser
- Tap the logo to remove it. Anything missing?

rern

Re: [Addon] RuneUI Enhancement

PostPosted: 31 May 2019, 03:41
by rern
dynobot wrote:Your method is not a replication of the issue and actually will not solve the issue.

As stated in my previous posts 'after' RuneUI Enhancement is installed the ability to connect to wifi is lost. It does not matter how many times you reboot, try to scan, remove test files etc.

I identified a soft block of wlan0, this alone will make it impossible to connect to wifi. This was resolved by rfkill unblock 0

Method
-flashing a new image
-boot up
-removed the test file located in /etc/netctl
-connect to wifi network
-install Addons
confirm that wifi is not blocked - rfkill list, if it is unblock with rfkill unblock 0
-confirm wifi is still able to scan - redis-cli get wlans | tr -d '\\"' | sed 's/,/\n/g' | grep ESSID
-confirm new connection is in netctl - redis-cli get stored_profiles | tr -d '\\"[]' | sed 's/,/\n/g'
-confirm redis-cli save command is in file - cat /srv/http/enhance.php | grep 'redis-cli save'
-run netctl - netctl-auto switch-to ESSID
-run redis-cli save - system says OK
-reboot

After
-confirm wifi working rfkill list - OK working
-confirm network connection saved in netctl dir + redis-cli get stored_profiles | tr -d '\\"[]' | sed 's/,/\n/g' - OK saved
-check UI to verify network connected - NO not connected
-check ifconfig - NO wlan0 ***strange because via the UI I can scan and see networks****

Although wifi is working, the connection is saved in redis-cli the default 192.168.xxx.xxx persists = wifi connection not working

Even after you've edited your post which seems to imply that it's me who missed it. Which step in your "Method" did you install RuneUI Enhancement?

Does your solution work or not? if not, why didn't you try my "Method" which might work for you? If yes, what are you trying to do?

You know what? I think I have enough for this. Anyone with the same issue please step in otherwise I'll call it closed.

rern

Re: [Addon] RuneUI Enhancement

PostPosted: 31 May 2019, 04:34
by dynobot
rern wrote:
dynobot wrote:Your method is not a replication of the issue and actually will not solve the issue.

As stated in my previous posts 'after' RuneUI Enhancement is installed the ability to connect to wifi is lost. It does not matter how many times you reboot, try to scan, remove test files etc.

I identified a soft block of wlan0, this alone will make it impossible to connect to wifi. This was resolved by rfkill unblock 0

Method
-flashing a new image
-boot up
-removed the test file located in /etc/netctl
-connect to wifi network
-install Addons
confirm that wifi is not blocked - rfkill list, if it is unblock with rfkill unblock 0
-confirm wifi is still able to scan - redis-cli get wlans | tr -d '\\"' | sed 's/,/\n/g' | grep ESSID
-confirm new connection is in netctl - redis-cli get stored_profiles | tr -d '\\"[]' | sed 's/,/\n/g'
-confirm redis-cli save command is in file - cat /srv/http/enhance.php | grep 'redis-cli save'
-run netctl - netctl-auto switch-to ESSID
-run redis-cli save - system says OK
-reboot

After
-confirm wifi working rfkill list - OK working
-confirm network connection saved in netctl dir + redis-cli get stored_profiles | tr -d '\\"[]' | sed 's/,/\n/g' - OK saved
-check UI to verify network connected - NO not connected
-check ifconfig - NO wlan0 ***strange because via the UI I can scan and see networks****

Although wifi is working, the connection is saved in redis-cli the default 192.168.xxx.xxx persists = wifi connection not working

Even after you've edited your post which seems to imply that it's me who missed it. Which step in your "Method" did you install RuneUI Enhancement?

Does your solution work or not? if not, why didn't you try my "Method" which might work for you? If yes, what are you trying to do?

You know what? I think I have enough for this. Anyone with the same issue please step in otherwise I'll call it closed.

rern


I only highlighted in red the answer to your question that you kept asking and I kept answering. From my very first post I said it happened after i installed the UI enhancement but you ignored it and kept looking for things for me to try.

FWIW I tried each and every one of your suggestions as I posted on from the very first but none of them worked. I showed that I had soft-block for wlan0 which you seemed not to get because knowing that the wifi was being blocked meant that saving to redis-cli would not help, it wound not matter if i rebooted etc. If the wlan was blocked no wifi will work. I think you scanned over my posts and threw out fixes blindly. None of what you wrote worked....the UI is cute but as seen by the various random errors others also have its hit or miss.

Re: [Addon] RuneUI Enhancement

PostPosted: 31 May 2019, 04:40
by ga1580
rern wrote:
ga1580 wrote:I was experiencing some slow load time on the old interface, and updated to the UI Enhancement today. Pretty slick, and was working much quicker for a couple hours.

Now when I go to load the app on my phone or using browser on my pc, it just sits on the logo screen. Tried powering down and restarting, same issue. It isn't a delay, been sitting on the logo for 10 minutes. I know the system is up because I can still cast music to the Rune and it is working through the speakers, but I can't access any controls. Any idea what would have changed that quickly?

Try:
- Clear browser cache > refresh

If still no:
- SSH: copy and paste all + enter
Code: Select all
. /srv/http/addonsedit.sh
file=/srv/http/assets/js/enhancefunction.js
string=$( cat <<'EOF'
$( '#splash' ).click( function() {
   $( this ).remove();
} );
EOF
)
insert 'function removeSplash'
- Refresh browser
- Tap the logo to remove it. Anything missing?

rern


This worked! Thank you, what went wrong there?

Re: [Addon] RuneUI Enhancement

PostPosted: 10 Jun 2019, 11:48
by vennesch
Hi Rern,

I got a strange problem with my local browser.

After updating the add ons my local browser setting (on) won't stick after reboot. I tried the following steps:
1. Downloading and Reflashing latest 0.5 image
- Set local browser to on and Rebooted
* It works: local browser setting sticks
2. Upgrading latest 0.5 to build 11
- Set local browser to on and Rebooted
* It works: local browser setting sticks
3, Installied add ons
- Installed UI add on (local browser selected)
* Local browser is off
- Set local browser to on and save
- Local browser is on
- Rebooted
* Local browser is off again

So it seems something in the latest add-ons update breaks my local browser (via HDMI)

Any solution?

Thanks in advance,
Simon

Re: [Addon] RuneUI Enhancement

PostPosted: 10 Jun 2019, 15:25
by rern
Hi Simon,

There're some changes in setting of local browser which I don't know since when. Now it contains multiple fields instead of one. Apparently, it has broken the setting for a while. A fix will be released with next update soon.
In the mean time, try this for me after RuneUIe installed to confirm it's the case:
Code: Select all
redis-cli hmset local_browser enable '' zoomfactor '1.8' rotate NORMAL 'mouse_cursor' 0 'disable-splash' 1

Then try the setting again.

rern

Re: [Addon] RuneUI Enhancement

PostPosted: 10 Jun 2019, 16:10
by vennesch
rern wrote:Hi Simon,

There're some changes in setting of local browser which I don't know since when. Now it contains multiple fields instead of one. Apparently, it has broken the setting for a while. A fix will be released with next update soon.
In the mean time, try this for me after RuneUIe installed to confirm it's the case:
Code: Select all
redis-cli hmset local_browser enable '' zoomfactor '1.8' rotate NORMAL 'mouse_cursor' 0 'disable-splash' 1

Then try the setting again.

rern

Thanks for your reply Rern. I got an error with and without quations:
root@runeaudio(rw):~# redis-cli hmset local_browser enable '' zoomfactor '1.8' rotate NORMAL 'mouse_cursor' 0 'disable-splash' 1
(error) WRONGTYPE Operation against a key holding the wrong kind of value
root@runeaudio(rw):~# redis-cli hmset local_browser enable zoomfactor 1.8 rotate NORMAL mouse_cursor 0 disable-splash 1

Re: [Addon] RuneUI Enhancement

PostPosted: 10 Jun 2019, 16:14
by rern
Simon,

Sorry, it has to be deleted first:
Code: Select all
redis-cli del local_browser

Then run the code again.

rern

Re: [Addon] RuneUI Enhancement

PostPosted: 11 Jun 2019, 14:49
by rern
Update 20190611

- Lastfm playlist was fixed and renamed to Add similar in context menu
- Add submenu for Add+Play, Replace+Play and Reboot/ScreenOff
- Fix local browser setting

rern

Re: [Addon] RuneUI Enhancement

PostPosted: 17 Jun 2019, 06:13
by rern
Coming soon!

IMG_0076_2.jpg
IMG_0076_2.jpg (31.04 KiB) Viewed 107 times