Page 3 of 4

Re: Android Remote Control app stopped working

PostPosted: 25 Dec 2016, 23:44
by Kilgore
I can confirm that it is the current version(s) of Android System Webview that is causing the crashing. (I suspect the trigger is the tablet going to sleep....but I don't want to keep it awake 24/7 and it is sitting in the lounge being shared by two other members of the family) By uninstalling the updates the RUI worked no probs for days at a time. And when it eventually crashed I checked Android System Webview and found that there must have been a minor release which then auto-updated back onto my tablet. Uninstalling it fixed the issue again.

I have now turned off 'Auto-update apps' (Google play store > settings)
This does concern me as it means that I no longer will be keeping my entire system and apps up to date. It does explicitly state that the updates have a security component. If I was using this on a phone I would be more concerned but I am still a little uneasy.

I'm hopping that eventually either the Rune team will find and fix this issue with the RUI, or that a later version of the Android System Webview will somehow play nicely with RUI again. So I will try to remember to update Android System Webview in say 3 mths time, and try again.

Re: Android Remote Control app stopped working

PostPosted: 29 Dec 2016, 00:29
by Kilgore
I was prompted to upgrade the Android version from 5.0.2 (Lollipop) to 6.0.1 (Marshmallow) yesterday so I thought I'd give it a try in case this somehow (unlikely) fixed the issue.
Nope.
As part of the install the 'Android System Webview' was upgraded back up to 55.0.2883.91. As expected within a day the RUI failed again. So I have once again uninstalled the updates so Android System Webview is back to the old factory version.

Re: Android Remote Control app stopped working

PostPosted: 02 Jan 2017, 02:33
by elliotn
I'm kind of at a loss. I have an HTC phone running Lollipop (5.0.2) with the same version of WebView you mentioned, and it works fine. Likewise, I have a couple of Nexus devices running Nougat, which uses Chrome instead of WebView, and they work fine. I'm wondering if this might be a Samsung issue.

Any additional information you can provide?

Re: Android Remote Control app stopped working

PostPosted: 03 Jan 2017, 11:07
by Kilgore
Thanks elliotn for the info. Yes, perhaps it is some combination thing with Samsung.

As I reported a few days ago I have now upgraded to Marshmallow. However now when I 'uninstall updates' for the WebView, the app disappears from the list of apps. However the RUI continues to work. :o But sadly after a day or less, the RUI again dies and I get the little green android man.

It is strange that I was able to get the RUI to work no probs for many days with Lollipop by uninstalling the WebView updates....but not with Marshmallow.

I'll keep playing with it and see if I can spot a pattern or some more information and report back.

Re: Android Remote Control app stopped working

PostPosted: 07 Jan 2017, 02:05
by elliotn
I got a hold of a Samsung Galaxy Tab A (SM-T580) with Marshmallow (6.0.1) and the same Webview version. I added RuneAudioRemote Control, and it works fine. I'll leave it up and running over night and check tomorrow.

Any other hints?

Re: Android Remote Control app stopped working

PostPosted: 08 Jan 2017, 06:50
by Kilgore
Thanks so much Elliot for taking the trouble to cross check.

No other clues, but now I will start taking more detailed notes.
I had to restart the RPi yesterday and when I checked today, the RUI is still functioning. I checked a few times this afternoon and it is still responding fine.

I do note however that 'Android System Webview' has reappeared in my Application Manager and is version 55.0.2883.91. I guess that despite clicking 'uninstall updates' it remains in the background as there is no old version to roll back to now that i have upgraded to Marshmallow.

My tablet is model SM-T350

Unfortunately my phone is provided by work and is a Windows phone rather than an Android so the tablet remains my preferred option.

i'll report back tomorrow.

Re: Android Remote Control app stopped working

PostPosted: 09 Jan 2017, 03:48
by Kilgore
Not much more to report.
Powered the RPi sometime on Sat. RUI working OK
on Sun at 12:00 RUI still working OK...played 1 CD
at 15:00 woke tablet and RUI still working ....played another CD
at 16:00 woke tablet and RUI still working....played another CD
20:35 woke up tablet and found spinning wheel for a few secs and then nothing but little green android guy in top corner
Close app and open app - still failed
Power off tablet and back on - still failed

I was only user of the Tablet for all this time.

depower and power RPi again - all good and back to normal and the same CD I had in the RUI queue is still there.
Rune plays fine.

This morning - again RUI fail with Green man
Try to access RUI using chrome on a laptop, fail. Message is 'Site can't be reached - runes DNS address could not be found.'

In the tablet settings I have:
Power saving mode = off
Ultra power saving mode = off
scheduled software updates = off

I will go back into my router tonight and ensure that the 'Address reservation' I ad set up to give permanent fixed address for Runeis still in place. (my earlier post here shows what I tried issue-with-the-runeui-failing-after-a-period-of-inactivity-t4223.html )

Re: Android Remote Control app stopped working

PostPosted: 10 Jan 2017, 20:40
by vondes
can this app - Mobile Recorder 24 use remote control ?

Re: Android Remote Control app stopped working

PostPosted: 14 Jan 2017, 01:40
by Kilgore
i was quietly getting hopeful. RUI had been working on the tablet without issue for four days after I had last rolled back Android System Webview. Android System Webview remained not listed in the list of apps in the tablet. A couple of hours ago I checked and all still good, played some music, and Android System Webview remained not listed in apps.

But about an hour ago I again get that pesky little green guy and RUI was again dead. When I checked the list of apps, sure enough, magically, current version of Android System Webview had again installed itself despite me having selected no automatic updates in Google Play Store. I'm sure if I can just prevent Android System Webview updating itself I'd be OK.

Re: Android Remote Control app stopped working

PostPosted: 15 Jan 2017, 22:15
by elliotn
This item "Site can't be reached - runes DNS address could not be found." sounds like either a networking problem or a problem with the RuneAudio device. When this issue occurs, have you tried connecting to it from another computer?