USB Storage Bug?

General discussion about RuneAudio. Do not post any support or feature requests here.

USB Storage Bug?

Postby irishwill2008 » 07 Sep 2017, 14:20

I noticed sometimes when i plug a usb device in and plug it back out? It still shows as if its plugged in via usb storage on runeaudio.

Looking further into this, i noticed i have a folder in /mnt/MPD/USB/ which was there when plugged in. Inside the folder is blank.

So i have /mnt/MPD/USB/USBNAMEHERE/ but inside is blank and sometimes might even have a file called ".udevil-mount-point".

How can i solve this from happening? I notice this also happening if i power off the pi and plug out the usb device and turn it back on, this happens.

Not sure if always, but it does make this bug appear.

Anyone have a fix?
irishwill2008
 
Posts: 128
Joined: 26 Jul 2016, 14:49
Location: Ireland

Re: USB Storage Bug?

Postby hondagx35 » 07 Sep 2017, 17:53

Hi irishwill2008,

Anyone have a fix?

It is a feature and can not be fixed!
Not all things that are not done correct are bugs!

USB mounts

List of mounted USB drives. To safe unmount a drive, click on it and confirm at the dialog prompt.
If a drive is connected but not shown in the list, please check if USB automount is enabled.


safeunmount.jpg
safeunmount.jpg (81.96 KiB) Viewed 140 times


Frank
User avatar
hondagx35
 
Posts: 2722
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: USB Storage Bug?

Postby irishwill2008 » 08 Sep 2017, 12:16

Hi Frank,

Thanks for the reply.

But doesnt that force the user to have to unmount? I mean, yes its always good to safely unmount a drive as it can lead to crazy behavior with devices etc.

But regards to the windows OS. You dont see the USB device still showing after you pull the USB stick from the PC? Without safely removing using the tool?

To me, it seems like a bug as it shouldnt still show the usb as if its still plugged in when its not?

Just my opinion.

Thanks though!
irishwill2008
 
Posts: 128
Joined: 26 Jul 2016, 14:49
Location: Ireland

Re: USB Storage Bug?

Postby hondagx35 » 08 Sep 2017, 12:58

Hi,

To me, it seems like a bug as it shouldnt still show the usb as if its still plugged in when its not?

All your music files have to be in /mnt/MPD/ to get recognized by MPD.
Rune audio mounts your USB storage device automatically in this folder under /mnt/MPD/USB.
The system is not designed to automatically remove this folder when you unplug the USB device.
The reason for that is that MPD rebuilds the library each time you add or remove files from that folder structure.
This is not a problem with small storage devices but is a pain with large ones.
We can try to make an optional setting (auto-unmount) like the automount one from the library-settings page.

Frank
User avatar
hondagx35
 
Posts: 2722
Joined: 11 Sep 2014, 22:06
Location: Germany

support RuneAudio Donate with PayPal


Return to General discussion

Who is online

Users browsing this forum: No registered users and 1 guest