USB Audio Low volume

Raspberry Pi related support

USB Audio Low volume

Postby Toube » 10 Oct 2018, 08:21

Hi guys,

firstly I'd like to thank you for providing such an innovative and beautiful application for playing music.
I really like the UI, I firstly tried the Pi MusicBox but it was just not my thing.

Sorry for being lazy and not searching through the forums.
I'm using the release version: 0.4b (build: 20170229) on a Raspberry Pi 3

I have a Asus Xonar U7 MK2 usb sound card and it works really well but I get a bit of low volume with it.
Tried using alsamixer through terminal, but it doesn't seem to be doing anything.
I have hardware volume enabled in the settings.
Is there anything I can try to get the volume a bit louder?

Debug output:
https://pastebin.com/WDvgs09p

Regards and many thanks.
Toube
Toube
 
Posts: 20
Joined: 10 Oct 2018, 08:10

Re: USB Audio Low volume

Postby Toube » 10 Oct 2018, 13:48

I tried to follow this: volume-low-with-iqaudio-dac-t2861.html
How do set the volume level in alsamixer? If I use arrow up keys for each channel the volume will increase but the volume know on the UI show totally different value than the alsamixer. How can I get the volume know in the UI to be in sync with alsamixer volume?
Toube
 
Posts: 20
Joined: 10 Oct 2018, 08:10

Re: USB Audio Low volume

Postby Toube » 10 Oct 2018, 14:05

if I use amixer to set volume for like 60% it will print out the following:

amixer -c 0 set PCM 60%
Simple mixer control 'PCM',0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right - Rear Left - Rear Right - Front Center - Woofer - Side Left - Side Right
Limits: Playback 0 - 127
Mono:
Front Left: Playback 77 [61%] [-50.00dB] [on]
Front Right: Playback 77 [61%] [-50.00dB] [on]
Rear Left: Playback 77 [61%] [-50.00dB] [on]
Rear Right: Playback 77 [61%] [-50.00dB] [on]
Front Center: Playback 77 [61%] [-50.00dB] [on]
Woofer: Playback 77 [61%] [-50.00dB] [on]
Side Left: Playback 77 [61%] [-50.00dB] [on]
Side Right: Playback 77 [61%] [-50.00dB] [on]

This will also show the UI volume with 61 as volume.
Toube
 
Posts: 20
Joined: 10 Oct 2018, 08:10

Re: USB Audio Low volume

Postby Toube » 11 Oct 2018, 06:51

Let me rephrase my question.
How can I set the volume control knob in the UI so that it matches the alsamixer settings. Now it seems that when turning the UI knob to 40 % it is the same as the alsamixers level 5db and there is barely any sound. Is it possible to make it produce sound when turning the knob from 0% and upwards?
Toube
 
Posts: 20
Joined: 10 Oct 2018, 08:10

Re: USB Audio Low volume

Postby hondagx35 » 11 Oct 2018, 17:04

Hi,

please try:

- set software control
- turn up the volume to 100%
- set hardware control

Frank
User avatar
hondagx35
 
Posts: 2990
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: USB Audio Low volume

Postby Toube » 11 Oct 2018, 17:42

hondagx35 wrote:Hi,

please try:

- set software control
- turn up the volume to 100%
- set hardware control

Frank

Hi Frank,

Yes thanks I will try that.
Appreciated.

-Toube
Toube
 
Posts: 20
Joined: 10 Oct 2018, 08:10

Re: USB Audio Low volume

Postby Toube » 12 Oct 2018, 07:23

Hi,
all working after I updated the mpd using the addon.

Regards,
Toube
Toube
 
Posts: 20
Joined: 10 Oct 2018, 08:10

Re: USB Audio Low volume

Postby Toube » 12 Oct 2018, 09:23

One other that thing that stopped working after updating and editing the mpd.conf.. I can't turn the volume using the sound cards own volume knob.
This is how the mpd.conf currently looks like:
Code: Select all
###################################
# Auto generated mpd.conf file
# please DO NOT edit it manually!
# Use RuneUI MPD config section
###################################

state_file   "/var/lib/mpd/mpdstate"
zeroconf_enabled    "yes"
zeroconf_name    "runeaudio"
bind_to_address "/run/mpd.sock"
bind_to_address    "any"
port    "6600"
max_connections    "20"
user    "mpd"
group    "audio"
db_file    "/var/lib/mpd/mpd.db"
sticker_file    "/var/lib/mpd/sticker.sql"
pid_file    "/var/run/mpd/pid"
music_directory    "/mnt/MPD"
playlist_directory    "/var/lib/mpd/playlists"
follow_outside_symlinks    "yes"
follow_inside_symlinks    "yes"
auto_update    "no"
filesystem_charset    "UTF-8"
id3v1_encoding    "UTF-8"
volume_normalization    "no"
audio_buffer_size    "4096"
buffer_before_play    "20%"
gapless_mp3_playback    "yes"

input {
   plugin    "curl"
}

decoder {
   plugin    "ffmpeg"
   enabled "yes"
}
replaygain    "off"

audio_output {
   name       "bcm2835 ALSA_1"
   type       "alsa"
   device       "hw:0,0"
   mixer_control    "PCM"
   mixer_type    "hardware"
   mixer_device    "hw:1"
   auto_resample    "no"
   auto_format    "no"
}

audio_output {
   name       "Xonar U7 MKII"
   type       "alsa"
   channels   "6"
   device    "ch51"
   mixer_control    "PCM"
   mixer_type   "hardware"
   mixer_device   "hw:1"
   auto_resample    "no"
   auto_format    "no"
   enabled    "yes"
}


audio_output {
   name       "bcm2835 ALSA_2"
   type       "alsa"
   device       "hw:0,0"
   mixer_control    "PCM"
   mixer_type    "hardware"
   mixer_device    "hw:1"
   auto_resample    "no"
   auto_format    "no"
}



Anything I'm missing there?

-Toube
Toube
 
Posts: 20
Joined: 10 Oct 2018, 08:10

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests
cron