Unable to select Analog Output via 3.5 Audio Jack

Raspberry Pi related support

Unable to select Analog Output via 3.5 Audio Jack

Postby ceejayemm » 01 Jul 2018, 16:26

I have flashed a new SD card with the latest 0.4 beta from Frank on a Raspberry PI 2B. This works Ok UNTIL I make any changes (other than changing the time zone) on the Settings page. At this point the ALSA mixer seems to get removed and I loose all ability to output audio from the 3.5mm Audio Jack., on the MPD / Audio Output Interface it says 'Nothing to Select'. I am not using a DAC and simply want to use the analog audio output.

My PI details are:

RuneAudio: Ver. 0.4b build 20170229
Arch Kernel: Linux runeaudio 4.4.39 ARCH+
Raspberry PI: RaspberryPi2 (08)
Network: Ethernet connected
DAC: None, output via RPi 3.5mm audio socket

Chris
ceejayemm
 
Posts: 10
Joined: 29 Oct 2016, 18:13

Re: Unable to select Analog Output via 3.5 Audio Jack

Postby JenniferT » 02 Jul 2018, 12:44

If on Raspian Jessie then the audio icon top right will let you select the relevant output.
It may still be defaulting to the HDMI, so might only be getting noisy lines.

Also, the analog audio out by default is a bit staticy. Work is being done to fix this and it's expected to be rolled out soon.
JenniferT
 
Posts: 3
Joined: 04 Dec 2017, 09:28
Location: CA, United State

Re: Unable to select Analog Output via 3.5 Audio Jack

Postby hondagx35 » 02 Jul 2018, 16:18

Hi Chris,

if there is no output option the 3,5mm jack and HDMI output is disabled.

It can be enabled on the settings page:
analog.png
analog.png (36.91 KiB) Viewed 87 times


You also can check the /boot/config.txt for this lines:
Code: Select all
## RuneAudio HDMI & 3,5mm jack
dtparam=audio=on


Frank
User avatar
hondagx35
 
Posts: 2971
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Unable to select Analog Output via 3.5 Audio Jack

Postby ceejayemm » 02 Jul 2018, 21:37

Frank

The HDMI and 3.5mm Jack setting IS enabled but still no analog output. I am away from home until later in the week but will try the config.txt option when I get home.


Thanks


Chris
ceejayemm
 
Posts: 10
Joined: 29 Oct 2016, 18:13

Re: Unable to select Analog Output via 3.5 Audio Jack

Postby ceejayemm » 05 Jul 2018, 11:00

Frank

Adding:

## RuneAudio HDMI & 3,5mm jack
dtparam=audio=on

to the config.txt file and rebooting solved my issue. I now have the 3.5mm jack working again.

Thanks

Chris
ceejayemm
 
Posts: 10
Joined: 29 Oct 2016, 18:13

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest