Temperature readout in the web interface

Suggestions/requests/ideas for RuneAudio core features and functions

Temperature readout in the web interface

Postby Bignumbas » 09 Aug 2019, 01:50

It would be really good to have a temperature readout in the web interface somewhere with the advent of the pi 4.
Currently I have pi-hole co-installed and that gives it to me and I found vcgencmd in /opt/vc/bin so that helps.
I am running the pi 4 without a case, heatsinks installed and a pifi DAC+ hat and it runs at 34C with a fan blowing in from the card end.
Without it it runs around 44C, I think a case would make this higher plus I am in Australia and its in the middle of winter at the moment.
Max air temp at the moment is around 23C not 30C+
Running Kodi with Netflix on the pi4 resulted in 80C+ and crashing so this iteration is heat sensitive and it is recommended to have a fan

I have another post here on running runeaudio on the pi4 which has photos of my system. Amazingly the sound seems louder and clearer,
Don't know whether I am imagining that or not.
runeaudio-0-5-beta-is-running-ok-on-my-rpi-4b-2gb-t6867.html

cheers


pihole_temp.png
pi-hole temp readout
pihole_temp.png (34.99 KiB) Viewed 300 times

vcgencmd_temp.png
vcgencmd measure_temp
vcgencmd_temp.png (36.29 KiB) Viewed 300 times
Attachments
pi4- runeaudio.jpg
fan placement
pi4- runeaudio.jpg (64.96 KiB) Viewed 300 times
Bignumbas
 
Posts: 7
Joined: 20 Feb 2019, 00:36

Re: Temperature readout in the web interface

Postby janui » 09 Aug 2019, 10:51

Hi Bignumbas,
I will put your CPU temperature indicator on my list of things to do.
In the meantime you can try a couple of things to make the PI 4 run cooler by modifying some parameters in /boot/config.txt.
You can reduce the temperature at which the Pi will start reducing its CPU cycle rate (throttling). This worked really well with the PI Zero when overclocked. Try adding this:
Code: Select all
temp_limit=70
You could also try removing the turbo mode, the idea here was that speeding up and slowing down the CPU rate (turbo on demand) would have an effect on the sound quality. But the Pi 4 is now so fast that it may not be needed. In fact this may now be creating more problems than it is solving because a hot CPU will create noise, this may be worse than the turbo on demand effect. Try changing this:
Code: Select all
force_turbo=1
to this:
Code: Select all
force_turbo=0
Underclocking and undervolting the CPU is a tactic which may be the ideal route, but I do not have any validated settings available for the Pi 4. The following settings work pretty good on the Pi 3 B+, you could try them:
Code: Select all
arm_freq=1000
sdram_freq=500
core_freq=400
gpu_freq=300
over_voltage=-3
over_voltage_sdram=-3
temp_limit=70
force_turbo=1
janui
User avatar
janui
 
Posts: 654
Joined: 20 Dec 2014, 12:55
Location: Ollanda

support RuneAudio Donate with PayPal


Return to Feature request

Who is online

Users browsing this forum: No registered users and 0 guests