Still supported? and a network question

Raspberry Pi related support

Still supported? and a network question

Postby three_jeeps » 29 Apr 2019, 21:13

I am experimenting with various players and Rune is next on the list. In looking at the release version/date, the 'stable' for download for the RPi3b+ 0.3, which uses MPD v 18.3 (interesting because v0.1 used MPD V 18.6) and the release date is 2017.

I see there are a few betas released for the RPi since then but it seems they are not 'official stable'?
MPD has had a significant upgrade with v19 (a lot of fixes) and currently in version 21.x (IIRC). So, my question is:
Is rune being actively maintained and upgraded?
If I am to take it for a test drive, what version should I try?
The UI looks a lot like the UI on Volumio, does the Rune UI show album artwork?
Is there a 'Users Manual'? I find user 'hints' sprinkled throughout the documentation but nothing specific to how to use the UI.
Will Rune connect to a 'Windows share"? e.g. A directory on a second or third disk in a w10 environment that has been shared using the native Windoz sharing. If so, where is the information on how to make this happen?
Thanks!
J
three_jeeps
 
Posts: 4
Joined: 29 Apr 2019, 20:55

Re: Still supported? and a network question

Postby janui » 29 Apr 2019, 22:22

Hi three_jeeps,
Try this version: runeaudio-0-5-beta-for-all-raspberry-pi-models-t6532.html#p25819
Gearhead and I are maintaining this version. A new version is also on the way.
three_jeeps wrote:The UI looks a lot like the UI on Volumio, does the Rune UI show album artwork?
Yes
three_jeeps wrote:Is there a 'Users Manual'? I find user 'hints' sprinkled throughout the documentation but nothing specific to how to use the UI.
See here, its basically the same, but now has some extra undocumented features: http://www.runeaudio.com/documentation/
three_jeeps wrote:Will Rune connect to a 'Windows share"?
Yes, see the Sources UI.
janui
User avatar
janui
 
Posts: 624
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Still supported? and a network question

Postby three_jeeps » 29 Apr 2019, 23:21

Thank you. I'll give it a spin.
If the version you suggested is newer, why isn't it the 'stable' download, as opposed to v0.3?
A suggestion for documentation: A publication date and successive update dates would be *real helpful* to a reader, along with what version of Rune it correlates with.
three_jeeps
 
Posts: 4
Joined: 29 Apr 2019, 20:55

Re: Still supported? and a network question

Postby three_jeeps » 30 Apr 2019, 03:58

janui wrote:Hi three_jeeps,
Try this version: runeaudio-0-5-beta-for-all-raspberry-pi-models-t6532.html#p25819
Gearhead and I are maintaining this version. A new version is also on the way.
three_jeeps wrote:The UI looks a lot like the UI on Volumio, does the Rune UI show album artwork?
Yes
three_jeeps wrote:Is there a 'Users Manual'? I find user 'hints' sprinkled throughout the documentation but nothing specific to how to use the UI.
See here, its basically the same, but now has some extra undocumented features: http://www.runeaudio.com/documentation/
three_jeeps wrote:Will Rune connect to a 'Windows share"?
Yes, see the Sources UI.
janui


I spent an evening playing with this. To be honest, I had a number of problems. I kept notes when I did my limited testing. I'd be happy to send them to you. I can also dump some logs if you tell me which ones and how to get to the OS and grab them. Let me know where to send them.
Thanks
J
three_jeeps
 
Posts: 4
Joined: 29 Apr 2019, 20:55

Re: Still supported? and a network question

Postby janui » 30 Apr 2019, 09:14

Hi three_jeeps,
Please post your notes and any issues here. All feedback, good or bad, is welcome.
Thanks in advance.
janui
User avatar
janui
 
Posts: 624
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Still supported? and a network question

Postby three_jeeps » 01 May 2019, 05:06

janui wrote:Hi three_jeeps,
Please post your notes and any issues here. All feedback, good or bad, is welcome.
Thanks in advance.
janui

Here ya go...
Config: RPi3b+, 64gb sd card, Rune 0.5b, Music is on RPi usb stick
Audio out of RPi 3.5mm audio jack into 3.5mm audio in on battery powered local speaker (Altec Lansing)
Testing setup: using current version of Firefox on my Windows 10 box (fully updated), RPi is hardwired to my LAN with ip address of 192.168.1.22.

Observations:
I get error when connecting to my Windows Network share //jjh_workstation/Music. Complains about not having permission (share is marked for Everyone, r/w/m)
Sometimes this problem is a SMB version error, so I configure that directory to be backward compatable with SMB v1….still did not work. (is strange because the same share works on Volumio)

At 100% volume, the volume at the speaker is low. Speaker volume level is maximum. Tried adjusting volume control: disabled/software/hardware, no effect.

MPD configuration Screen: Changing from Analog out to HDMI out stops music on speaker (as it should) but then switching back to Analog out results in extremely slow playback (about 50% normal speed)
With track playing…I did Menu-> MPD (configuration) - > Volume knob –changed to realtime. Then -> Save and Apply button at bottom of screen. Playback stopped (as I expected) then started playing at beginning of the track that was playing before I clicked Save, but the volume ‘control’ on the Playback screen could not be moved…was stuck at 100%. Machine was wedged. Had to power cycle. Other controls seem to have worked (I could advance the track position by clicking on various parts of the circle, I could advance to the next track, I could get the menu to drop down and change)

Realtime setting on volume control seems to have broken volume control…holding the volume up/down icons have absolutely no effect on the actual volume or the control movement.
The volume control is broken as well. I have the startup volume set to 80 and when the UI starts up, the volume control is set to 100. Cant seem to move it (either playing a track or not playing a track).

Constantly tapping the mute icon under the volume control results in the indicator flashing to the -1 position the flashes back to 100%.
Now I tried my ipad tablet. Same behavior with the volume control as above, in all aspects.
On the plus side, the web app seems to be very fast and is visually appealing. Sigh, too bad it is buggy….
three_jeeps
 
Posts: 4
Joined: 29 Apr 2019, 20:55

Re: Still supported? and a network question

Postby janui » 02 May 2019, 17:07

Hi three_jeeps,
Thanks for the feedback and also for the professional way that you have reported it. There are some known and some new issues. I have put them all on my to-do list.
janui
User avatar
janui
 
Posts: 624
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Still supported? and a network question

Postby cmh714 » 02 May 2019, 17:14

some of those volume issues may be able to be fixed by running alsamixer and setting it correctly

GL!
cmh714
 
Posts: 354
Joined: 04 May 2014, 03:06

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 13 guests