Static on 24bit

Raspberry Pi related support

Static on 24bit

Postby thedman! » 14 Nov 2018, 00:49

Hi all,

I'm sure I've seen this before, but have searched everywhere to no avail.

I/m getting static when playing 24bit audio.

RPi 3b+>Kali>Allo Piano 2.0, latest version of Rune.

All is fine on 16 bit, but pure static - no music on 24 bit.

https://pastebin.com/jsawRUL2

Thanks in advance,

Dave.
thedman!
 
Posts: 61
Joined: 24 Mar 2016, 15:45

Re: Static on 24bit

Postby thedman! » 14 Nov 2018, 19:14

Hmmm. Its not just 24 bit. I'll investigate further... Hold your horses.
thedman!
 
Posts: 61
Joined: 24 Mar 2016, 15:45

Re: Static on 24bit

Postby janui » 14 Nov 2018, 23:11

Hi thedman!,
thedman! wrote:I'm getting static when playing 24bit audio.
RPi 3b+>Kali>Allo Piano 2.0, latest version of Rune.
All is fine on 16 bit, but pure static - no music on 24 bit.
There is a documented bug concerning the Allo Piano 2.1 driver when used together with the latest kernel versions. A workaround has been implemented for 'RPi x>Kali>Allo Piano 2.1'. The same bug could also be present in the Allo Piano 2.0 driver. You could try selecting the 'Allo Piano 2.1 DAC Plus with Kali Reclocker' I²S kernel module in the Settings UI.
janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Static on 24bit

Postby Stymieddd » 01 Dec 2018, 00:31

Could the driver for Piano 2.0 be extracted from Volum*** and place in Rune?
Stymieddd
 
Posts: 19
Joined: 25 Mar 2014, 04:19

Re: Static on 24bit

Postby thedman! » 01 Dec 2018, 00:51

I think I fixed this... But then formatted my sd card before I could fully check...

There some advice on this forum you can use to fix it, but again, I can't check right now...

You need to force sox to resample to 32bit, I think.

Very approximately edit mpd find your device, and add a newline similar to
Format 192000:32:* or 192000:32:2

I post something soonish, maybe tomorrow, when I fix it.
thedman!
 
Posts: 61
Joined: 24 Mar 2016, 15:45

Re: Static on 24bit

Postby thedman! » 01 Dec 2018, 19:44

see piano-not-2-1-version-driver-not-working-t6653.html

The fix is working for me now...
thedman!
 
Posts: 61
Joined: 24 Mar 2016, 15:45

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests