[Addon] RuneUI Enhancement

Raspberry Pi related support

Re: [Addon] RuneUI Enhancement

Postby rern » 14 Mar 2019, 09:00

Garrido33 wrote:...
- There are no more CoverArt images in the "Browse by Coverart" library, but when you click on an empty CovertArt, the album open and the CovertArt is displayed with the songs ;
- The "Single tap song" (Add + Play) no longer works (checked in the library tools), and there is no context menu (impossible to select and add a song to the playlist, impossible to play the song)
...

Browse By CoverArt - thumbnail files from coverarts directory
Coverarts in album view - fullsize files from each directory of that album
Try long-press CoverArt to update. It will find the previously created directory and make it works again.

Single tap song Add + Play - fixed.

rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 378
Joined: 14 Jul 2016, 08:15

Re: [Addon] RuneUI Enhancement

Postby R101 » 14 Mar 2019, 18:13

rern,

I cannot play any albums at the moment as there is no playback menu in the album list, and the option to show it has gone from the library options.
(Pi 3, Ver. 0.4b build 20170229, JLS I2S over USB)
R101
 
Posts: 208
Joined: 29 Apr 2016, 16:16

Re: [Addon] RuneUI Enhancement

Postby Garrido33 » 14 Mar 2019, 21:19

Hi Rern,

I updated the database and thumbnails : still dummy thumbnails in "Browse by Coverart". I reflashed totally the SD Card and created a new library (to test) : situation unchanged. The message after update mentions for each file "no Coverart found". Coverarts are however displayed correctly in the album search.

"Single tap song Add + Play" works well now.

Garrido33
Garrido33
 
Posts: 6
Joined: 07 Mar 2019, 18:49

Re: [Addon] RuneUI Enhancement

Postby rern » 15 Mar 2019, 04:02

R101 wrote:I cannot play any albums at the moment as there is no playback menu in the album list, and the option to show it has gone from the library options.

Context menu icons on the right were gone. Use main icons on the left instead.

rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 378
Joined: 14 Jul 2016, 08:15

Re: [Addon] RuneUI Enhancement

Postby rern » 15 Mar 2019, 04:08

Garrido33 wrote:I updated the database and thumbnails : still dummy thumbnails in "Browse by Coverart". I reflashed totally the SD Card and created a new library (to test) : situation unchanged. The message after update mentions for each file "no Coverart found". Coverarts are however displayed correctly in the album search.
...

Try:
Code: Select all
sed -i '/file_put_contents/ a\return $coverfile;' /srv/http/enhancegetcover.php
rm /srv/http/assets/img/coverarts/*

Then do Thumnails Update again.

rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 378
Joined: 14 Jul 2016, 08:15

Re: [Addon] RuneUI Enhancement

Postby AndyF » 15 Mar 2019, 06:03

Hi rern,

Dirble stations seem to be unsorted. Alphabetical sidebar don't work, too.

Regards, Andy
AndyF
 
Posts: 81
Joined: 02 Aug 2015, 07:36
Location: Germany - Bavaria

Re: [Addon] RuneUI Enhancement

Postby Garrido33 » 15 Mar 2019, 11:56

Rern wrote :
Try:
sed -i '/file_put_contents/ a\return $coverfile;' /srv/http/enhancegetcover.php
rm /srv/http/assets/img/coverarts/*
Then do Thumnails Update again.


Hi Rern,

After this modification, the coverarts have reappeared and everything is ok now. Thanks.

Regards,
Garrido33
Garrido33
 
Posts: 6
Joined: 07 Mar 2019, 18:49

Re: [Addon] RuneUI Enhancement

Postby R101 » 15 Mar 2019, 12:13

rern wrote:
R101 wrote:I cannot play any albums at the moment as there is no playback menu in the album list, and the option to show it has gone from the library options.

Context menu icons on the right were gone. Use main icons on the left instead.

rern


Thanks. I did not see that change.
(Pi 3, Ver. 0.4b build 20170229, JLS I2S over USB)
R101
 
Posts: 208
Joined: 29 Apr 2016, 16:16

Re: [Addon] RuneUI Enhancement

Postby AndyF » 16 Mar 2019, 23:40

Hi rern,

sometimes I get an empty library tab after I did some changes in playback-settings (e. g. change to large coverart).
The only thing that help, is to uninstall>reinstall UIe.
Any idea to debug/what's going wrong?

regards, Andy
AndyF
 
Posts: 81
Joined: 02 Aug 2015, 07:36
Location: Germany - Bavaria

Re: [Addon] RuneUI Enhancement

Postby rern » 17 Mar 2019, 13:22

Update 20190317

- Fix Browse By CoverArt thumbnails update when created from embedded
- Fix sorting and index bar in Dirble
- Show image icons in Dirble

rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 378
Joined: 14 Jul 2016, 08:15

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: Bing [Bot], cmh714 and 2 guests