[Addon] RuneUI Enhancement

Raspberry Pi related support

Re: [Addon] RuneUI Enhancement

Postby klassikmann » 12 Mar 2019, 08:18

Garrido33 wrote:Some issues :
- Webradios no longer work
Same here.

Another issue concerning web-radios and FFmpeg:
During installation of RuneUI Enhancement you see https://www.magentacloud.de/lnk/UyhpKA2X.
Support of FFmpeg is crucial not only for AAC/ALAC/m4a, but also for specific web-radios: My web-radios are MPEG2 Transport Streams (*.ts) from my SAT-TV receiver. FFmpeg has to be active to demux the *.ts container to play the imbedded MPEG-1 Audio Layer 2 (*.mp2) elementary stream.
klassikmann
 
Posts: 45
Joined: 27 Apr 2016, 18:36

Re: [Addon] RuneUI Enhancement

Postby rern » 12 Mar 2019, 10:02

klassikmann wrote:
Garrido33 wrote:Some issues :
- Webradios no longer work
Same here.

Another issue concerning web-radios and FFmpeg:
During installation of RuneUI Enhancement you see https://www.magentacloud.de/lnk/UyhpKA2X.
Support of FFmpeg is crucial not only for AAC/ALAC/m4a, but also for specific web-radios: My web-radios are MPEG2 Transport Streams (*.ts) from my SAT-TV receiver. FFmpeg has to be active to demux the *.ts container to play the imbedded MPEG-1 Audio Layer 2 (*.mp2) elementary stream.

@klassikmann and @Garrido33,

Please confirm that you've fixed the webradio issue by setting FFmpeg to enable.

rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 338
Joined: 14 Jul 2016, 08:15

Re: [Addon] RuneUI Enhancement

Postby klassikmann » 12 Mar 2019, 10:18

@rern
rern wrote:Please confirm that you've fixed the webradio issue by setting FFmpeg to enable.
Sure. I'm inspecting the value after every update. My comment about FFmpeg doesn't describe a bug, but is a hint only about the general usefulness of FFmpeg. But web-radio doesn't work at all after your latest update.
klassikmann
 
Posts: 45
Joined: 27 Apr 2016, 18:36

Re: [Addon] RuneUI Enhancement

Postby klassikmann » 12 Mar 2019, 13:22

The sorting of tracks in the library view is no more according track numbers but "at random".
Look here: https://www.magentacloud.de/lnk/9fBJqqLy
The sorting in the playlist view is o.k.
klassikmann
 
Posts: 45
Joined: 27 Apr 2016, 18:36

Re: [Addon] RuneUI Enhancement

Postby cmh714 » 12 Mar 2019, 16:30

Adding a web radio to the queue fails, but the radios I had in the queue prior to updating are still there and play correctly.

I do NOT use any FFMPEG since that screws up the db update, and have never had any issues with web radios. Having said that, I dont know if the stations I play, use that format.....GDRadio still plays, as does the Zappa station, etc.
cmh714
 
Posts: 353
Joined: 04 May 2014, 03:06

Re: [Addon] RuneUI Enhancement

Postby rern » 13 Mar 2019, 04:15

Hi guys,

Thanks for reportings.

There're always some bugs slip from the daredevils, pre-release update testers, and me. So bugs reports, feature requests or suggestions are welcome.

Bugs: Fixed. To be released with next update real soon.
- Adding Webradio failed
- Sorting tracks wrong

FFmpeg - So it's still good to have the option to disable during installation.

rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 338
Joined: 14 Jul 2016, 08:15

Re: [Addon] RuneUI Enhancement

Postby rern » 13 Mar 2019, 11:41

Update 20190313
- Fix add webradio bug
- Fix track sorting in Library
- Remove context menu icon - use main icon instead

rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 338
Joined: 14 Jul 2016, 08:15

Re: [Addon] RuneUI Enhancement

Postby Garrido33 » 13 Mar 2019, 21:50

Hi Rern,

With my v 0.4, I have the following issues :

- There are no more CoverArt images in the "Browse by Coverart" library, but when you click on an empty CovertArt, the album open and the CovertArt is displayed with the songs ;
- The "Single tap song" (Add + Play) no longer works (checked in the library tools), and there is no context menu (impossible to select and add a song to the playlist, impossible to play the song)
- Webradios still don’t work.

Today's Rune UI Enhancement proposed an installation and not an update. The installation lasted very long. I did a reset and reinstalled the addons, but the above mentioned problems have not changed.
Garrido33
 
Posts: 6
Joined: 07 Mar 2019, 18:49

Re: [Addon] RuneUI Enhancement

Postby cmh714 » 13 Mar 2019, 22:04

@rern, the Webradios work as expected in the latest update on .5

just posting based on the last post above....
cmh714
 
Posts: 353
Joined: 04 May 2014, 03:06

Re: [Addon] RuneUI Enhancement

Postby Garrido33 » 13 Mar 2019, 22:56

Hi cmh714,
Hi Rern,

You are right : webradios also work in v 0.4, via main icons. I was confused because the Single Tap function doesn't work.
Rern, please ignore my remark about webradios. Thanks.
Garrido33
 
Posts: 6
Joined: 07 Mar 2019, 18:49

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest