[Addon] RuneUI Enhancement

Raspberry Pi related support

Re: [Addon] RuneUI Enhancement

Postby ceejayemm » 30 Jun 2018, 16:32

Rern

Thanks for your recent update. I have applied this to my 2 RPi's this afternoon (post your bug report of 12:58). I can report the following:

PI1:
RuneAudio: Ver. 0.4b build 20170229
Arch Kernel: Linux runeaudio 4.4.39 ARCH+
Raspberry PI: RaspberryPi2 (08)
Network: Ethernet connected
DAC: IQaudIO-DAC+
Addons: Login Logo for Terminal
RuneUI Enhancements

Worked fine as far as I can tell, all the functionality I normally use is working Ok for me via a remote Chrome session to the PI.

PI2:
RuneAudio: Ver. 0.4b build 20170229 (I think but can't verify)
Arch Kernel: Linux runeaudio 4.1.20-1 ARCH
Raspberry PI: RaspberryPi2 (08)
Network: Ethernet connected
DAC: None, output via RPi 3.5mm audio socket
Addons: Boot Logo
Chromium Browser
Login Logo for Terminal
MPD Upgrade
RuneUI Enhancements

Seemed to update OK but no access from either local TFT screen or remote Chrome session. TFT screen just black after boot logo, Chrome showed main screen but no cog wheel to access settings etc. I wasn't entirely sure of the Rune build used for this PI so decided to start again. I reflashed Ver. 0.4b build 20170229 to the SD card and rebooted, reconfigured etc. All well (I thought). I then installed the latest RuneUI Enhancements and again all seem well, all menus available, artwork for albums etc and new UI seemed OK.

I then tried to actually listen to some music. No audio output. PI2 uses a plugin speaker via the 3.5mm audio socket. There is no way to get this working. I have also found the the ALSA Mixer which could be used to check out the audio settings seems to be toast too. I can open the ALSA Mixer web page (<my IP>:8080) but only get the banner heading, no details at all. Running alsamixer from an SSH session gives me 'cannot open mixer: No such file or directory' for which I haven't yet found a suitable solution. There does seem to be some posts on the forum that suggest RuneUI and the ALSA Mixer have some problems but I don't know if these apply to me.

The upshot at the moment is that I have no sound from PI2 at all but ti is otherwise working ok :-(

Chris
ceejayemm
 
Posts: 10
Joined: 29 Oct 2016, 18:13

Re: [Addon] RuneUI Enhancement

Postby ceejayemm » 30 Jun 2018, 16:34

Rern

Sorry, should have said, in the rebuilt PI2 I only installed the Boot Logo and the Rune UI additions. I don't really need the other things so thought that I would keep it a simple as possible for my use.

Chris
ceejayemm
 
Posts: 10
Joined: 29 Oct 2016, 18:13

Re: [Addon] RuneUI Enhancement

Postby ceejayemm » 01 Jul 2018, 16:21

Rern

I don't think my current problems with PI2 are anything to do with your Rune UI enhancements now. I have reflashed a new SD card with the latest0.4 beta from Frank. This works Ok UNTIL I make any changes (other than changing the time zone) on the Settings page. At this point the ALSA mixer seems to get removed and I loose all access to output audio from the 3.5mm Audio Jack., on the MPD / Audio Output Interface it says 'Nothing to Select'.


I will raise a new ticket to take this issue forward.

Chris
ceejayemm
 
Posts: 10
Joined: 29 Oct 2016, 18:13

Re: [Addon] Chromium Browser

Postby R101 » 02 Jul 2018, 14:44

rern,

The 7" local touch screen does not work on a Pi2 when the enhanced UI is installed on 0.4-beta. The display hangs at "Started RuneAudio System Worker". No problems with remote access.

Edit: This was fixed by uninstalling and reinstalling Chromium, so not a UIe problem. Apologies.

If "custom" is selected as the local display size when installing Chromium, what format does the entry need? Tapping on the field does not bring up a keyboard on the local touchscreen, by the way.

Thanks,

R.
Last edited by R101 on 03 Jul 2018, 20:14, edited 1 time in total.
(Pi 3, Ver. 0.4b build 20170229, JLS I2S over USB)
R101
 
Posts: 121
Joined: 29 Apr 2016, 16:16

Re: [Addon] RuneUI Enhancement

Postby cmh714 » 02 Jul 2018, 15:45

After this last update the Rune App on Android seems to be misbehaving.....I cant swipe up to get the menu to drop down....
cmh714
 
Posts: 299
Joined: 04 May 2014, 03:06

Re: [Addon] RuneUI Enhancement

Postby rern » 03 Jul 2018, 07:55

cmh714 wrote:After this last update the Rune App on Android seems to be misbehaving.....I cant swipe up to get the menu to drop down....

Since only the settings menu has to be accessed via top bar, the vertical swipe / tap on screen L/R was removed.
- Top bar - Every buttons, except the menu, are available as overlay controls. (Tap the top of cover art for the overlay guide.)
- Bottom bar - Swipe horizontally to switch between pages.
- Toggle top-bottom bars - Tap top right corner of cover art.
- Toggle buttons - Tap bottom right corner of cover art.
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 209
Joined: 14 Jul 2016, 08:15

Re: [Addon] RuneUI Enhancement

Postby R101 » 03 Jul 2018, 13:22

rern,

I find the Android app I have still works well, with top/bottom buttons always present. The only very minor bug I see is that the alphabetical selection bar has a few letters missing due to my 1024x600 screen.

The Android browser has the new layout, without controls. I prefer the old layout with buttons I can see, but would it be worth having the top/bottom buttons show when the cover art is disabled?
(Pi 3, Ver. 0.4b build 20170229, JLS I2S over USB)
R101
 
Posts: 121
Joined: 29 Apr 2016, 16:16

Re: [Addon] RuneUI Enhancement

Postby cmh714 » 03 Jul 2018, 15:18

Thank You Rern, didnt realize you made that change. Sort of got it now :) Need to get used to it.

The button icons on top and bottom arent rendering properly. I just have an X in a box.

***UPDATE*** Nevermind, blew out the apps cache and buttons are back. Thanks again Rern!
cmh714
 
Posts: 299
Joined: 04 May 2014, 03:06

Re: [Addon] RuneUI Enhancement

Postby LeighP » 04 Jul 2018, 19:58

Issue now fixed.

Leigh....
Last edited by LeighP on 14 Jul 2018, 19:47, edited 1 time in total.
Home: Custom cased Rpi3 running RuneAudio (of course!)
1Tb storage.
HifiBerry+ DAC.
Denon RCDM350DAB Hifi.

Workplace: Pi Zero W with RuneAudio.
pHAT DAC and 320Gb storage.
Sony HiFi.
Colleagues who don't appreciate my music!
LeighP
 
Posts: 20
Joined: 27 Jan 2018, 10:27

Re: [Addon] RuneUI Enhancement

Postby ceejayemm » 05 Jul 2018, 11:02

Rern

Problems with audio output from the 3.5mm audio jack have been resolved and I have now reinstalled the latest RuneUI Enhancements and all seems well from my point of view.

Thanks

Chris
ceejayemm
 
Posts: 10
Joined: 29 Oct 2016, 18:13

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 0 guests