RuneAudio Temporarily Unavailable NOW regularly

Raspberry Pi related support

RuneAudio Temporarily Unavailable NOW regularly

Postby foxint » 02 Jan 2019, 01:01

Hi Guys

Still trying to get things working. I have gone back to a different hardware.

But this is happening on all platforms much more regularily - now DAILY?

any suggestions
Attachments
Z-Runne-TempUnavailable.JPG
Z-Runne-TempUnavailable.JPG (46.76 KiB) Viewed 347 times
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby eea123 » 17 Jan 2019, 13:06

Can you confirm if your Rune PI unit is randomly rebooting (software glitch) or physically losing power (power strip, surge protector, bad wall wart)? I confess that I've not established a static IP home network and power outages can cause havoc on my network with DCHP reassigning IPs on reboot.
eea123
 
Posts: 59
Joined: 23 Dec 2017, 19:19

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby foxint » 17 Jan 2019, 21:16

Hi eea123
Thank you for sticking by me.

It happens in the morning. I shut down the pi when I go to bed and then turn it on in the mornings. It happens than and also when I have to turn it off and one during the day.

This morning was OK????

Not sure.

Thank you
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby eea123 » 18 Jan 2019, 11:19

My Setup:
Well, I leave mine on all of the time just to be on the ready when I switch on my stereo. I already have a Niles Infrared Repeater (IR 6+) tucked in behind some components that stays on all of the time, so I placed the Rune Player next to it since I'm just using a basic enclosure without any LCD display or hardware controls. My stereo cabinet / armoire is in the den next to my desktop PC. Typically I manually switch on the multi-room amps (I'm hard-wired to each room from the den), click on the preamp and select Rune as my line source (2-channel stereo). I then go to the PC and select an album or web-radio station from the Rune interface. No problem for the last year I've been using it (except when the whole house's power drops out and IPs are DCHP reassigned - that's happened maybe twice and its just my laziness to not assign static IPs).

My Rune Player is CAT-6 ethernet wired, as is most of my house. I suspect you are running into your router, or which ever device is handling IP assignments, catching up with this being turned on and assigning &/or recognizing its IP on your network. I think in another posting I shared that I use my NAS as my source for FLAC playback of my albums, another reason for myself to stay on the ready with power on setup.

Back to Your Error:
I was often times getting a similar error when I used my Android tablet on WiFi. I had two routers supplying WiFi to each end of the house and if the tablet connected to the other router it was on a different subnet and could not see the Rune Player. My Rune Player is on 10.0.0.XX subnet and if the tablet was on 192.168.0.XX subnet I would get a similar error. This happened to me because of varying WiFi signal strength it would automatically change to the other subnet. I've since added a Zyxel WiFi repeater to supplement the 10.0.0.XX subnet and retired the other router and subnet conflicts.
eea123
 
Posts: 59
Joined: 23 Dec 2017, 19:19

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby R101 » 18 Jan 2019, 11:31

eea123,

The fact that foxint is seeing a message generated by the Pi implies that it is connecting to the router OK. It looks as if the UI is not starting for some reason.

foxint,

Have you logged in to the router to make sure connection is not being lost during boot-up?
(Pi 3, Ver. 0.4b build 20170229, JLS I2S over USB)
R101
 
Posts: 211
Joined: 29 Apr 2016, 16:16

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby foxint » 18 Jan 2019, 23:27

Eea123 & R101

Thank you for the comments and thank you for not saying I am an idiot and should go away until I learn more. I learn from asking stupid questions and having them answered by nice people

Thank you.

This morning the Pi was working. I then turned it off closed off the software and turned it on again.

Same message. I went into the router and the IP address for the Pi was (within minutes) assigned to another device (it was wireless, and the name was “you”)

The Pi has a fixed IP address – I am stumped.

I have now pushed the fresh thing on Chrome, and I got the RuneAudio page and the radio.

Strange, I checked the router, refreshed it again…. still shows that the device is wireless. But it is connected with Cat-6??? In the old days, the Hostname was RaspberryPi…. but not now

Not wanting to upset anyone, I still have lots of other issues (just a heads up). I seem to have upset one of the senior members on the forum.
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby eea123 » 19 Jan 2019, 11:27

It sounds like it could be as simple as another device is being assigned your Rune PI's static IP while it is powered off by the network? Maybe bump your PI's static to up by a 50 or 100 increment, IE old static IP of 192.168.0.10 becomes 192.168.0.110.
eea123
 
Posts: 59
Joined: 23 Dec 2017, 19:19

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby R101 » 19 Jan 2019, 11:44

foxint,

I suggest you disable the wifi and bluetooth on the Pi, (used to be in the file "/etc/modprobe.d/disable_rpi3_wifi_bt.conf" but might have changed) and delete the wireless settings. Either that or unplug the ethernet cable and use the wireless connection.

It might also be worth checking that you do not have two devices asking for the same fixed IP, and that the fixed IP you chose is not in the router's DHCP range.
(Pi 3, Ver. 0.4b build 20170229, JLS I2S over USB)
R101
 
Posts: 211
Joined: 29 Apr 2016, 16:16

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby englishtim » 19 Jan 2019, 13:26

Hi foxint,

I really hope the following suggestion isn't so simple that it causes offence - the RuneAudio forum is normally a friendly and helpful place, and I'm genuinely sorry to hear about your difficulties with some other members. We all have different levels of knowledge and experience, and the only thing forum members want is either a bit of guidance, or to help a fellow RuneAudio user - no-one's an idiot, and there's no such thing as a stupid question! :)

If I understand the postings so far, the fundamental issue seems to be that the Pi doesn't stay on the correct IP address. If so, it would be good to know exactly how you've assigned a fixed IP address to the PI. Are you trying to do this only on the Pi (Menu > Network > IP assignment > Static > your preferred IP address numbers), or have you configured a list of static IPs on your router? Given that something else seems to be stealing the IP address you want to use for the Pi, I wonder if your network setup is inadvertently allowing different devices to compete for the same IP addresses.

IMHO the only safe and reliable way to use fixed IP addresses is to configure a list of them on the router, and nowhere else - normally the router would be set up as your network's DHCP server anyway, so it's already responsible for allocating IP addresses (fixed or not) to all your client devices. Once you've set up a list of fixed IPs (including the one for your Pi) on your router you should configure all your network client devices (including the Pi) to use DHCP instead of Static IP - the router's then in complete control of the numbers throughout the network, and the Pi just uses the number that the router's assigned to it.

While you're in the router's static IP config section it wouldn't do any harm to assign separate static IPs for each of the PI's wired and wireless network interfaces.

I hope this helps,

Peace and friendship,
englishtim
  • Raspberry Pi 3 Model B+ > Behringer UCA202 >
      Denon RCD-M38DAB > KEF Cresta II
      Pro-Ject Head Box S > Sennheiser HD 650
  • Raspberry Pi 3 Model B > FiiO E10K > Sansui AU-317 > Celestion SL6
  • Raspberry Pi Model B > extl speakers
User avatar
englishtim
 
Posts: 37
Joined: 20 Feb 2015, 11:36
Location: Always European

Re: RuneAudio Temporarily Unavailable NOW regularly

Postby foxint » 20 Jan 2019, 05:07

Gentlemen

Great ideas.

OK. I must ask 2 stupid questions before I change the IP Address:

1. What is the difference between ETH0 and WLAN0

Since I have the IP address for the Pi at ETH0 – I am assuming this is the Pi IP address. So what is the other?

2. How would I assign an IP Address to the Pi via the modem?

I have 28 devices on the DHCP list in the modem.

I think I am done with the stupid questions.
foxint
 
Posts: 181
Joined: 29 Mar 2016, 06:36

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest