RuneAudio crashes while using onboard wifi

Raspberry Pi related support

RuneAudio crashes while using onboard wifi

Postby wertkost » 18 May 2017, 18:09

Hi Guys,

i got a HiFiBerry DAC+ Pro on a raspberry 3B.
I tried rune audio RuneAudio_rpi2_rp3_0.4-beta_20170229 as well as RuneAudio_rpi2_rp3_0.4-beta_20160321 and always had the same problem.
The onboard wifi is recognised and i am able to connect. Seconds after starting the playback the connection crashes and I am not able to connect again.
Using a LAN-cable everything works fine, but I'd rather use the wifi, can you guys help me?

Thanks a lot!

PS: I tried volumio and it didn't even showed my wifi-interface.
wertkost
 
Posts: 5
Joined: 18 May 2017, 17:57

Re: RuneAudio crashes while using onboard wifi

Postby wertkost » 18 May 2017, 18:17

as an add-on information:

I just started the pi with lan-cable and after booting and connecting to wifi, i restarted it. Wifi is unable to connect afterwards... thats just happening to with RuneAudio_rpi2_rp3_0.4-beta_20170229. In order to fix it, i have to remove the saved wifi data and reconnect.
wertkost
 
Posts: 5
Joined: 18 May 2017, 17:57

Re: RuneAudio crashes while using onboard wifi

Postby janui » 19 May 2017, 09:08

Hello wertkost,

I am considering buying the HiFiBerry DAC+ Pro and had done a little homework. There are two potential problems with using this DAC card:

1. When using the HiFiBerry DAC+ Pro with a Raspberry 3B there is a UART conflict with the built in bluetooth. You need to add the following line to config.txt to disable on-board bluetooth:
Code: Select all
dtoverlay=pi3-disable-bt-overlay

It is also possible that you will need to stop hciattach trying to reach the modem via uart0. This can be done in by blacklisting the bluetooth drivers as described in this post: disable-wifi-and-blueooth-on-pi3-t3547.html#p14220 OR (I have not tried this) via the SSH interface disable starting the services with the command:
Code: Select all
systemctl disable hciuart

2. On the HiFiBerry website, hidden away in their documentation, you can find the text:
The DAC+ Pro onboard oscillators can interfere with onboard WLAN. Selecting a different WiFi channel usually fixes this problem.
You could try changing the WiFi frequency. But this statement points to a more general problem: WiFi (and Bluetooth) antennas & DAC oscillators don’t like to be close together. You should therefore consider switching off the built in WiFi. But if you really determined to use WiFi, you could use a dongle on a short USB cable to keep it away from the oscillators. You can switch off built in WiFi by blacklisting the WiFi drivers see this post: wifi-disable-rpi3-t4390.html#p19743

Regardless of the above you should read this post: disable-wifi-and-blueooth-on-pi3-t3547.html#p14220
I am very interested in your progress, please post updates.

Janui
janui
 
Posts: 6
Joined: 20 Dec 2014, 12:55

Re: RuneAudio crashes while using onboard wifi

Postby wertkost » 19 May 2017, 12:36

Hi Janui,

thanks for your post.

While installing m2p, I changed the wifi-channel to 10. Afterwards m2p worked great with the on-board wifi except spotify, thats why i am back here. I like the RuneAudio-Software way better. Tried again the RuneAudio_rpi2_rp3_0.4-beta_20160321-Version, disabled bluetooth like you suggested and it seems to work.... ! That would be so awesome! :P

Also wrote to hifiberry support. They said, it is maybe a rare problem with the DAC + pro and i should try the wifi without the dac. Not yet tried it (right now no need to...), maybe tomorrow...
wertkost
 
Posts: 5
Joined: 18 May 2017, 17:57

Re: RuneAudio crashes while using onboard wifi

Postby janui » 19 May 2017, 13:51

Hi wertkost,

Good that things are a little beter. There seems to be some issues at the moment with Spotify, see threads: spotify-tried-everything-playlist-undefined-undefined-t4442.html#p20060 and spotify-playlists-not-visible-t4310.html#p19090. If Spotify is your only problem then tagging onto these theads would be best.

Note: Some users are also reporting no problems with Sporify. I am using the standard image (RuneAudio_rpi2_rp3_0.4-beta_20160321_2GB.img.gz) on my Pi3B, my Spotify is still working fine. But I am also getting extra lines like "undefined (undefined)". What I did notice is that it takes ages to load the Spotify playlists.

How does the DAC sound?

Janui
janui
 
Posts: 6
Joined: 20 Dec 2014, 12:55

Re: RuneAudio crashes while using onboard wifi

Postby wertkost » 20 May 2017, 12:54

Hey,

still working like a charm! Sound is great, love runeaudio and the pi!

Having the same issues with undefined playlists in spotify, but it seems more like that if you are just following a playlists it appears as undefined. It is not the case if you create it yourself... Maybe some kind of Problem with the link to a playlist and not having the real playlist yourself.
wertkost
 
Posts: 5
Joined: 18 May 2017, 17:57

Re: RuneAudio crashes while using onboard wifi

Postby wertkost » Yesterday, 10:03

update:

telling Hifiberry (D. Matuschek) what solved the Problem, he said, it is a hardware-problem and he is going to replace the DAC + Pro with another. Great support!

Meanwhile, i am having the same issues with spotify concerning the long time till a playlist appears in library...
wertkost
 
Posts: 5
Joined: 18 May 2017, 17:57

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: Bing [Bot] and 0 guests