RuneAudio 0.5-beta for most Raspberry Pi models

Raspberry Pi related support

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 16 Sep 2018, 14:47

Hi Nic,
nic wrote:I've been a happy user of 0.5b for the past few weeks and really appreciate Janui's help getting my DAC working with the new image . I've run into a slight issue when casting , I get 'twiitering noises' type static . I have rebooted the PC used for casting , rebooted the PI and also done a gitpull . This issue happens with MP3 cast from my PC , WAVs now seen fine . Any ideas ?
This is a new one, need to do a bit of research first, will get back to you.

janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 16 Sep 2018, 15:18

Hi J4K,
J4K wrote:Rpi3b, RuneAudio 0.5-beta2.
Thank-you for releasing an update, But my fresh install is stuck on the "Starting rune audio" screen with a blinking cursor, and never gets past this.
Cannot collect debug info.
Very occasionally I have had a Pi stall on the first boot with very similar symptoms. You have probably seen the splash startup screen (this one: download/file.php?id=861), you will get this even if local browser is disabled (and it is disabled by default). Could you confirm this?
When an initial boot stalls I give it about 5 minutes just to be sure, then pull out the plug. The initial boot time varies per Pi type, 3 to 5 minutes is normal. Plug it in again and again wait again for 5 minutes. Repeat just one more time, if it still will not boot I would assume that the SD-card has problems and you probably need to reflash it. I don’t have a local screen on my Rune players, so it is difficult to advise on that point. Stephane seems to be giving some good advice and has a similar system.
janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 16 Sep 2018, 20:42

Hi rainy,
rainy wrote:Can the devs please confirm if ext4 is supported on the Rpi images? If not is there a reason or plans to fix? I can only play my audio files with Rune if they are on a USB drive formatted as NTFS.
This is a surprise for me, I would have expected it to work. Will get back to you.
janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby englishtim » 16 Sep 2018, 23:00

Hi Everyone,

I've been using v0.5b for a few weeks now, and - at least with my relatively simple setup - it's looking and sounding good. The updated packages under the hood are well worth having, and my experience has been that it's solid in day to day use.

Big kudos and thanks to Janui and Gearhead for all their work on this release!

Peace and friendship,
englishtim
  • Raspberry Pi 3 Model B > Behringer U-Control UCA202 >
      Denon RCD-M38DAB > DIY KEF Cresta II / Caprice I
      Pro-Ject Head Box S > Sennheiser HD 650
  • Raspberry Pi Model B > FiiO E10K > Sansui AU-317 > Celestion SL6;
User avatar
englishtim
 
Posts: 21
Joined: 20 Feb 2015, 11:36
Location: Proud to be in Europe

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby J4K » 17 Sep 2018, 12:21

Hi People,

Just thought I would update, left it on the loading screen after three x boots for about half an hour and no progress, stuck rune 4 back on the card and all is back to normal. loaded straight through without a hick up.

Good luck with your update though, glad to see some movement on the software.

J
J4K
 
Posts: 20
Joined: 25 Mar 2017, 21:20

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 17 Sep 2018, 12:51

Hi rainy,
rainy wrote:Just like the previous version (0.3 beta) on the Raspberry Pi1, a USB stick or external USB drive formatted with the ext4 format does not seem to work with Rune Audio 0.5 beta.
Since Rune is based on Arch Linux, I would have expected this to work out of the box. Has anyone else had success with ext4?
Rune can see my USB drive and folders but all folders appear empty (I can see all the audio files when I SSH into Rune).
I have a feeling that it is working, but the file protections on the ext4 USB drive are preventing MPD from reading the data. MPD uses the user 'mpd', group 'audio' to access all the storage. User mpd, needs to have read access to filesystem, directories and files to able to use the data. When you log in via SSH you access the files as user 'root', which can read everything. You need to do something like this to fix it:
Code: Select all
find <path to drive> -type f -exec chmod 644 {} \;
find <path to drive> -type d -exec chmod 755 {} \;
Replace <path to drive> with the actual path to the drive. I think Rune will mount it read/write so you can do this after logging in with SSH. Personally I would automatically mount it ‘read only’, you can change this by adding the following line to /etc/udevil/udevil.conf:
Code: Select all
default_options_ext4      = nosuid, noexec, nodev, noatime, ro, noload

janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 17 Sep 2018, 13:00

Hi J4K,
J4K wrote:Just thought I would update, left it on the loading screen after three x boots for about half an hour and no progress, stuck rune 4 back on the card and all is back to normal. loaded straight through without a hick up.
Thanks for the update, at least we know it is not the Pi, could you send your debug. Then we know what type of configurations have problems.
janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby MidnightExpress » 17 Sep 2018, 13:11

What an excellent news to know that 0.5b is available to download! Cannot wait to try.

Thanks to Gearhead and janui for the great works on 0.5b, and also those who have contributions to RuneAudio.

The performance of 0.5b is quite good. My ES9018 dac now can output 352.8kHz perfectly by using hifiberry dac I2S driver with my Raspberry Pi 3B+. The OS detects and treats ES9018 as PCM1502a dac. It can output 384kHz, however, some continuous "de de" sound is found on the right channel. Anyhow, it is minor.

By the way, I have some questions:
1) How can I disable bluetooth? Command "systemctl disable hciuart" no long works on 0.5b. It says "Unit file hciuart.service does not exist."

2) RuneUI keeps prompting "Disk Errors, Action Required" every 2 minutes. The system has a system SD-Card and one NAS network mount only. No USB Drive. Where can I find the information regarding this popup message? Would it be related to this message "CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2" that I found from the dmesg? Although RuneUI keeps prompting the error message, my RuneAudio 0.5b seems working without any problems.

I have tried different players but find that Rune is still the best.

Thanks.
MidnightExpress
 
Posts: 12
Joined: 04 Aug 2018, 12:19

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 17 Sep 2018, 15:13

Hi nic,
nic wrote:I've been a happy user of 0.5b for the past few weeks and really appreciate janui's help getting my DAC working with the new image . I've run into a slight issue when casting , I get 'twittering noises' type static . I have rebooted the PC used for casting , rebooted the PI and also done a gitpull . This issue happens with MP3 cast from my PC , WAVs now seen fine. Any ideas?
I have searched on the net for this problem, unfortunately found nothing similar with a recent date. So it will be a bit of an experimental approach.
Could you first try a few simple things first. In the /dev UI try setting SoXr for MPD ON or OFF (I don’t know what your normal setting is), then reboot & test. Then try selecting the Allo Piano 2.1 DAC Plus (without Kali) in the Settings UI, reboot, check that the correct output is selected in the MPD UI and retest.
If there is no improvement in sound quality then revert to your normal settings. Upgrading the upmpdcli package could fix it, so let’s try it. Log in with SSH and run the following commands:
Code: Select all
cd /home
wget https://github.com/gearhead/RuneOS/raw/master/packages/upmpdcli-rune/upmpdcli-rune-1.3.0-1-armv7h.pkg.tar.xz
pacman -U upmpdcli-rune-1.3.0-1-armv7h.pkg.tar.xz --force
Then:
Code: Select all
rm upmpdcli-rune-1.3.0-1-armv7h.pkg.tar.xz
cp /var/www/app/config/defaults/upmpdcli.conf /etc/upmpdcli.conf
cp /var/www/app/config/defaults/upmpdcli.service /usr/lib/systemd/system/upmpdcli.service
find /usr/lib/systemd/system -name *.service -exec chmod 644 {} \;
find /etc -name *.conf -exec chmod 644 {} \;
redis-cli hset dlna enable 0
redis-cli hset dlna queueowner 0
redis-cli hset dlna name RuneAudio
Then via the Settings UI switch ‘UPnP / DLNA’ ON, configure it, reboot and retest.
If this changes nothing then it is probably better to revert back to the original version of upmpdcli package, but this is optional and up to you. To revert back, run the following commands:
Code: Select all
cd /home
wget https://github.com/gearhead/RuneOS/raw/master/packages/upmpdcli-rune/upmpdcli-rune-1.2.15-3-armv7h.pkg.tar.xz
pacman -R upmpdcli-rune
Then:
Code: Select all
pacman -U upmpdcli-rune-1.2.15-3-armv7h.pkg.tar.xz
Then:
Code: Select all
rm upmpdcli-rune-1.3.0-1-armv7h.pkg.tar.xz
cp /var/www/app/config/defaults/upmpdcli.conf /etc/upmpdcli.conf
cp /var/www/app/config/defaults/upmpdcli.service /usr/lib/systemd/system/upmpdcli.service
find /usr/lib/systemd/system -name *.service -exec chmod 644 {} \;
find /etc -name *.conf -exec chmod 644 {} \;
redis-cli hset dlna enable 0
redis-cli hset dlna queueowner 0
redis-cli hset dlna name RuneAudio
Then via the Settings UI switch ‘UPnP / DLNA’ ON, configure it, reboot and retest to check that it still works.
janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 17 Sep 2018, 15:42

Hi MidnightExpress,
MidnightExpress wrote:The performance of 0.5b is quite good. My ES9018 dac now can output 352.8kHz perfectly by using hifiberry dac I2S driver with my Raspberry Pi 3B+. The OS detects and treats ES9018 as PCM1502a dac. It can output 384kHz, however, some continuous "de de" sound is found on the right channel. Anyhow, it is minor.
If you select the I²S kernel module for the ES90x8 (Sabre) in the Settings UI you will get better performance.
MidnightExpress wrote:1) How can I disable bluetooth? Command "systemctl disable hciuart" no long works on 0.5b. It says "Unit file hciuart.service does not exist."
The best way to do this on a Pi3 is to add the following line to /boot/config.txt:
Code: Select all
dtoverlay=pi3-disable-bt
Since systemctl disable hciuart doesn’t works it looks like we have forgotten something in the image, it is already disabled because the service file is missing.
You can also disable the on board WiFi with by adding this line to config.txt:
Code: Select all
dtoverlay=pi3-disable-wifi
I do not know whether these commands will work on the Zero W.
MidnightExpress wrote:2) RuneUI keeps prompting "Disk Errors, Action Required" every 2 minutes. The system has a system SD-Card and one NAS network mount only. No USB Drive. Where can I find the information regarding this popup message? Would it be related to this message "CIFS VFS: ioctl error in smb2_get_dfs_refer rc=-2" that I found from the dmesg? Although RuneUI keeps prompting the error message, my RuneAudio 0.5b seems working without any problems.
Please post your debug for this one.
janui
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 2 guests