RuneAudio 0.5-beta for all Raspberry Pi models

Raspberry Pi related support

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » 11 Oct 2018, 20:03

Hi jlynton,
jlynton wrote:Thanks Janui, I will do so as soon as it stops again, and post the result. I do not need to run the commands as su, right?
Right.
janui
User avatar
janui
 
Posts: 323
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby popov » 12 Oct 2018, 16:16

Hi

Really strange I see mdns request from clients... but no answer from runeaudio... and when I restart avahi... runeaudio send information but looks like client not getting it .... If can take time with week end
No issue with apple system so ?
Popov



Envoyé de mon iPad en utilisant Tapatalk
popov
 
Posts: 47
Joined: 11 Oct 2014, 16:13

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby jlynton » Yesterday, 16:54

Janui,

The runeaudio.local address stopped working today, after some 72 hours of it working correctly. I tried as you said...

Code: Select all
root@runeaudio(rw):~# systemctl stop shairport-sync
root@runeaudio(rw):~# systemctl stop avahi-daemon
Job for avahi-daemon.service canceled.
root@runeaudio(rw):~# systemctl start avahi-daemon
root@runeaudio(rw):~# systemctl start shairport-sync
root@runeaudio(rw):~#


It still did not work, but after rebooting my PC it did. The whole time that runeaudio.local did not work, I was able to connect using the pi's (fixed) IP, I was also able to connect using the RuneAudio android app (where I have NOT entered the pi's IP).
jlynton
 
Posts: 27
Joined: 20 May 2016, 12:53

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » Yesterday, 17:29

HI jlynton,
Thanks for trying the commands and reporting back.
jlynton wrote:It still did not work, but after rebooting my PC it did. The whole time that runeaudio.local did not work, I was able to connect using the pi's (fixed) IP, I was also able to connect using the RuneAudio android app (where I have NOT entered the pi's IP).
From this, it would seem that Rune is working correctly, but somehow your PC is 'forgetting' the link to the IP address. If it’s a Windows PC you could try deinstalling and reinstalling Bonjour (reboot after deinstalling). You can download it from the Apple site here: https://support.apple.com/downloads just search for Bonjour. It is called ‘Bonjour Print Services for Windows v2.0.2’.
janui
User avatar
janui
 
Posts: 323
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby jlynton » Yesterday, 19:05

janui wrote:...From this, it would seem that Rune is working correctly, but somehow your PC is 'forgetting' the link to the IP address. If it’s a Windows PC you could try deinstalling and reinstalling Bonjour (reboot after deinstalling). You can download it from the Apple site here: https://support.apple.com/downloads just search for Bonjour. It is called ‘Bonjour Print Services for Windows v2.0.2’.
janui

Thanks Janui, but I would never use windows! My PC runs Linux Mint. It does not do this with Volumio, and never did it previously with RuneAudio 0.3 or 0.4.
I have tried running
Code: Select all
systemctl restart avahi-daemon

on the PC, but that did not help.
jlynton
 
Posts: 27
Joined: 20 May 2016, 12:53

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby popov » Yesterday, 21:19

Hi

This came from client... I was focused on Runeaudio. but in fact when fail, i loose all .local adress, only o one client... Others are still working

On linux restarting dhcpcd "solve", but not explain

Regards
popov
 
Posts: 47
Joined: 11 Oct 2014, 16:13

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby janui » Today, 10:43

Hi popov & jlynton,
popov wrote:On linux restarting dhcpcd "solve", but not explain
That is interesting, so it seems to be related to dhcpcd. This command should show what your linux client can see:
Code: Select all
avahi-browse -atrlkp
I wonder if there is a difference between when it is working and when it fails. These posts could also help: https://unix.stackexchange.com/question ... ain-issues and this: https://bbs.archlinux.org/viewtopic.php?id=205917 and this: https://groups.google.com/forum/#!topic ... nIduBxVkSI
janui
User avatar
janui
 
Posts: 323
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby jlynton » Today, 15:11

Hello Janui,

I have run
Code: Select all
avahi-browse-atrlkp
when runeaudio.local is not working, and again when it is. When it is NOT working,there is no data returned at all. When it is working it returns
Code: Select all
+;enp4s0;IPv4;RUNEAUDIO;_smb._tcp;local
+;enp4s0;IPv4;runeaudio;_mpd._tcp;local
=;enp4s0;IPv4;RuneAudio\032\091runeaudio\093\032\091b8\05827\058eb\05867\05861\0585e\093;_http._tcp;local;runeaudio.local;10.24.57.35;80;"runeos_version=0.5-gearhead-janui" "skin_name=RuneUI"
=;enp4s0;IPv4;RUNEAUDIO;_smb._tcp;local;runeaudio.local;10.24.57.35;445;
=;enp4s0;IPv4;runeaudio;_mpd._tcp;local;runeaudio.local;10.24.57.35;6600;
jeremy@jeremy ~ $
This is preceded by a lot of info regarding my NAS, can PM it to you if you like.

When it is not working, if I reboot both the Pi and the PC, it does not then work. The only (as far as I know) way to make it work again is to first run (on the Pi)
Code: Select all
root@runeaudio(rw):~# systemctl restart avahi-daemon
then to restart my PC.
jlynton
 
Posts: 27
Joined: 20 May 2016, 12:53

Re: RuneAudio 0.5-beta for all Raspberry Pi models

Postby popov » 18 minutes ago

Hi

When .local is down
ping runeaudio.local = unkonw host
avahi-browse -atrlkp = nothing
avahi-resolve -n raspberrypi.local = nothing

On or 2 more
avahi-resolve -n raspberrypi.local => fe80::ebcb:62fc:9951:aa82 => IP v6 is disable on avahi !!!!!, and my dhpc is not delevering any ipV6
on more
pi@raspberrypi:~ $ avahi-resolve -n raspberrypi.local
raspberrypi.local 192.168.1.15
avahi-browse -atrlkp = nothing
ping runeauio.local = ko

systemctl restart dhcpcd
ping runeaudio = ok
avahi-resolve -n raspberrypi.local
raspberrypi.local 192.168.1.15
avahi-browse -atrlkp = Ok with only ipv4 address .....
popov
 
Posts: 47
Joined: 11 Oct 2014, 16:13

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 3 guests
cron