RuneAudio 0.3-beta for Raspberry Pi

Raspberry Pi related support

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby hondagx35 » 04 Jun 2016, 21:03

Hi Dondorito,

Don't know what I have to type in setting field netmask.

Typically the netmask is "255.255.255.0".

What's the next step should I change the Lan connection to static?

You can, but you do not need to change it.

Can I use the same values from the Lan for the setting in the wlan?

No you can't, because the IP has to be unique.
NETMASK, GATEWAY and DNS are the same for all devices on your network.
Gateway is usually the IP from your router.
Example:
Router IP = 192.168.0.1

Settings on Rune
IP = 192.168.0.100
NETMASK = 255.255.255.0
GATEWAY = 192.168.0.1
DNS = 192.168.0.1
Check your router for attached devices and their IP addresses, so you get a free one.

I know this has to be static.

If your router has DHCP enabled there is no need for doing this.

Frank
User avatar
hondagx35
Moderator
 
Posts: 2382
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby Dondorito » 04 Jun 2016, 21:32

Thanks very much.
I did most of that all ready, but it doesn't work out. Another problem is that I can't turn the Pi of... The connecting circles for 10 minutes now...do I have to apply the same turn off routine described in the docs with the stock wlan from pi 3 or should it work without this?
Still circling... Do I need to wipe? What can this turn off problem be?
After initial connection the green checkmark is there, for a few seconds then it goes on and off a few times and is gone afterwards whether I use static or DHCP. after that the signal is dropping from 60 to percent or lower... Try to turn out using desktop app on win 10 pc or Android phone.
Thanks again
Dondorito
 
Posts: 9
Joined: 04 Jun 2016, 18:31

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby hondagx35 » 04 Jun 2016, 23:00

Hi Dondorito,

do you connect via IP or http://runeaudio?
With both networks (ethernet and wifi) active you can not use the playername.

Also check the channel on which your router works.
The internal wifi can only be used with channels up to 11.

So first try to connect via:
http://192.168.0.100 (replace with your ip)

Frank
User avatar
hondagx35
Moderator
 
Posts: 2382
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby Dondorito » 05 Jun 2016, 11:39

Thanks again Frank,
I used to use the Ui I found a link in my router settings. It's an fritz box 7312 from 1&1. This is http://runeaudio
Now I even sometimes get timeout error and when I get to the UI it responds very slowly, I can't even get to the Network settings, or I am too impatient. Tried restarting router but it didn't work.
I guess I will wipe the card again and try it over again. Then I will try the Ip you suggested.
What do you mean with I can't use player with both networks active? Do you mean I have to type in the Ip instead of http://runeaudio ?


Later
Last edited by Dondorito on 05 Jun 2016, 12:40, edited 1 time in total.
Dondorito
 
Posts: 9
Joined: 04 Jun 2016, 18:31

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby hondagx35 » 05 Jun 2016, 12:37

Hi Dondorito,

sorry but i have no idea what is wrong with your setup or what you are doing.

Setting up wifi on RuneAudio should be easy and straight forward. (OK it is a developer point of view)

- Connect your ethernet cable
- find the IP (your router will tell you) or try http://runeaudio (see quick start for more details)
- connect to the UI
- go to Network page
- click on WLAN0
- wait until the scan is complete
- click on your access point
- enter your credentials (passphrase)
- select static IP and enter your values
- save the profile
- wait until you get a green check mark in front of your SSID
- shut down
- remove ethernet cable
- start your PI
- connect via IP (e.g. http://192.168.0.100)

Frank
User avatar
hondagx35
Moderator
 
Posts: 2382
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby Dondorito » 05 Jun 2016, 12:49

Ahh ok I think I see what my mistake was... Will try this later. Thanks for your patience.
I really feel I got it this time :mrgreen:
Dondorito
 
Posts: 9
Joined: 04 Jun 2016, 18:31

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby Dondorito » 05 Jun 2016, 17:10

Now after another wipe and reinstalling I can access UI, but there is no wlan listed anymore :oops:
Can't seem to turn of the Pi over the Ui. What does it look like? Connection is circling for minutes. Is this normal? Can the Pi be defect? Maybe I killed it when I had to plug power for restart several times?
here is a my debug file:


http://pastebin.com/k4n3q5KW
Dondorito
 
Posts: 9
Joined: 04 Jun 2016, 18:31

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby hondagx35 » 05 Jun 2016, 17:43

Hi Dondorito,

first of all keep cool.

Can the Pi be defect? Maybe I killed it when I had to plug power for restart several times?

No, by cutting power you can not kill your PI.
We only thing that can happen is, you can make the image on your sd card unusable.

Can't seem to turn of the Pi over the Ui. What does it look like? Connection is circling for minutes. Is this normal?

What do you expect to happen?
It is normal that you get the spinning circles after shutdown, because your PI can't respond anymore.
Look at the LEDs on your PI. Depending on the model the green LED goes off or on after shutdown.

but there is no wlan listed anymore

With i Pi3 it has to be there.

Please open a new thread (your problem has nothing to do with "RuneAudio 0.3-beta for Raspberry Pi") and i will guide you through the setup.

Frank

Frank
User avatar
hondagx35
Moderator
 
Posts: 2382
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby bluuu » 15 Jun 2016, 11:46

Hi

I found that hardware volume control for PCM2704 not working.
After plugging this DAC master volume is set to 69%.
I can change it by command line but not by "knob" (setting hardware volume control).

Code: Select all
[  362.268361] usb 1-1.5: USB disconnect, device number 5
[  377.101624] usb 1-1.5: new full-speed USB device number 6 using dwc_otg
[  377.208597] usb 1-1.5: New USB device found, idVendor=08bb, idProduct=2704
[  377.208607] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber
=0
[  377.208613] usb 1-1.5: Product: Hi-Fi Audio DAC
[  377.208619] usb 1-1.5: Manufacturer: bluuu Audio HI-FI USB DAC
[  377.222821] hid-generic 0003:08BB:2704.0002: hidraw0: USB HID v1.00 Device [b
luuu Audio HI-FI USB DAC        Hi-Fi Audio DAC ] on usb-3f980000.usb-1.5/input2


Code: Select all
[root@runeaudio etc]# amixer -c DAC scontents
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 44 [69%] [-20.00dB] [on]
  Front Right: Playback 44 [69%] [-20.00dB] [on]



setting by:
Code: Select all
[root@runeaudio etc]# amixer -c DAC -q sset PCM 100%


i can get:
Code: Select all
[root@runeaudio etc]# amixer -c DAC -R
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]


so i think the little change in UI is needed to make it working

btw. thanks for great stuff
bluuu
 
Posts: 2
Joined: 15 Jun 2016, 11:36

Re: RuneAudio 0.3-beta for Raspberry Pi

Postby Matusalemjr » 25 Jun 2016, 18:40

Hello all!!!
Please, i had read all topic, and I found some suggestions and how to procedure with my issue, I tried all but without success, so, I'm posting here to see if anyone can help me.

My system is a raspberry pi2, and I'm using runeaudio last stable version.
My dad doesn't have a USB input, and I have here a Hiface one that I use in my laptop, well, I wanna use this Hiface on Pi2, if I can. Do it, I can retire my old lap top.
I make a lot of tests, changing the OS, software, etc. Specifically in runeaudio, the hardware was recognized by system, and play, but with a lot of clicks.
In a previous message a user is recommended to compile a driver to use, in a noob in Linux, but I loose some days trying, I can. Update git, etc, but for some reason, doesn't work.
Could anyone help on this?
I'm from Brazil, and I'm very poor, so, I can't spend more money importing a i2s DAC to use here.

I'm appreciate any help.

Tks
Edu

Enviado de meu XT1097 usando Tapatalk
Matusalemjr
 
Posts: 4
Joined: 25 Jun 2016, 18:31

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest