RPi + Runeaudio +Wifi as Accesspoint

Raspberry Pi related support

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby Joe90 » 23 Sep 2016, 23:48

OK

So I guess it is raspbian -> accesspoint, mpd and mpddroid for me then ;)

Thanks for the pointers, Frank :)
Joe90
 
Posts: 13
Joined: 11 Sep 2016, 19:42

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby hondagx35 » 24 Sep 2016, 09:12

Hi Joe90,

So I guess it is raspbian -> accesspoint, mpd and mpddroid for me then ;)

dnsmasq is not needed if you use static IP addresses on your clients.
Connect to the AP and change the IP settings on your Phone or Tablet to static.
Set the IP address to 192.168.1.10 and the NETMASK to 255.255.255.0
GATEWAY = 192.168.1.1 DNS = 192.168.1.1 (or 8.8.8.8)

Frank
User avatar
hondagx35
Moderator
 
Posts: 2370
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby Joe90 » 24 Sep 2016, 12:06

Yay, that works :)

Can connect to the UI using the Chrome browser on my phone.

However, if I try using the RuneAudio app all I get is a black screen with a small half graphic of an upside down Android logo in the top left corner?

Will try a reinstall of the app......ahh that fixed it :)

Looking good to go. Now to get it fired up in the car :)

Many thanks Frank - will write up full howto for RPi Model B in due course.
Joe90
 
Posts: 13
Joined: 11 Sep 2016, 19:42

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby johnbanks » 24 Sep 2016, 13:10

Frank ...
Wireless AP can be made to happen for the old model B, Pi 2 & Pi 3 and with a range of wireless dongles. The instructions are a little bit different in each case though.
So I repeat my suggestion that you make this thread 'sticky' so it appears at/near the top of the forum topic listing.
Your thoughts?
johnbanks
 
Posts: 124
Joined: 11 Jun 2014, 00:16

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby Joe90 » 24 Sep 2016, 13:29

RPi B:

Hmmm

No soundcard?

Connecting USB (stick or HDD) knows is connected, but shows nothing in Library
Joe90
 
Posts: 13
Joined: 11 Sep 2016, 19:42

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby nathanashton » 13 Oct 2016, 11:05

This solution works great but I'm trying to get it working with a different scenario.

I'd like the Pi to be connected either via Ethernet or WiFi to the local network. Then if it is unplugged or away from the network, the AP functionality would kick in.
nathanashton
 
Posts: 4
Joined: 13 Oct 2016, 02:40

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby hondagx35 » 13 Oct 2016, 11:20

Hi nathanashton,

I'd like the Pi to be connected either via Ethernet or WiFi to the local network. Then if it is unplugged or away from the network, the AP functionality would kick in.

This is how the current version works.

If wlan0 does not get an IP address the AP gets started.

Some wifi device can not scan the network while in AP mode, so have to do it in this order:
- configure your wifi connection at home
- enable access point

Frank
User avatar
hondagx35
Moderator
 
Posts: 2370
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby nathanashton » 13 Oct 2016, 23:30

Thanks Frank,

It all seemed to work well without issue until I connected the Wifi to my local network. Since then the AP never comes up, even with Ethernet disconnected, Router turned off and a reboot. If I delete the saved profile and reboot then the AP becomes visible again as expected.
nathanashton
 
Posts: 4
Joined: 13 Oct 2016, 02:40

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby Runebeginner » 20 Oct 2016, 20:37

I have a Raspberry Pi 3 model B. I have followed all the steps mentioned on page 2 of this thread. The AP is not started when I reboot the system.

running redis-cli hgetall AccessPoint gives:
1) "enabled"
2) "1"

I have tried running
Code: Select all
hostapd -d /etc/hostapd/hostapd.conf

Then the AP is visible from my phone but I can not access it because my phone is not assigned an IP. I get the following output.

Code: Select all
[root@runeaudio ~]# hostapd -d /etc/hostapd/hostapd.conf
random: Trying to read entropy from /dev/random
Configuration file: /etc/hostapd/hostapd.conf
nl80211: TDLS supported
nl80211: Supported cipher 00-0f-ac:1
nl80211: Supported cipher 00-0f-ac:5
nl80211: Supported cipher 00-0f-ac:2
nl80211: Supported cipher 00-0f-ac:4
nl80211: Supported cipher 00-0f-ac:6
nl80211: Using driver-based off-channel TX
nl80211: Supported vendor command: vendor_id=0x1018 subcmd=1
nl80211: Use separate P2P group interface (driver advertised support)
nl80211: Enable multi-channel concurrent (driver advertised support)
nl80211: use P2P_DEVICE support
nl80211: interface wlan0 in phy phy0
nl80211: Set mode ifindex 3 iftype 3 (AP)
nl80211: Setup AP(wlan0) - device_ap_sme=0 use_monitor=1
nl80211: Create interface iftype 6 (MONITOR)
Failed to create interface mon.wlan0: -95 (Operation not supported)
nl80211: Driver does not support monitor interface type - try to run without it
nl80211: Enable Probe Request reporting nl_preq=0x1e96b18
nl80211: Register frame type=0x40 (WLAN_FC_STYPE_PROBE_REQ) nl_handle=0x1e96b18 match=
nl80211: Register frame command failed (type=64): ret=-22 (Invalid argument)
nl80211: Register frame match - hexdump(len=0): [NULL]
nl80211: Failed to enable Probe Request frame reporting in AP mode
rfkill: initial event: idx=0 type=1 op=0 soft=0 hard=0
nl80211: Add own interface ifindex 3 (ifidx_reason -1)
nl80211: if_indices[16]: 3(-1)
phy: phy0
BSS count 1, BSSID mask 00:00:00:00:00:00 (0 bits)
nl80211: Regulatory information - country=DE (DFS-ETSI)
nl80211: 2400-2483 @ 40 MHz 20 mBm
nl80211: 5150-5250 @ 80 MHz 20 mBm (no outdoor)
nl80211: 5250-5350 @ 80 MHz 20 mBm (no outdoor) (DFS)
nl80211: 5470-5725 @ 160 MHz 26 mBm (DFS)
nl80211: 57000-66000 @ 2160 MHz 40 mBm
nl80211: Added 802.11b mode based on 802.11g information
Completing interface initialization
Mode: IEEE 802.11g  Channel: 7  Frequency: 2442 MHz
DFS 0 channels required radar detection
nl80211: Set freq 2442 (ht_enabled=0, vht_enabled=0, bandwidth=20 MHz, cf1=2442 MHz, cf2=0 MHz)
  * freq=2442
  * vht_enabled=0
  * ht_enabled=0
  * channel_type=0
RATE[0] rate=10 flags=0x1
RATE[1] rate=20 flags=0x1
RATE[2] rate=55 flags=0x1
RATE[3] rate=110 flags=0x1
RATE[4] rate=60 flags=0x0
RATE[5] rate=90 flags=0x0
RATE[6] rate=120 flags=0x0
RATE[7] rate=180 flags=0x0
RATE[8] rate=240 flags=0x0
RATE[9] rate=360 flags=0x0
RATE[10] rate=480 flags=0x0
RATE[11] rate=540 flags=0x0
hostapd_setup_bss(hapd=0x1e96490 (wlan0), first=1)
wlan0: Flushing old station entries
nl80211: flush -> DEL_STATION wlan0 (all)
nl80211: Station flush failed: ret=-14 (Bad address)
wlan0: Could not connect to kernel driver
wlan0: Deauthenticate all stations
nl80211: sta_remove -> DEL_STATION wlan0 ff:ff:ff:ff:ff:ff --> 0 (Success)
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=0 addr=(nil) key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=0 addr=(nil) key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=0 addr=(nil) key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=0 addr=(nil) key_idx=3 set_tx=0 seq_len=0 key_len=0
Using interface wlan0 with hwaddr b8:27:eb:7f:59:d8 and ssid "RuneAudioAP"
Deriving WPA PSK based on passphrase
SSID - hexdump_ascii(len=11):
     52 75 6e 65 41 75 64 69 6f 41 50                  RuneAudioAP
PSK (ASCII passphrase) - hexdump_ascii(len=9): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
random: Got 20/20 bytes from /dev/random
GMK - hexdump(len=32): [REMOVED]
Key Counter - hexdump(len=32): [REMOVED]
WPA: Delay group state machine start until Beacon frames have been configured
nl80211: Set beacon (beacon_set=0)
nl80211: Beacon head - hexdump(len=62): 80 00 00 00 ff ff ff ff ff ff b8 27 eb 7f 59 d8 b8 27 eb 7f 59 d8 00 00 00 00 00 00 00 00 00 00 64 00 11 04 00 0b 52 75 6e 65 41 75 64 69 6f 41 50 01 08 82 84 8b 96 0c 12 18 24 03 01 07
nl80211: Beacon tail - hexdump(len=57): 2a 01 04 32 04 30 48 60 6c 30 14 01 00 00 0f ac 04 01 00 00 0f ac 04 01 00 00 0f ac 02 0c 00 dd 18 00 50 f2 02 01 01 00 00 03 a4 00 00 27 a4 00 00 42 43 5e 00 62 32 2f 00
nl80211: ifindex=3
nl80211: beacon_int=100
nl80211: dtim_period=2
nl80211: ssid - hexdump_ascii(len=11):
     52 75 6e 65 41 75 64 69 6f 41 50                  RuneAudioAP
  * beacon_int=100
  * dtim_period=2
nl80211: hidden SSID not in use
nl80211: privacy=1
nl80211: auth_algs=0x1
nl80211: wpa_version=0x2
nl80211: key_mgmt_suites=0x2
nl80211: pairwise_ciphers=0x10
nl80211: group_cipher=0x10
WPA: Start group state machine to set initial keys
WPA: group state machine entering state GTK_INIT (VLAN-ID 0)
GTK - hexdump(len=16): [REMOVED]
WPA: group state machine entering state SETKEYSDONE (VLAN-ID 0)
wpa_driver_nl80211_set_key: ifindex=3 (wlan0) alg=3 addr=0x95684 key_idx=1 set_tx=1 seq_len=0 key_len=16
nl80211: KEY_DATA - hexdump(len=16): [REMOVED]
   broadcast key
nl80211: Set wlan0 operstate 0->1 (UP)
netlink: Operstate: ifindex=3 linkmode=-1 (no change), operstate=6 (IF_OPER_UP)
Failed to set TX queue parameters for queue 0.
Failed to set TX queue parameters for queue 1.
Failed to set TX queue parameters for queue 2.
Failed to set TX queue parameters for queue 3.
wlan0: interface state UNINITIALIZED->ENABLED
wlan0: AP-ENABLED
wlan0: Setup of interface done.
ctrl_iface not configured!
RTM_NEWLINK: ifi_index=3 ifname=wlan0 operstate=6 linkmode=0 ifi_family=0 ifi_flags=0x11043 ([UP][RUNNING][LOWER_UP])
Runebeginner
 
Posts: 13
Joined: 20 Oct 2016, 07:58

Re: RPi + Runeaudio +Wifi as Accesspoint

Postby hondagx35 » 20 Oct 2016, 21:51

Hi Runebeginner,

seems like you missed this step
* modify /var/www/command/refresh_nics

Frank
User avatar
hondagx35
Moderator
 
Posts: 2370
Joined: 11 Sep 2014, 22:06
Location: Germany

support RuneAudio Donate with PayPal

PreviousNext

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest