Piano (not 2.1 version) driver not working.

Raspberry Pi related support

Piano (not 2.1 version) driver not working.

Postby Stymieddd » 01 Dec 2018, 17:33

I have not been able to get my Piano DAC to work with Rune since the 0.4 beta. I have been trying off and on for years and still have no sound from it. Volum** works fine. Could the driver for Piano 2.0 be extracted from Volum** and place in Rune?
Stymieddd
 
Posts: 19
Joined: 25 Mar 2014, 04:19

Re: Piano (not 2.1 version) driver not working.

Postby thedman! » 01 Dec 2018, 19:43

I have a Piano DAC.

I'm no expert, but.... Apparently you need to force 32bit audio... Mine works fine after editing /etc/mpd.conf to contain:

Code: Select all
audio_output {
name            "PianoDAC"
type            "alsa"
device          "hw:1,0"
auto_resample   "no"
auto_format     "no"
enabled         "yes"
format          "*:32:*"
}


have a look at http://www.runeaudio.com/forum/using-soxr-resampling-with-rune-0-4-beta-t5835.html and mix the above in with the instructions in the link, you should be good to go...
thedman!
 
Posts: 61
Joined: 24 Mar 2016, 15:45

Re: Piano (not 2.1 version) driver not working.

Postby janui » 01 Dec 2018, 20:44

Hi Stymieddd,
Stymieddd wrote:Could the driver for Piano 2.0 be extracted from Volum** and place in Rune?
No, this is not nessesary, all the allo drivers are already available in rune 0.4 and 0.5. But as thedman! points out it probably needs to be forced to run at 32bit for the Allo Piano 2.0.
What I suggest is first try the selecting the Allo Boss DAC in the I²S kernel modules in the settings UI and reboot. After restarting select the this dac in the MPD UI and test. If this does not work, run the following commands from SSH:
Code: Select all
cp /srv/http/db/redis_acards_details /home/redis_acards_details
sed -i -e '/ALLO Piano DAC (/s/)","mixer_numid":/)","card_option":"format\\t\\"*:32:*\\"","mixer_numid":/' /srv/http/db/redis_acards_details
php /srv/http/db/redis_acards_details
Reboot, reselect the Allo Piano in the MPD UI and retest.
Please let me know if it works. This fix works in the same way for 0.4b and 0.5b.
If all is OK I will build a Piano 2.0 selection into the Settings UI for 0.5b.
janui
PS
Stymieddd wrote:P.S. The commands in the code box had return breaks in them. After I figured that out, all was good.
Fixed, thanks
Last edited by janui on 03 Dec 2018, 22:18, edited 1 time in total.
User avatar
janui
 
Posts: 392
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: Piano (not 2.1 version) driver not working.

Postby Stymieddd » 03 Dec 2018, 20:56

Thank you janui and thedman! ! That was the problem. I ssh'ed the commands and all is good! I CAN USE RUNE AGAIN!!! :D

P.S. The commands in the code box had return breaks in them. After I figured that out, all was good.
Stymieddd
 
Posts: 19
Joined: 25 Mar 2014, 04:19

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: Bing [Bot] and 2 guests