NAS network mount

Raspberry Pi related support

Re: NAS network mount

Postby Nononono » 20 Oct 2016, 21:49

I have not tried cifs yet, but runeaudio does not find anything in a test folder with only one .mp3 file.
Nononono
 
Posts: 5
Joined: 19 Oct 2016, 12:04

Re: NAS network mount

Postby Nononono » 01 Nov 2016, 15:07

Do anyone have something else i could try? I was really looking forward to using runeaudio for playing sacd iso files.
Nononono
 
Posts: 5
Joined: 19 Oct 2016, 12:04

Re: NAS network mount

Postby surfninja » 01 Nov 2016, 16:32

Nononono,
did you try mounting your NAS on a pc (not rune audio)? At least you can narrow down the problem.

I'm using cifs not NFS from a linux box for file sharing. I've turned off anonymous access (I enter a username/passwd when I mount the fs) and haven't had a problem.

I'd probably try to mount the drive from one of my linux boxes and Windows to make sure I have the path and permissions correct.

If you mount is connected to a linux box, you could make file music files wide open (chmod 777 *) to help with permissions.
surfninja
 
Posts: 64
Joined: 13 Mar 2015, 22:06
Location: Twin Cities

Re: NAS network mount

Postby Nononono » 04 Nov 2016, 21:57

I will try to make it work with username and password access. I already have a Linux based player (bluesound) and various computers and ITT devices working with the NAS, so I'm fairly confident that the problem lies at the other end.
Nononono
 
Posts: 5
Joined: 19 Oct 2016, 12:04

Re: NAS network mount

Postby Nononono » 06 Nov 2016, 22:03

Cifs worked perfectly! Indexed in a minute.

Thank you!
Nononono
 
Posts: 5
Joined: 19 Oct 2016, 12:04

Re: NAS network mount

Postby audiopip » 22 Feb 2017, 03:12

Thank you all for this thread, I too had been around this loop several times, but what stopped it working was a silly. In the Synology UI, the references to disk volume are written Volume 1, which being aware of the need for correctness in the path I copied slavishly. And of course it should be volume1. As it happens to make matters worse it does not care about the space (which I noticed early on) but it does care about the capital V (which I didn't).
audiopip
 
Posts: 1
Joined: 21 Feb 2017, 12:19

Re: NAS network mount

Postby johnaco » 12 Jan 2018, 22:58

Hello folks,
I'm very excited to get this running to connect to my new smsl M8A - which already sounds amazing out of my pc.
I am struggling with connecting my RasPi3(b) to my Synology DSM415+.
I have read all the threads related to this and tried MANY of the combinations suggested, but to no avail.
I do have foobar2k and audirvana accessing the NAS without issues.

as ACX suggested:
ls /mnt/MPD/NAS/
does not output anything.

I've set Squash to 'Map all users to admin'
I've changed the daemon user group to root:root and mount flags to nfsvers=3,rw
I've deleted and created the mount multiple times and never been able to get past the red X

I've attached a couple of screenshots to show my config.

Any help really appreciated.
Attachments
ru2.PNG
NAS config
ru2.PNG (48.68 KiB) Viewed 63 times
ru1.PNG
Rune source
ru1.PNG (32.38 KiB) Viewed 63 times
johnaco
 
Posts: 3
Joined: 12 Jan 2018, 22:08

Re: NAS network mount

Postby hondagx35 » 13 Jan 2018, 01:15

Hi,

please read this http://www.runeaudio.com/forum/post21144.html?hilit=synology#p21127.

- try "volume1/music" as Remote directory
- try "Hostname or IP" = *
- try "Hostname or IP" = IP from your PI

Frank
User avatar
hondagx35
 
Posts: 2892
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: NAS network mount

Postby johnaco » 15 Jan 2018, 04:42

Thank your Frank for your reply.
I have followed your suggestions and literally tried all the permutations of these values (see below)
The error I cannot get through now is:
mount.nfs: access denied by server while mounting 192.168.1.8:/volume1/music/listen

There is nothing special about my NAS setup:
Noting on the advanced options, admin has r/w on permissions, nothing on advanced permissions. NFS permissions has runeaudio as host (* times out), r/w, squash = all users to admin, security=sys, enable async, non-priviledged ports, mount sub-folders.

I can ssh into RPi and into NAS. Ping is disabled, but I can ssh RPi <-> NAS. Unfortunately my tech chops are limited, specially networking/mounts.

Can anyone provide me with some hints????
Thank you.

These are the combinations I tried (I've been working on this 3 nights already :( )
@runeaudio

Source
----------
Protocol: NFS
Remote Directory:
volume1/music
volume1/music/
volume1/music/listen
volume1/music/listen/
Mount Flags:
nfsvers=3,ro
nfsvers=3,rw

MPD Config
---------
Daemeon user:group:
root:root
mpd:audio(default)


@NAS
Hostname or IP*:
<RPi IP>
*
runeaudio
Privilege: read/write
Squash:
no mapping
Map all users to admin
security: sys
allow async/non-privileged ports/sub-folders all checked

Depending on the combination, I either get NFS mount time out or permission denied.
johnaco
 
Posts: 3
Joined: 12 Jan 2018, 22:08

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest