Music stops after a few seconds

Raspberry Pi related support

Music stops after a few seconds

Postby Fixitkid » 16 Dec 2016, 22:17

Music was playing when another device was connected to the pi at the same time and suddenly it died. On restarting it won't play anything for more than a few seconds. I am a Unix noob and struggling to get to grips with debug log and what other posts are suggesting.

http://pastebin.com/5KmBJp57
Fixitkid
 
Posts: 3
Joined: 16 Dec 2016, 21:49

Re: Music stops after a few seconds

Postby hondagx35 » 16 Dec 2016, 23:48

Hi Fixitkid,

i have no idea what happened, but please try this:
- MENU->Mpd
- change the "Audio output interface" to analog
- change the "Audio output interface" back to IQaudIO

Frank
User avatar
hondagx35
 
Posts: 2971
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Music stops after a few seconds

Postby Fixitkid » 17 Dec 2016, 08:37

Hey Frank,

Thank you for replying. That actually worked, which is awesome cause I was this close to taking my stereo apart.

Could you lead me to what made you think to try that? I tried a lot of stuff last night including a disc partition to try to sort this, but flicking the output over wasn't in my list. :D

Thanks again

Rob
Fixitkid
 
Posts: 3
Joined: 16 Dec 2016, 21:49

Re: Music stops after a few seconds

Postby hondagx35 » 17 Dec 2016, 10:39

Hi Rob,

nice to hear that it did work.

Could you lead me to what made you think to try that?

Because i had the same problem once on my dev device.
The problem is, that i couldn't figure out what the problem was.

Frank
User avatar
hondagx35
 
Posts: 2971
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Music stops after a few seconds

Postby Fixitkid » 17 Dec 2016, 11:08

OK well thank you for being the voice of experience.

When the music would stop the whole system would freeze. So java dev brain, I started frantically looking for something that looked like a stacktrace, but found nothing.

Ta.

Rob
Fixitkid
 
Posts: 3
Joined: 16 Dec 2016, 21:49

Re: Music stops after a few seconds

Postby hondagx35 » 17 Dec 2016, 11:12

Hi Rob,

it is definitively an issue with MPD (Music Player Daemon).

Frank
User avatar
hondagx35
 
Posts: 2971
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: Music stops after a few seconds

Postby Krayon » 24 Jun 2018, 09:28

hondagx35 wrote:Hi Fixitkid,

i have no idea what happened, but please try this:
- MENU->Mpd
- change the "Audio output interface" to analog
- change the "Audio output interface" back to IQaudIO

Frank

Thank you so much, I was close to giving up on RuneAudio! Same issue as OP - solution worked like a charm.
Krayon
 
Posts: 3
Joined: 07 Dec 2016, 15:37

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest