[Addon] MPD Upgrade

Raspberry Pi related support

Re: [Addon] MPD Upgrade

Postby klassikmann » 02 Jun 2019, 13:59

rern wrote:Update 20190529

Moving forward to MPD 0.21.9.
Now RuneAudio 0.5 can be upgraded again.

rern

My experiment with 0.5b failed. I started from scratch with the latest 0.5b image, I updated the installation with "git pull" and installed the Addons via ssh. The I tried "MPD Upgrade". Here the result:
Code: Select all
wget -qN --no-check-certificate https://github.com/rern/RuneAudio/raw/master/mpd/install.sh
chmod 755 install.sh
./install.sh


 .  Upgrade MPD ...

 .  Prefetch packages ...
:: Synchronizing package databases...
downloading core.db...
downloading extra.db...
error: failed retrieving file 'extra.db' from mirror.archlinuxarm.org : Operation too slow. Less than 1 bytes/sec transferred the last 10 seconds
error: failed to update extra (download library error)
downloading community.db...
resolving dependencies...
cannot resolve "fluidsynth", a dependency of "mpd"
:: The following package cannot be upgraded due to unresolvable dependencies:
 .  Get support files ...
x libcrypto.so.1.1
x libicudata.so.64.2
x libicui18n.so.64.2
x libicuio.so.64.2
x libicutest.so.64.2
x libicutu.so.64.2
x libicuuc.so.64.2
x libreadline.so.8.0
x libssl.so.1.1
 .  Remove conflict packages ...

Packages (4) ashuffle-rune-0.22-6  ffmpeg-rune-3.4.1-3  libsystemd-238.76-1.1  mpd-rune-0.20.20-1

Total Removed Size:  9.01 MiB


:: Processing package changes...
removing ashuffle-rune...
removing ffmpeg-rune...
removing mpd-rune...
/etc/mpd.conf saved as /etc/mpd.conf.pacsave
removing libsystemd...
ldconfig: /usr/lib/libcrypto.so.1.1 is not a symbolic link

ldconfig: /usr/lib/libssl.so.1.1 is not a symbolic link

:: Running post-transaction hooks...
(1/2) Reloading system manager configuration...
/usr/bin/systemctl: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory
error: command failed to execute correctly
(2/2) Arming ConditionNeedsUpdate...
 .  Install MPD ...
cannot resolve "fluidsynth", a dependency of "mpd"
:: The following package cannot be upgraded due to unresolvable dependencies:
 .  Modify files ...
sed: can't read /usr/lib/systemd/system/mpd.service: No such file or directory
systemctl: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory
 .  Start MPD ...


 !  MPD upgrade failed.

Because sometimes the first run of "MPD Upgrade" fails in 0.4b either and the second run succeeds, I repeated the "MPD Upgrade" in 0.5b, also. Here the result:
Code: Select all
wget -qN --no-check-certificate https://github.com/rern/RuneAudio/raw/master/mpd/install.sh
chmod 755 install.sh
./install.sh


 .  Upgrade MPD ...

 .  Prefetch packages ...
:: Synchronizing package databases...
 core is up to date
downloading extra.db...
 community is up to date
resolving dependencies...

Packages (44) archlinuxarm-keyring-20140119-1  fluidsynth-2.0.5-1  gcc-libs-8.2.1+20181127-1  l-smash-2.14.5-1  libass-0.14.0-1  libavc1394-0.5.4-3  libbluray-1.1.1-1  libcddb-1.3.2-5  libcdio-2.1.0-1  libcdio-paranoia-10.2+2.0.0-2  libgme-0.6.2-1  libibus-1.5.20-2  libiec61883-1.2.0-5  libmikmod-3.3.11.1-2  libmodplug-0.8.9.0-2  libraw1394-2.1.2-2  libshout-1:2.4.2-1  libssh-0.8.7-1  libtheora-1.1.1-4  libvpx-1.8.0-1  portaudio-1:19.6.0-5  sdl2-2.0.9-1  speex-1.2.0-2  speexdsp-1.2rc3-4  systemd-libs-242.29-1  twolame-0.3.13-8  v4l-utils-1.16.6-1  vid.stab-1.1-2  wildmidi-0.4.3-1  x264-2:157.r72db4377-1  x265-3.0-1  xvidcore-1.3.5-1  zziplib-0.13.69-1  ffmpeg-1:4.1.3-1  gcc-8.2.1+20181127-1  libgcrypt-1.8.4-1  libgpg-error-1.36-1  libmpdclient-2.16-1  libnfs-4.0.0-3  libwebp-1.0.2-1  mpc-0.31-1  mpd-0.21.9-1  pacman-5.1.3-1.1  wavpack-5.1.0-2

Total Download Size:  63.80 MiB

downloading gcc-libs-8.2.1+20181127-1-armv7h.pkg.tar.xz...
downloading gcc-8.2.1+20181127-1-armv7h.pkg.tar.xz...
downloading libgpg-error-1.36-1-armv7h.pkg.tar.xz...
downloading libgcrypt-1.8.4-1-armv7h.pkg.tar.xz...
downloading systemd-libs-242.29-1-armv7h.pkg.tar.xz...
downloading archlinuxarm-keyring-20140119-1-any.pkg.tar.xz...
downloading pacman-5.1.3-1.1-armv7h.pkg.tar.xz...
downloading libwebp-1.0.2-1-armv7h.pkg.tar.xz...
downloading wavpack-5.1.0-2-armv7h.pkg.tar.xz...
downloading libass-0.14.0-1-armv7h.pkg.tar.xz...
downloading libraw1394-2.1.2-2-armv7h.pkg.tar.xz...
downloading libavc1394-0.5.4-3-armv7h.pkg.tar.xz...
downloading libbluray-1.1.1-1-armv7h.pkg.tar.xz...
downloading libiec61883-1.2.0-5-armv7h.pkg.tar.xz...
downloading libmodplug-0.8.9.0-2-armv7h.pkg.tar.xz...
downloading libssh-0.8.7-1-armv7h.pkg.tar.xz...
downloading libtheora-1.1.1-4-armv7h.pkg.tar.xz...
downloading vid.stab-1.1-2-armv7h.pkg.tar.xz...
downloading libvpx-1.8.0-1-armv7h.pkg.tar.xz...
downloading l-smash-2.14.5-1-armv7h.pkg.tar.xz...
downloading x264-2:157.r72db4377-1-armv7h.pkg.tar.xz...
downloading x265-3.0-1-armv7h.pkg.tar.xz...
downloading xvidcore-1.3.5-1-armv7h.pkg.tar.xz...
downloading libibus-1.5.20-2-armv7h.pkg.tar.xz...
error: downloading sdl2-2.0.9-1-armv7h.pkg.tar.xz...
downloading speexdsp-1.2rc3-4-armv7h.pkg.tar.xz...
downloading speex-1.2.0-2-armv7h.pkg.tar.xz...
downloading v4l-utils-1.16.6-1-armv7h.pkg.tar.xz...
downloading ffmpeg-1:4.1.3-1-armv7h.pkg.tar.xz...
downloading portaudio-1:19.6.0-5-armv7h.pkg.tar.xz...
downloading fluidsynth-2.0.5-1-armv7h.pkg.tar.xz...
downloading libcddb-1.3.2-5-armv7h.pkg.tar.xz...
downloading libcdio-2.1.0-1-armv7h.pkg.tar.xz...
downloading libcdio-paranoia-10.2+2.0.0-2-armv7h.pkg.tar.xz...
downloading libgme-0.6.2-1-armv7h.pkg.tar.xz...
downloading libmikmod-3.3.11.1-2-armv7h.pkg.tar.xz...
downloading libmpdclient-2.16-1-armv7h.pkg.tar.xz...
downloading libshout-1:2.4.2-1-armv7h.pkg.tar.xz...
downloading wildmidi-0.4.3-1-armv7h.pkg.tar.xz...
downloading zziplib-0.13.69-1-armv7h.pkg.tar.xz...
downloading mpd-0.21.9-1-armv7h.pkg.tar.xz...
downloading mpc-0.31-1-armv7h.pkg.tar.xz...
downloading libnfs-4.0.0-3-armv7h.pkg.tar.xz...
downloading twolame-0.3.13-8-armv7h.pkg.tar.xz...
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
 .  Get support files ...
 .  Remove conflict packages ...
 .  Install MPD ...
looking for conflicting packages...

Packages (44) archlinuxarm-keyring-20140119-1  fluidsynth-2.0.5-1  gcc-libs-8.2.1+20181127-1  l-smash-2.14.5-1  libass-0.14.0-1  libavc1394-0.5.4-3  libbluray-1.1.1-1  libcddb-1.3.2-5  libcdio-2.1.0-1  libcdio-paranoia-10.2+2.0.0-2  libgme-0.6.2-1  libibus-1.5.20-2  libiec61883-1.2.0-5  libmikmod-3.3.11.1-2  libmodplug-0.8.9.0-2  libraw1394-2.1.2-2  libshout-1:2.4.2-1  libssh-0.8.7-1  libtheora-1.1.1-4  libvpx-1.8.0-1  portaudio-1:19.6.0-5  sdl2-2.0.9-1  speex-1.2.0-2  speexdsp-1.2rc3-4  systemd-libs-242.29-1  twolame-0.3.13-8  v4l-utils-1.16.6-1  vid.stab-1.1-2  wildmidi-0.4.3-1  x264-2:157.r72db4377-1  x265-3.0-1  xvidcore-1.3.5-1  zziplib-0.13.69-1  ffmpeg-1:4.1.3-1  gcc-8.2.1+20181127-1  libgcrypt-1.8.4-1  libgpg-error-1.36-1  libmpdclient-2.16-1  libnfs-4.0.0-3  libwebp-1.0.2-1  mpc-0.31-1  mpd-0.21.9-1  pacman-5.1.3-1.1  wavpack-5.1.0-2

Total Download Size:     5.16 MiB
Total Installed Size:  292.03 MiB
Net Upgrade Size:      120.44 MiB

downloading libibus-1.5.20-2-armv7h.pkg.tar.xz...
checking keyring...
checking package integrity...
loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libnfs...
upgrading gcc-libs...
upgrading libwebp...
upgrading gcc...
reinstalling wavpack...
installing libass...
installing libraw1394...
installing libavc1394...
installing libbluray...
Optional dependencies for libbluray
    java-runtime=8: BD-J library
installing libiec61883...
installing libmodplug...
installing libssh...
installing libtheora...
installing vid.stab...
upgrading libvpx...
installing l-smash...
installing x264...
installing x265...
installing xvidcore...
installing libibus...
installing sdl2...
Optional dependencies for sdl2
    alsa-lib: ALSA audio driver [installed]
    libpulse: PulseAudio audio driver [installed]
    jack: JACK audio driver [installed]
installing speexdsp...
installing speex...
installing v4l-utils...
Optional dependencies for v4l-utils
    qt5-base
    alsa-lib [installed]
upgrading libgpg-error...
upgrading libgcrypt...
installing systemd-libs...
installing ffmpeg...
Optional dependencies for ffmpeg
    ladspa: LADSPA filters [installed]
installing archlinuxarm-keyring...
upgrading pacman...
/etc/pacman.conf installed as /etc/pacman.conf.pacnew
New optional dependencies for pacman
    perl-locale-gettext: translation support in makepkg-template
    xdelta3: delta support in repo-add
installing portaudio...
installing fluidsynth...
Optional dependencies for fluidsynth
    pulseaudio: PulseAudio sound support
installing libcddb...
installing libcdio...
installing libcdio-paranoia...
installing libgme...
installing libmikmod...
upgrading libmpdclient...
installing libshout...
installing twolame...
installing wildmidi...
installing zziplib...
installing mpd...
upgrading mpc...
ldconfig: /usr/lib/libcrypto.so.1.1 is not a symbolic link

ldconfig: /usr/lib/libssl.so.1.1 is not a symbolic link

:: Running post-transaction hooks...
(1/8) Updating icon theme caches...
(2/8) Reloading system manager configuration...
/usr/bin/systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
/usr/bin/systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
/usr/bin/systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
/usr/bin/systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
error: command failed to execute correctly
(3/8) Creating system user accounts...
/usr/bin/systemd-sysusers: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
/usr/bin/systemd-sysusers: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
/usr/bin/systemd-sysusers: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
/usr/bin/systemd-sysusers: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
error: command failed to execute correctly
(4/8) Creating temporary files...
/usr/bin/systemd-tmpfiles: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
/usr/bin/systemd-tmpfiles: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
/usr/bin/systemd-tmpfiles: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
/usr/bin/systemd-tmpfiles: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
error: command failed to execute correctly
(5/8) Reloading device manager configuration...
/usr/bin/udevadm: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
/usr/bin/udevadm: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
/usr/bin/udevadm: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
/usr/bin/udevadm: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
error: command failed to execute correctly
(6/8) Arming ConditionNeedsUpdate...
(7/8) Updating the info directory file...
(8/8) Updating the desktop file MIME type cache...
 .  Modify files ...
systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
 .  Start MPD ...


 !  MPD upgrade failed.

After that the installation was fully corrupted, as you can see:
Code: Select all
wget -qN --no-check-certificate https://github.com/rern/RuneAudio/raw/master/mpd/install.sh
chmod 755 install.sh
./install.sh
sudo: error in /etc/sudo.conf, line 0 while loading plugin "sudoers_policy"
sudo: unable to load /usr/lib/sudo/sudoers.so: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
sudo: fatal error, unable to load plugins


AndyF wrote:is MPD 0.21.x worth a try?
I need actual mpd/ffmpeg because my webradios consisting of "MPEG2 Transport Streams" containing "MPEG 1 Audio Layer 2" (mp2) do not work in aged mpd.

klassikmann
RPI 2B + HifiBerry Digi+ Pro + RuneAudio 0.5b (build 11) + RuneUI Enhancements (not pre-installed)
klassikmann
 
Posts: 66
Joined: 27 Apr 2016, 18:36

Re: [Addon] MPD Upgrade

Postby rern » 02 Jun 2019, 14:44

@klassikmann,

Your progress terminal shows errors about incomplete package databases and packages themselves. This happened to me most of the time lately. That's why packages for coverarts and metadata editor are bundled for download from GitHub instead. (I have asked @janui to consider pre-installing them in next release of 0.5/0.6.) But MPD is more dynamic and critical in term of upgrade so it has to be done directly against ArchLinuxArm package servers.

Try download all needed ones beforehand:
Code: Select all
pacman -Syw --noconfirm libnfs libwebp gcc wavpack ffmpeg pacman mpd mpc libmpdclient libgcrypt libgpg-error

Repeat it if there're still some errors. Once they're ready, continue install normally from Addons.

rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 415
Joined: 14 Jul 2016, 08:15

Re: [Addon] MPD Upgrade

Postby klassikmann » 03 Jun 2019, 09:38

rern wrote:@klassikmann,

Your progress terminal shows errors about incomplete package databases and packages themselves. This happened to me most of the time lately. That's why packages for coverarts and metadata editor are bundled for download from GitHub instead. (I have asked @janui to consider pre-installing them in next release of 0.5/0.6.) But MPD is more dynamic and critical in term of upgrade so it has to be done directly against ArchLinuxArm package servers.

Try download all needed ones beforehand:
Code: Select all
pacman -Syw --noconfirm libnfs libwebp gcc wavpack ffmpeg pacman mpd mpc libmpdclient libgcrypt libgpg-error

Repeat it if there're still some errors. Once they're ready, continue install normally from Addons.

rern

I did it, but without success.
First I installed the prerequisites. I had to do it twice because of a temporary slow connection to the ArchLinux servers. Second trial successful.

Than I executed "MPD Upgrade":
Code: Select all
wget -qN --no-check-certificate https://github.com/rern/RuneAudio/raw/master/mpd/install.sh
chmod 755 install.sh
./install.sh


 .  Upgrade MPD ...

 .  Prefetch packages ...
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
resolving dependencies...

Packages (44) archlinuxarm-keyring-20140119-1  fluidsynth-2.0.5-1  gcc-libs-8.2.1+20181127-1  l-smash-2.14.5-1  libass-0.14.0-1  libavc1394-0.5.4-3  libbluray-1.1.1-1  libcddb-1.3.2-5  libcdio-2.1.0-1  libcdio-paranoia-10.2+2.0.0-2  libgme-0.6.2-1  libibus-1.5.20-2  libiec61883-1.2.0-5  libmikmod-3.3.11.1-2  libmodplug-0.8.9.0-2  libraw1394-2.1.2-2  libshout-1:2.4.2-1  libssh-0.8.7-1  libtheora-1.1.1-4  libvpx-1.8.0-1  portaudio-1:19.6.0-5  sdl2-2.0.9-1  speex-1.2.0-2  speexdsp-1.2rc3-4  systemd-libs-242.29-1  twolame-0.3.13-8  v4l-utils-1.16.6-1  vid.stab-1.1-2  wildmidi-0.4.3-1  x264-2:157.r72db4377-1  x265-3.0-1  xvidcore-1.3.5-1  zziplib-0.13.69-1  ffmpeg-1:4.1.3-1  gcc-8.2.1+20181127-1  libgcrypt-1.8.4-1  libgpg-error-1.36-1  libmpdclient-2.16-1  libnfs-4.0.0-3  libwebp-1.0.2-1  mpc-0.31-1  mpd-0.21.9-1  pacman-5.1.3-1.1  wavpack-5.1.0-2

Total Download Size:  0.00 MiB

 .  Get supporting files ...
x libcrypto.so.1.1
x libicudata.so.64.2
x libicui18n.so.64.2
x libicuio.so.64.2
x libicutest.so.64.2
x libicutu.so.64.2
x libicuuc.so.64.2
x libreadline.so.8.0
x libssl.so.1.1
 .  Remove conflict packages ...

Packages (4) ashuffle-rune-0.22-6  ffmpeg-rune-3.4.1-3  libsystemd-238.76-1.1  mpd-rune-0.20.20-1

Total Removed Size:  9.01 MiB


:: Processing package changes...
removing ashuffle-rune...
removing ffmpeg-rune...
removing mpd-rune...
/etc/mpd.conf saved as /etc/mpd.conf.pacsave
removing libsystemd...
ldconfig: /usr/lib/libcrypto.so.1.1 is not a symbolic link

ldconfig: /usr/lib/libssl.so.1.1 is not a symbolic link

:: Running post-transaction hooks...
(1/2) Reloading system manager configuration...
/usr/bin/systemctl: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory
error: command failed to execute correctly
(2/2) Arming ConditionNeedsUpdate...
 .  Install MPD ...
looking for conflicting packages...

Packages (44) archlinuxarm-keyring-20140119-1  fluidsynth-2.0.5-1  gcc-libs-8.2.1+20181127-1  l-smash-2.14.5-1  libass-0.14.0-1  libavc1394-0.5.4-3  libbluray-1.1.1-1  libcddb-1.3.2-5  libcdio-2.1.0-1  libcdio-paranoia-10.2+2.0.0-2  libgme-0.6.2-1  libibus-1.5.20-2  libiec61883-1.2.0-5  libmikmod-3.3.11.1-2  libmodplug-0.8.9.0-2  libraw1394-2.1.2-2  libshout-1:2.4.2-1  libssh-0.8.7-1  libtheora-1.1.1-4  libvpx-1.8.0-1  portaudio-1:19.6.0-5  sdl2-2.0.9-1  speex-1.2.0-2  speexdsp-1.2rc3-4  systemd-libs-242.29-1  twolame-0.3.13-8  v4l-utils-1.16.6-1  vid.stab-1.1-2  wildmidi-0.4.3-1  x264-2:157.r72db4377-1  x265-3.0-1  xvidcore-1.3.5-1  zziplib-0.13.69-1  ffmpeg-1:4.1.3-1  gcc-8.2.1+20181127-1  libgcrypt-1.8.4-1  libgpg-error-1.36-1  libmpdclient-2.16-1  libnfs-4.0.0-3  libwebp-1.0.2-1  mpc-0.31-1  mpd-0.21.9-1  pacman-5.1.3-1.1  wavpack-5.1.0-2

Total Installed Size:  292.03 MiB
Net Upgrade Size:      120.44 MiB

loading package files...
checking for file conflicts...
checking available disk space...
:: Processing package changes...
upgrading libnfs...
upgrading gcc-libs...
upgrading libwebp...
upgrading gcc...
reinstalling wavpack...
installing libass...
installing libraw1394...
installing libavc1394...
installing libbluray...
Optional dependencies for libbluray
    java-runtime=8: BD-J library
installing libiec61883...
installing libmodplug...
installing libssh...
installing libtheora...
installing vid.stab...
upgrading libvpx...
installing l-smash...
installing x264...
installing x265...
installing xvidcore...
installing libibus...
installing sdl2...
Optional dependencies for sdl2
    alsa-lib: ALSA audio driver [installed]
    libpulse: PulseAudio audio driver [installed]
    jack: JACK audio driver [installed]
installing speexdsp...
installing speex...
installing v4l-utils...
Optional dependencies for v4l-utils
    qt5-base
    alsa-lib [installed]
upgrading libgpg-error...
upgrading libgcrypt...
installing systemd-libs...
installing ffmpeg...
Optional dependencies for ffmpeg
    ladspa: LADSPA filters [installed]
installing archlinuxarm-keyring...
upgrading pacman...
New optional dependencies for pacman
    perl-locale-gettext: translation support in makepkg-template
    xdelta3: delta support in repo-add
installing portaudio...
installing fluidsynth...
Optional dependencies for fluidsynth
    pulseaudio: PulseAudio sound support
installing libcddb...
installing libcdio...
installing libcdio-paranoia...
installing libgme...
installing libmikmod...
upgrading libmpdclient...
installing libshout...
installing twolame...
installing wildmidi...
installing zziplib...
installing mpd...
upgrading mpc...
ldconfig: /usr/lib/libcrypto.so.1.1 is not a symbolic link

ldconfig: /usr/lib/libssl.so.1.1 is not a symbolic link

:: Running post-transaction hooks...
(1/8) Updating icon theme caches...
(2/8) Reloading system manager configuration...
/usr/bin/systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
/usr/bin/systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
/usr/bin/systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
/usr/bin/systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
error: command failed to execute correctly
(3/8) Creating system user accounts...
/usr/bin/systemd-sysusers: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
/usr/bin/systemd-sysusers: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
/usr/bin/systemd-sysusers: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
/usr/bin/systemd-sysusers: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
error: command failed to execute correctly
(4/8) Creating temporary files...
/usr/bin/systemd-tmpfiles: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
/usr/bin/systemd-tmpfiles: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
/usr/bin/systemd-tmpfiles: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
/usr/bin/systemd-tmpfiles: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
error: command failed to execute correctly
(5/8) Reloading device manager configuration...
/usr/bin/udevadm: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
/usr/bin/udevadm: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
/usr/bin/udevadm: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
/usr/bin/udevadm: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
error: command failed to execute correctly
(6/8) Arming ConditionNeedsUpdate...
(7/8) Updating the info directory file...
(8/8) Updating the desktop file MIME type cache...
 .  Modify files ...
systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgcrypt.so.20)
systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libgpg-error.so.0)
systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libudev.so.1)
systemctl: /usr/lib/libc.so.6: version `GLIBC_2.28' not found (required by /usr/lib/libsystemd.so.0)
 .  Start MPD ...


 !  MPD upgrade failed.
After that the system was unusable.

klassikmann
RPI 2B + HifiBerry Digi+ Pro + RuneAudio 0.5b (build 11) + RuneUI Enhancements (not pre-installed)
klassikmann
 
Posts: 66
Joined: 27 Apr 2016, 18:36

Re: [Addon] MPD Upgrade

Postby rern » 03 Jun 2019, 12:32

@klassikmann,

You're almost there.
GLIBC_2.28 was missing. Tracing back to RuneUIe was not installed which I have fix it for upgrading without RuneUIe.

The pre-upgrade download must include GLIBC:
Code: Select all
pacman -Syw --noconfirm libnfs libwebp gcc wavpack ffmpeg pacman mpd mpc libmpdclient libgcrypt libgpg-error glibc


rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 415
Joined: 14 Jul 2016, 08:15

Re: [Addon] MPD Upgrade

Postby klassikmann » 03 Jun 2019, 16:33

rern wrote:@klassikmann,

You're almost there.
GLIBC_2.28 was missing. Tracing back to RuneUIe was not installed which I have fix it for upgrading without RuneUIe.

The pre-upgrade download must include GLIBC:
Code: Select all
pacman -Syw --noconfirm libnfs libwebp gcc wavpack ffmpeg pacman mpd mpc libmpdclient libgcrypt libgpg-error glibc


rern

Success! Thank you.

In the next time I make me familar with 0.5b + UIe Addons.

klassikmann
RPI 2B + HifiBerry Digi+ Pro + RuneAudio 0.5b (build 11) + RuneUI Enhancements (not pre-installed)
klassikmann
 
Posts: 66
Joined: 27 Apr 2016, 18:36

Re: [Addon] MPD Upgrade

Postby porcupiney » 02 Jul 2019, 18:51

Hi,

I have used the method discussed earlier in the topic to upgrade MPD on my RaspPi 3B - all works fine, and I can now listen to BBC
320K streams on that unit.

I tried to upgrade MPD on my Pi Zero, using exactly the same procedure, but the upgrade fails:

(1/2) Reloading system manager configuration...
/usr/bin/systemctl: error while loading shared libraries: libudev.so.1: cannot open shared object file: No such file or directory
error: command failed to execute correctly


After the failed upgrade, any attempt to run mpd results in core dump error.

I am trying this upgrade in vain?

Cheers,

Dave
Raspberry Pi Zero W; Rune 0.5b; JustBoom Zero HAT
Raspberry Pi B 2; Rune 0.5b; JustBoom HAT
porcupiney
 
Posts: 7
Joined: 20 Dec 2017, 17:26

Re: [Addon] MPD Upgrade

Postby rern » 03 Jul 2019, 14:44

Hi Dave,

The missing libudev.so.1 is a file from systemd-libs. Try install it:
Code: Select all
pacman -Sy systemd-libs


rern
Raspberry Pi 3 > SMSL M8 DAC
GitHub
rern
 
Posts: 415
Joined: 14 Jul 2016, 08:15

support RuneAudio Donate with PayPal

Previous

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 10 guests