MPD missing files

Raspberry Pi related support

MPD missing files

Postby zerocover » 17 Apr 2018, 01:15

So I have a ton of music but only a small amount of it is showing up in the scanned library. I'm not seeing any errors on the logs. Is there a folder dept setting or something that would cause files to be ignored?
User avatar
zerocover
 
Posts: 5
Joined: 08 Mar 2017, 03:18

Re: MPD missing files

Postby janui » 17 Apr 2018, 07:49

Hi zerocover,
It is usually a permissions/rights problem i they do not show up at all. Depending on the version of Rune which you are using it can also take a while to build up the library. MPD has some problems with corrupted music files; if a file extension identifies it as a music file but metadata is corrupt/unreadable it seems to retry for an excessively long period before giving up.
janui
User avatar
janui
 
Posts: 243
Joined: 20 Dec 2014, 12:55
Location: Ollanda

Re: MPD missing files

Postby zerocover » 17 Apr 2018, 08:40

Hmm. I get like 200 or so songs.

This is using NFS. I had been using SMB on an older build and had access to the whole library, trying to use NFS just because its 2x faster. Scanning did complete, I've also tried rebuilding the database. Is it possible one of the files is corrupted and MPD just gives up on it + everything after it?
User avatar
zerocover
 
Posts: 5
Joined: 08 Mar 2017, 03:18

Re: MPD missing files

Postby janui » 18 Apr 2018, 09:50

Hi zerocover,
I have never seen MPD fail completely, but I suppose it’s possible. I still think the more likely cause is a file protections/permissions/rights problem. I assume you are using a wired ethernet connection, but if you are using WiFi this could also be the cause.
janui
User avatar
janui
 
Posts: 243
Joined: 20 Dec 2014, 12:55
Location: Ollanda

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 1 guest