MPD Builds

Raspberry Pi related support

MPD Builds

Postby eea123 » 30 Sep 2018, 19:10

My NAS is getting loaded up, as such it takes a few hours to update the MPD each time I add a few CD folders. Does anyone have a quick way tp either edit the MPD or an alternate program which will just append new subdirectories / files?

Thanks.
eea123
 
Posts: 19
Joined: 23 Dec 2017, 19:19

Re: MPD Builds

Postby hondagx35 » 30 Sep 2018, 22:40

Hi eea123,

will just append new subdirectories / files?

This is how it should work and works for me if auto update is enabled (see mpd settings page).

Frank
User avatar
hondagx35
 
Posts: 2990
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: MPD Builds

Postby cmh714 » 01 Oct 2018, 03:30

just out of curiosity what does loaded up equate to? I have almost 40000 flac files/songs and that takes I think about 15 minutes or so to update fully.
cmh714
 
Posts: 309
Joined: 04 May 2014, 03:06

Re: MPD Builds

Postby eea123 » 09 Oct 2018, 12:11

cmh714,
Nowhere near 40,000 files, but 500 CDs each in their own subdirectory. Double or triple CDs might mean 20 files per directory, so maybe 1/4 of your library. I would estimates it takes 2 hours to manually update the MPD when I add a single CD / directory.

Frank,
My auto update feature was disabled, so I turned that ON. When I do a manual update of the NAS' library under Network Mounts is when it rebuilds the whole MPD. When it is doing that, it typically won't even let me browse the NAS while the MPD is being indexed. Sometimes it will, but the listing is incomplete and not in alphabetical order.

Thanks for the help and input on this. I'll update my post when I get home from work.
eea123
 
Posts: 19
Joined: 23 Dec 2017, 19:19

Re: MPD Builds

Postby ianhaynes » 09 Oct 2018, 12:35

FWIW, according to the debug info I have 752 albums, although not sure how many directories, with 9647 tracks. Just tested and it took 6:02 minutes to update.

Ian
Pi 2, Ver. 0.4b build 20170229, IQAudio DAC+
ianhaynes
 
Posts: 201
Joined: 04 Mar 2015, 12:51

Re: MPD Builds

Postby eea123 » 10 Oct 2018, 10:38

I dropped two new CD folders onto my music directory on the NSA. Still a no show this morning for a background / realtime update of the MPD directory. That would have been 6pm and it is now 4:30am.

I XXXX'd out my user name, but I think these are the two related portions of the debug report regarding the NAS stats directly copy and pasted here.

###### Filesystem mounts ######
//10.0.0.73/Multimedia/Music /mnt/MPD/NAS/NAS0960A5 cifs ro,relatime,vers=1.0,sec=ntlm,cache=none,username=XXXXXXX,uid=1000,forceuid,gid=92,forcegid,addr=10.0.0.73,file_mode=0755,dir_mode=0755,nounix,mapposix,rsize=16384,wsize=17408,actimeo=1 0 0

###### Filesystem mounts - free space (df -h) ######
//10.0.0.73/Multimedia/Music 3.6T 1.1T 2.6T 29% /mnt/MPD/NAS/NAS0960A5


I have a x2, 4Tb RAID 1 setup. The NAS to Raspberry PI connection is hardwired and I usually see 100Mb speeds for transfer when I copy files straight across from my PC to NAS.
eea123
 
Posts: 19
Joined: 23 Dec 2017, 19:19

Re: MPD Builds

Postby MidnightExpress » 11 Oct 2018, 04:43

Hi eea123,

FYI, I have a pretty old Qnap NAS which is configured as RAID5 and is pretty full (90% full). When I copy new album folders to the NAS, it almost stops responding. i.e. I cannot access to the other network folders until it is done copying files. The performance of my NAS is pretty bad!

According to my Rune's debug information, I have 1,200+ albums and 15,000+ tracks and according to my NAS info, my music library has 900+ folders. Today, I added 6 new album folders to the NAS, it took 1:38 minutes to update.

As per my memory, a newly created network mount (in my case) took less than 30 minutes to complete the build.

MidnightExpress
Pi3b+, Ver. Experimental Beta 0.5 20180903, ES9018K2M Dac
MidnightExpress
 
Posts: 12
Joined: 04 Aug 2018, 12:19

Re: MPD Builds

Postby Beelzebassie » 11 Oct 2018, 08:03

Off-topic:

The choice is yours, of course, but when archiving CD's why not use images and cue-sheets? Less files, extremely easy way to handle HTOA, edit pauses, etc.
Beelzebassie
 
Posts: 26
Joined: 09 Nov 2014, 12:16

Re: MPD Builds

Postby eea123 » 13 Oct 2018, 12:33

Old habits I guess. I've been using WinAMP since the late 90s early 00s to create FLAC files to archive my CDs and also to make MP3s (WinAMP frontend w/ LAME).
eea123
 
Posts: 19
Joined: 23 Dec 2017, 19:19

Re: MPD Builds

Postby eea123 » 13 Oct 2018, 14:17

MidnightExpress wrote:Hi eea123,

FYI, I have a pretty old Qnap NAS which is configured as RAID5 and is pretty full (90% full). When I copy new album folders to the NAS, it almost stops responding. i.e. I cannot access to the other network folders until it is done copying files. The performance of my NAS is pretty bad!

According to my Rune's debug information, I have 1,200+ albums and 15,000+ tracks and according to my NAS info, my music library has 900+ folders. Today, I added 6 new album folders to the NAS, it took 1:38 minutes to update.

As per my memory, a newly created network mount (in my case) took less than 30 minutes to complete the build.

MidnightExpress


I wonder if my QNAP security settings are part of the problem? I just logged into the QNAP as Admin and see that IP 92.37.142.164 was banned for 5 minutes for hammering the NAS. All of my local IPs should be 10.X.X.X, but is there a funky external call from Rune to rebuild the MPD?

Hardware-wise, the QNAP NAS is a TS-251+. That one has an Intel based quad-core with dual 1Gb ethernet ports and 8Gb of RAM.
eea123
 
Posts: 19
Joined: 23 Dec 2017, 19:19

support RuneAudio Donate with PayPal

Next

Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 7 guests