help me ! - distorted sound 24/48kHz

ODROID related support

help me ! - distorted sound 24/48kHz

Postby sern » 22 Aug 2016, 19:05

Hi ,

My Odroid c1+ - sound via I2S to external DAC. Music library on USB HDD . and what I found : when I try to listen music from HDD (no matter if it is 120GB SSD or 500 GB "classic" 2,5'' drive or USB Pendrive ) 24b/48kHZ (it is last Radiohead ) everything seems OK with first track (it can be last track but firstly played) but when the next track is coming it is heavy distorted ! when i press "stop" and "play" again everything is OK. Till the next track -again distorted. again "stop" and "play" and OK. sometimes it can play 2 tracks perfectly .... but third again distorted....
When I tried Volumio and it plays perfectly everything . But I want Runeaudio because for me it sounds much better ! Period. and this odd behaviour drives me crazy.... i think it is software related problem - Volumio plays without distortions....
Just checked - 24bit/88.2kHz OK , 16bit / 44.1kHz Ok ... 24bit /48kHz FLAC - OK 24bit/96kHz wav -ok ... Radiohead is 24bit /48kHz WAV..
24bit/44.1kHz wav -OK. Problem with 24bit/ 48kHz files ?? so why not with 24bit/96kHz ... ? ???
sern
 
Posts: 5
Joined: 20 Aug 2016, 17:23

Re: help me ! - distorted sound 24/48kHz

Postby hondagx35 » 22 Aug 2016, 22:54

Hi sern,

welcome to RuneAudio.

My Odroid c1+ - sound via I2S to external DAC.

With ODROID Hifishield or something else?
when i press "stop" and "play" again everything is OK.

This restarts the clock on the I2S output, so it seems to be a problem with the DAC.

Get access to the console and enter this command:
Code: Select all
cat /proc/asound/card*/pcm*p/sub*/hw_params

What is the output while playing a distorted song?

Frank

- Get access to the console:
Use SSH from your PC
    If you are not familiar with SSH read this for Windows or this for Linux/MacOS
    The default login for RuneAudio is "root" with the password "rune" (without quotes).
User avatar
hondagx35
 
Posts: 3016
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: help me ! - distorted sound 24/48kHz

Postby sern » 23 Aug 2016, 01:14

it is audio-gd's HDMI I2S output module to Raleigh Audio input module next is Ian's FIFO and reclocking (from diyaudio.com) and dual mono
TwistedPearAudio DAC (WM8741 based) ...

output from "your" command is :

closed
access: RW_INTERLEAVED
format: S32_LE
subformat: STD
channels: 2
rate: 48000 (48000/1)
period_size : 2048
buffer_size: 8192

as i wrote : no problems with my DAC/FIFO with all kind of music files/formats
maybe my Odroid is defective ?

BTW , why Rune "sees" all my 24bit wav's as 32bit ? i've converted this Radiohead album to FLAC and now Rune tells me "24bit"
and format is S24_LE and plays it all undistorted...
sern
 
Posts: 5
Joined: 20 Aug 2016, 17:23

Re: help me ! - distorted sound 24/48kHz

Postby hondagx35 » 23 Aug 2016, 10:42

Hi sern,

BTW , why Rune "sees" all my 24bit wav's as 32bit ?

The question is, why sees MPD your WAVs as 32bit?
I will do some tests and see what the reason is.

i've converted this Radiohead album to FLAC and now Rune tells me "24bit"
and format is S24_LE and plays it all undistorted...

I have my whole music library in FLAC format, because it offers better tagging support.
So i didn't test WAV on the ODROID in depth.

BTW: Nice setup!

Frank
User avatar
hondagx35
 
Posts: 3016
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: help me ! - distorted sound 24/48kHz

Postby sern » 23 Aug 2016, 16:02

Thank you very much ! nicest setup is nothing without your excellent RuneAudio software..... :)
(exactly - i have quad-mono Opus Dac ...)
about 32 bit wav's - yesterday I read , that it is something ALSA - related ALSA needs additional 8 bit for transport or sth.... but final
output is 24 bit. I don't know if it is true .
I'll play with these 24/48 wav's .. will see..
My music library is mostly in wav files because I used a PC- based (win XP heavily cutted, linear PS) CiCS memory player (CMP2/Cplay) with I2S output via Esi Juli@ card and for it wav's and cue sheets are "native" files.... but when I heard Odroid with yours RuneAudio i decided to switch to Rune. Despite for inconvenient for me mainly because of changes to music library structure and lack of direct display /screen
sonically it is step (big) forward. and some talks that I2S should sounds the same in every case.....
sern
 
Posts: 5
Joined: 20 Aug 2016, 17:23

Re: help me ! - distorted sound 24/48kHz

Postby hondagx35 » 23 Aug 2016, 20:11

Hi sern,

Despite for inconvenient for me mainly because of changes to music library structure and lack of direct display /screen

You can add a local display, Rune (RP2/3 and ODROID-C2) is able to display the UI locally.

Frank
User avatar
hondagx35
 
Posts: 3016
Joined: 11 Sep 2014, 22:06
Location: Germany

Re: help me ! - distorted sound 24/48kHz

Postby sern » 25 Aug 2016, 16:21

yes , I know about local browser , but I need configure it by ethernet first (or use Odroid Magazine image ) but I'm starting to get used...
and learning.... (it is not so hard - I remember x386 PC's and MS-DOS )
OK. I've played with some wav's , setup etc. I bought Odroid C2 (with last Rune rc image ). I've tried Madeleine Peyroux The Blue Room bought at HDtracks (separate wav tracks 24/44.1 ) and distortions the same . Radiohead - same distortions after player start to play next track... Again , I must say it happens only with separate 24 bit wav tracks .
on Volumio ("...rc2fix" image for C2) - everything is OK . So , something is missed in RuneAudio with 24bit wav's .....
I know , that wav's are rare and I can convert it to flac's but wav is still studio standard .....
sern
 
Posts: 5
Joined: 20 Aug 2016, 17:23

Re: help me ! - distorted sound 24/48kHz

Postby sern » 27 Aug 2016, 17:11

My last try (i thought that it could be setup fault) - i rebuilt my old Buffalo IIIse DAC + Ian's FIFO and Si570 reclocking module and audio-gd's output and input I2S to HDMI modules and ... I've got the distorted sound same as with previous setup. With Volumio - no distortions.
of course distortions only with 24bit single track wav's - first track played perfectly next track starts distorted....
How distorted ? hmm the simplest answer could be : like frying music....

I tried some more - and this is what I finally found : it happens only with 24bit wav and 44.1kHz and 24/48kHz . And only with tracks/files
within 1 album - when tracks are added to playlist one after the another (first track +second .... ) but all tracks are from the same album - the second played is distorted (and next too) Usually I listen the music by whole albums not by tracks and when I made "patchworked" playlist
- first track from Radiohead , second from Gotye (all 24bit/44.1kHz) everything is OK , no distortions ..... but 2 tracks from the same album - second always distorted. ?!?!
24bit wav higher then 48kHz - everything OK. wt... ?!?!
sorry for my english ....
sern
 
Posts: 5
Joined: 20 Aug 2016, 17:23

support RuneAudio Donate with PayPal


Return to ODROID

Who is online

Users browsing this forum: No registered users and 1 guest