Digi+ Pro dead?

Raspberry Pi related support

Digi+ Pro dead?

Postby klassikmann » 06 Aug 2019, 22:28

After 2 1/2 years my combo of RPI 2B + HifiBerry Digi+ Pro seams to be dead: No more digital output!
My question: How can I dissect the cause of the problem? My working hypthesis: The Digi+ Pro is dead.

What I did up to now:
- mpd.log looks reasonable likewise a successful playing
- when starting an audio file hw_params looks reasonable
- my active speakers are working using a different input (CD transport)
- optical output of the Digi+ is dark

My goal is to become sure that the Digi+ has to be replaced.

Thanks in advance for suggestions

klassikmann

Edit: 2019-08-07
The Digi+ Pro is o.k.
I flashed another SD-Card with RuneAudio_rpi2_rp3_0.4-beta_20170229_2GB.img and Digital-Out works.

My new working hypthesis:
There must be a subtle change in the configuration of the system in my signature. The Debug-Output can be found here:
https://www.magentacloud.de/lnk/4xBpKc2w
RPI 2B + HifiBerry Digi+ Pro + RuneAudio 0.5b (build 11) + RuneUI Enhancements (not pre-installed)
klassikmann
 
Posts: 66
Joined: 27 Apr 2016, 18:36

Re: Digi+ Pro dead?

Postby klassikmann » 07 Aug 2019, 09:04

New findings in the Edit section of the original post.
RPI 2B + HifiBerry Digi+ Pro + RuneAudio 0.5b (build 11) + RuneUI Enhancements (not pre-installed)
klassikmann
 
Posts: 66
Joined: 27 Apr 2016, 18:36

Re: Digi+ Pro dead?

Postby klassikmann » 07 Aug 2019, 21:19

I gave it up to isolate the problem of the silent digital output. Not the slightest idea why the digital output stopped working from here to no now.
At last I started from scratch (RuneAudio 0.5b (build 11)), then added the RuneUI Enhancements and now I'm back in business.

klassikmann
RPI 2B + HifiBerry Digi+ Pro + RuneAudio 0.5b (build 11) + RuneUI Enhancements (not pre-installed)
klassikmann
 
Posts: 66
Joined: 27 Apr 2016, 18:36

Re: Digi+ Pro dead?

Postby eea123 » 10 Aug 2019, 08:49

I seem to recall a post on this forum about SD card failures over time as sort of a known weakness with the Raspberry PI arrangement. You might search that out directly, but I thought it was from read-write access simply exhausting the MTBF rating of the card.
eea123
 
Posts: 65
Joined: 23 Dec 2017, 19:19

Re: Digi+ Pro dead?

Postby klassikmann » 10 Aug 2019, 15:59

Hi eea123,
eea123 wrote:I seem to recall a post on this forum about SD card failures over time as sort of a known weakness with the Raspberry PI arrangement. You might search that out directly, but I thought it was from read-write access simply exhausting the MTBF rating of the card.
I just finished a fsck on a different Linux machine. The filesystem is clean. OTOH I think a hardware failure on the SD-card will result in a more disastrous effect. But nevertheless thank you for your solution proposal.

klassikmann
RPI 2B + HifiBerry Digi+ Pro + RuneAudio 0.5b (build 11) + RuneUI Enhancements (not pre-installed)
klassikmann
 
Posts: 66
Joined: 27 Apr 2016, 18:36

support RuneAudio Donate with PayPal


Return to Raspberry Pi

Who is online

Users browsing this forum: No registered users and 7 guests